Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

Running xmllint on the gml 3.1.1 schema fails, even though the release notes claim that this release was created to get the schema to validate using 'common tools'. There's questions about this on the web, but no satisfying answers.

xmllint --schema http://schemas.opengis.net/gml/3.1.1/base/gml.xsd \
        --noout foo.xml

returns something like:

element complexType: Schemas parser error : local list type: A type, derived by list or union, must have the simple ur-type definition as base type

This is not the same problem as the one described here, which was a Xerces C++ issue.

If there is some other xmllint issue here, what xml validator is known to work with GML?

I have this problem on a few different flavors of Ubuntu, CentOS, and RHEL 5.x

Update:

The 3.1.1 and 2.1.2 GML schemas validate using the following tools:

  1. The W3C XML Schema Validator
  2. Sun's msv:

    running java -jar msv.jar -warning gml\base\gml.xsd

    returned 1 warning about "anyType" in gmlBase.

  3. Using the validator bundled in eclipse worked with no errors or warnings.

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.