Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

Has anyone successfully used PostgreSQL with PostGIS successfully? I am a semi-experienced ArcGIS user and want to build out a database and connect it to ArcCatalog. I've scoured the internet for resources but nobody has really given a good walkthrough. Any help would be much appreciated!

share|improve this question
2  
Which version of ArcGIS are we talking about? –  radek Mar 3 '11 at 14:24
add comment

6 Answers

Give a look at this post on my blog: http://www.paolocorti.net/2008/06/06/spatial-database-for-postgres-and-arcgis-users-how-to-choose/

Basically you have 2 options:

  1. use PostGis with ArcSde (so you need an ArcSde license, and ArcEditor if you need to edit data)
  2. use zigGIS: http://www.obtusesoft.com/ (note that is not tested on ArcGis 10.0). You will just need an ArcView box to connect to it, even for writing data.

Note that if you need Geodatabase support (Domains, topology etc...) or ArcCatalog support, the first solution (with ArcSde) is the only way to go at this time.

As far as I have heard (I did not directly test it) on ArcGis Desktop 10 you can make a read only direct connection to PostGis without the ArcSde gateway.

share|improve this answer
3  
+1 I haven't tried it but you should be able to configure a featureservice in arcgis server using a featureclass in arcsde/postgis, then you can do simple (web) editing without an arceditor license. blogs.esri.com/Dev/blogs/arcgisserver/archive/2010/12/09/… –  Kirk Kuykendall Mar 3 '11 at 14:49
5  
<rant>I'm sorry but the fact that ArcGIS doesn't support the most common open source DB out of the box is really pathetic. How much is a ArcSde license? I can almost bet it's not cheap. </rant> –  Nathan W Mar 4 '11 at 11:44
    
+1 zigGIS was a very early beta tester with good results - sent loads of feedback and most was implemented. They switched from free-to-paid and now back to opensource. –  Mapperz Jul 26 '11 at 2:33
    
unluckily zigGIS has been discontinued: blog.geomusings.com/2011/08/03/ziggis-the-end-of-the-road –  capooti Oct 18 '11 at 16:57
add comment

I have a few posts on doing it with 9.3. The first is here and you can get to the rest of them from there: http://geobabble.wordpress.com/2008/05/28/using-arcsde-93-with-postgresql-part-1/

I've done it once with 10.0 and have had no issues. I will say that, when using PostgreSQL and PostGIS with ArcSDE, that I strongly recommend sticking to whatever versions are supported by Esri.

Bill

share|improve this answer
    
I followed Bills blog, and the esri documentation to successfully get Postgresql and PostGIS working with ArcSDE. I agree that you need to use the version supported by esri, even though they may sometimes be hard to find e.g Postgresql 8.4.1 was tricky to locate. –  Ando Mar 21 '11 at 22:34
add comment

It's been a while since this question was updated, so briefly ArcGIS 10.1 and ArcGIS 10.2 both natively support PostGreSQL and PostGIS data types. Included in the help for both versions is a walkthrough of gettting set up, and configuring tables to use the PostGIS geometry types.

share|improve this answer
add comment

First of all: You will only be able to use ArcGIS with PostgreSQL using OLE DB connections, meaning, you will only be able to read common tables and collumns (you even will be able to read the spatial collumns, but ArcGIS cannot do anything to them,

To use ArcGIS and PostgreSQL + PostGIS (meaning that you need to see spatial data), you will need ArcSDE or ZigGIS.

With both options you can query, edit and analyze data stored in PostGIS, inside ArcMap or other ESRIs tools.

ArcSDE is a middleware provided by ESRI, changing the whole workflow (of installing, configuring a geodatabse, etc) of work and ZigGIS is desktop tool (I mean, only used when ESRIs desktop tools are involved).

share|improve this answer
1  
I saw this post come through another list source recently that stated "zigGIS has officially reached its end-of-life since the next version of ArcGIS should support direct read / write interoperability with PostGIS (thereby rendering zigGIS moot)." groups.google.com/group/ziggis/browse_thread/thread/… –  RyanDalton Aug 12 '11 at 15:43
add comment

New to the scene: ST-Links pgMap. The software is freeware, and works with ArcGIS 9.3 and up.

The download has a nice PDF to document the capabilities, which include viewing, editing, etc.

As I know, many people have been using this small useful tools since last year. The tool work with PostgreSQL 8.3/8.4. Not work for PostgreSQL 9.0 yet. A new release for working with PostgreSQL 9.0 should come out very soon.

share|improve this answer
    
Mike, looking @ the documentation ST-Links seems like it may have awesome potential. Have you used it personally? Do you have any impressions of its speed and usability you can share with the community? –  RyanDalton Jul 21 '11 at 23:27
    
Actually, I'm still figuring out the install process .. I have ArcGIS 9.3 installed with a custom configuration, but I don't see pgMap 1.0 in the Extensions yet .. hopefully someone else can share their experience –  Mike T Jul 21 '11 at 23:34
1  
Please forgive the link to my own blog, but I took a look at PgMap after the announcement that zigGIS was shutting down. My observations are here: blog.geomusings.com/2011/08/09/taking-a-look-at-pgmap Given that it looks like ArcMap will not be able to directly edit spatial databases at 10.1, PgMap looks all the more compelling. –  Bill Dollins Aug 19 '11 at 11:03
add comment

Will PostgreSQL 9 work with ArcGIS 10?

For Editing Postgis ZigGIS 3.0

http://groups.google.com/group/ziggis/browse_thread/thread/8e17f4c2ac57f428?hl=en

Read Only can be done via the right ODBC Postgres Drivers and doing a direct connection in ArcCatalog

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.