Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

enter image description hereI tried to export a File Geodatabase Feature Class to a *.dbf table/shapefile, but there are no records inside. I believe there is no mistake in exporting--it is simple. The doubt is the file geodatabase format--I cannot use it as a shapefile or export it as a shapefile with intact data. Attached is the original data and the exported data.

I am using ArcGIS 10. The data are from the United States census.

I am only interested in one data column/Field from each state. Is there a fast way to open, export, or convert the geodatabase format to *.dbf?

share|improve this question
    
@StuHamilton's advice sounds wise - perhaps you can include a picture of the table - or at least enough of it to show what the columns that "go missing" look like. Also, can you include the precise steps you use when you see the rows go missing, please? –  PolyGeo Aug 4 '13 at 23:37

1 Answer 1

up vote 2 down vote accepted

Just right click on the FGDB it in arccatalog and export to feature class, shapefile .shp is an option or open the attribute table in ArcMap and the from with the attribute table export / save the data and .dbf is a valid option.

OK so I just tested and it has too many attributes for a .dbf

Maximum fields is 255 so just export it to two separate dbf or just remove the fields (Data Management > Delete Fields) you do not need. I would advise the latter.

share|improve this answer
    
Yes, I tried that, but there is nothing inside--except the first column. –  Apple Aug 4 '13 at 22:49
    
Too many fields (columns) for the dbf. See the revised answer to fix. –  user17614 Aug 5 '13 at 0:53
2  
You don't need to delete. Just turn off before export –  Brad Nesom Aug 5 '13 at 5:03
    
Thanks, Stu Hamilton. I didn't know there is a maximum. You are right. That is the problem. Thanks, @BradNesom. It works much better! –  Apple Aug 5 '13 at 6:01

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.