Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I have three municipalities with a total surface of 178 sq km. I want to analyze land cover of those municipalities using both LANDSAT images with a pixel size of 30 x 30 meters and SPOT with a pixel size 10 x 10 meters.

I have a raster of a whole county (> 1000 sq km) with land cover info derived both from LANDSAT and SPOT. When I clip the whole county raster with polygons of three municipalities, in case of clipping SPOT-based raster I get the correct surface of 178 sq km. That is the clipped raster area, the same as the surface of the three polygons/municipalities I am cutting with

If I clip the LANDSAT raster, the surface is 25% smaller, according to the attribute table! I know there should be differences because the pixel size is not the same and on the edges of the polygon I am cutting with some small discrepancies will appear. But what happened with the 25% of the surface?

I really have no clue what to do, I have done such things before, but never had such different results. Could it be something wrong with the data in the attribute table? (Even though I don't know what). Thank you in advance.

share|improve this question
1  
What projection are you working in? –  Andre Joost Aug 5 '13 at 10:37
1  
What GIS software product & version are you using? –  PolyGeo Aug 5 '13 at 10:57
    
It's WGS1984, ArcGIS 9.3. And to add more to this confusion, it seems that something else is also wrong. The three municipalities in SPOT have a surface (from attribute table) of 178701893, and the whole county has 1230022337, which I assume is in sq meters. The numbers add up with the real data, it's OK. Then I open the LANDSAT raster and the total county has 1366871 (?!!) and when I clip it with the three small municipalities, it's again 1366871. –  Miren Sanov Aug 5 '13 at 11:07

1 Answer 1

up vote 1 down vote accepted

Two suggestions.

(1) I hate to be so obvious but arcgis does not auto-expand field in the attribute table. Have you verified manually dragging the field to make it larger and see if more numbers appear?

(2) Find the exact x,y cell size (I suspect from the values your actually in UTM / WGS 1984) in raster properties and just multiply the numbers together and then multiply this number by the count in the field calculator to recalculate the area.

share|improve this answer
    
Being obvious with a clueless beginner as myself is always a good option. In the attribute table by default it gives the number of cells so in order to get the surface in SPOT I have to multiply it by 10x10, so the number is the same, it's just the zeroes which led me to the wrong trail. In Landsat I have to multiply by 30x30, so the numbers change and that is where the "error" was. Thank you very much. –  Miren Sanov Aug 5 '13 at 13:21
    
Yes you have the answer. –  user17614 Aug 5 '13 at 13:29

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.