Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When creating polygon features in ArcView 10, using the auto-complete polygon tool, I create a feature neighboring another polygon and ArcView hangs or processes for over 15 seconds. The feature is successfully created, but it takes forever. The polygon layer being edited is in a file geodatabase (although location of the feature, in or out of a gdb, being edited appears to have no bearing on the problem). I've done the Normal.mxt rename and all the tried-and-true solutions and ESRI has been of little help.

Any help would be appreciated, thanks. -Ross

share|improve this question
is your fgdb perhaps on a network drive or in a folder with many other files? – Brad Nesom Mar 5 '11 at 1:24
Also, what if you export to shapefile and then edit. Still a slug? Brad is definitely on to something with the network latency issues, have seen those ALOT. – Chad Cooper Mar 5 '11 at 3:08
up vote 1 down vote accepted

Check the tolerance of the feature class: ArcCatalog > Right-click the feature class > Properties > Tolerance. A proper value depends on the spatial reference (and the associated linear unit) and what kind of precision you require.

For almost all purposes the default tolerance chosen by ArcGIS is good enough. If the tolerance is set too low (i.e. extremely fine-grained tolerance ) this results in large amounts of extra processing when interacting with the features but not when simply drawing them. As a point of comparison: for data in geographic WGS84 the default tolerance is 0.000000008983153 decimal degrees.

The tolerance of a feature class can only be set at the time of creation. If the tolerance value is your problem, create a new feature class with the proper settings and load the features into this new feature class.

share|improve this answer
Thanks Philip; the feature is in NAD1983 UTM15N and the tolerance is set to 0.001m (or one millimeter). Too much? – Ross Mar 8 '11 at 14:33
Here's a video that shows the problem: – Ross Mar 8 '11 at 15:52
Problem solved! Philip, I think you got it. The tolerance was set 0.001m, I decreased it to 0.1m and the performance appears to have improved (for now; and of course, this was AFTER I did a clean re-install and all that). Sheesh! What a stubborn problem, thanks everyone for their help! It's much appreciated! – Ross Mar 8 '11 at 20:28

This a response from ESRI Support (USA):

There are a few known issues that cause slow performance with version 10. Large datasets can certainly slow things down. Editing over a network, or using .mxd files that were created in a previous version are also known to degrade performance.

How large are the datasets that you are working on (size of file and number of features)? Line or polygon features with huge numbers of vertices, so called Godzillas, can also be a problem for performance. These can be diced into smaller features with fewer segments to improve processing time, but in general, large datasets require more processing power.

share|improve this answer
Thanks for responses, everyone. In answer to some questions; the MXD file was created in ArcView 10, I have exported to shapefile and edited outside of the file geodatabase and it still is painfully slow, and file is local, not on a network as is the ArcView license. The feature I'm editing has about 14,000 features, is that too big (not sure how to figure out the actual file size)? Any more ideas? Thanks again in advance! – Ross Mar 7 '11 at 20:20
14,000 features is not many - though if 1 feature has many vertices those could potentially slow editing down as all coordinates are re-written. File size use windows explorer and select the .shp, .shx and .dbf – Mapperz Mar 7 '11 at 20:51
If I export to shapefile from the file geodatabase, the physical size on disk of the shapefile is about 16.6MB (thanks, Mapperz). Also, is a clean install worth it? I just installed this on my new computer about 2-3 months ago! – Ross Mar 7 '11 at 22:07

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.