Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I would like to remove the orthoimage layer from a USGS topo geoPDF map. I have Adobe Acrobat Pro 9, but can't find a way to delete a layer. I've tried setting the layer to "Never export", then exporting the pdf, but the image is still there (and in the process I have somehow deleted the geo-referencing info.)

Thanks

share|improve this question
    
Layer Properties> Default State:OFF and then disable from export, Then export with a different name. You can also delete the layer if wish so (reducing file size). –  Mapperz Aug 12 '13 at 13:34
    
When first opened, the file is locked against modification because extended features in Reader are present. It says to "Save A Copy" which deactivates extended features. I do that, then open the new file. I can now set the default state to off and Export Never. I then Export as PDF/E. I get and error that it doesn't conform to PDF/E requirements. I open the resulting file and the layer is locked off, but still present. The size of the exported file is pretty much the same as the input. I then ran Reduce File Size which generated several warnings, but did shrink the file, but the layer remains. –  Llaves Aug 12 '13 at 14:06
    
You say "You can also delete the layer". How do you do this? Is it the Reduce File Size command I mentioned above? Clicking on the layer doesn't offer and delete option, nor can I find it in the menus. –  Llaves Aug 12 '13 at 14:07
    
to unlock do this techrepublic.com/blog/windows-and-office/… –  Mapperz Aug 12 '13 at 14:09
    
delete forums.adobe.com/thread/546374 (see 22) –  Mapperz Aug 12 '13 at 14:11

3 Answers 3

up vote 3 down vote accepted

Deleting Layers in PDF files should be straightforward, unfortunately not. The user has to create another file to do this with the layer in question.

But some PDF's are locked down. This workaround breaks the security down. Windows (not tried on a Mac)

"If you try to use Adobe's PDF printer driver, it will detect that you are attempting to export a secured PDF to a fresh file and it will refuse to continue. Even third-party PDF print drivers tend to choke on such files. However, by using the XPS Document Writer, you effectively circumvent that check entirely" http://www.techrepublic.com/blog/windows-and-office/how-do-i-circumvent-pdf-editing-security/

The unwanted layers always reappear after flattening / merging / saving As, even when you hide them.

Here's what worked:

1) HIDE the layers you want to KEEP. (The layers you want to delete remain visible).

2) Select Tools > Advanced Editing > Touch-up Text Tool.

3) Hit Ctrl-A to select all visible text objects.

4) Hit Delete.

5) Select Tools > Advanced Editing > Touch-up Object Tool.

6) Hit Ctrl-A to select all visible objects.

7) Hit Delete.

8) Now, you want to "merge away" the unwanted layers, which are now empty. In the Layers pane, Click the "Options" pull-down and select "Merge Layers...".

9) Hold down CONTROL and click all the UNWANTED (empty) layers.

10) Click "Add".

11) In the right-hand pane (target layer), select the first layer that you want to KEEP. This will basically merge that layer with all the empty ones, and in effect, delete the empty layers.

12) Hit OK, and you're done. When you save the file, the layers you want to preserve are preserved, and the file size is smaller, reflecting the "deleted" layers.

http://forums.adobe.com/thread/546374

Technically not a GIS-SE question but is geo-image related.

share|improve this answer

The gdal_translate utility allows you to exclude layers from the output file but the layers copied to the new geopdf file seem to be combined into one image. If there are options that will avoid that and keep the separate layers perhaps someone with more knowledge will post it here.

share|improve this answer
    
If you want separate layers in the PDF, you have to add them to a single base layer explicitely with -co EXTRA_RASTERS. See gdal.org/frmt_pdf.html and latuviitta.org/documents/… –  AndreJ Nov 7 at 19:04

I'm using GDAL 1.11.0 to convert USGS GeoPDFs to GeoTiffs. Using gdal_translate I'm able to remove some of the GeoPDF layers such as "Map_Collar" but for some GeoPDFs the "Image" layer apparently cannot be removed. This appears to be the results of processing older GeoPDFs (as noted at GDAL Conversion of US Topo GeoPDFs).

The command that I'm using looks something like this:

gdal_translate.exe -of GTiff -co "TILED=YES" -co "TFW=YES" Inputfile.pdf Outputfile.tif --config GDAL_PDF_LAYERS_OFF "Map_Collar","Map_Frame.Projection_and_Grids","Images" --config GDAL_PDF_DPI 300

share|improve this answer
    
Hi Bob, Welcome to GIS.SE. Is this an answer or a question? If you are asking a question, please create your own: gis.stackexchange.com/tour –  GISKid Jul 28 at 17:02
    
Hello, originally it was a question but I noted someone else asking the same so my intention here is more of a comment. If I can clarify something please let me know, thanks. –  Bob N Jul 28 at 17:24
    
If none of the above solutions worked for you, feel free to create your own question and reference this one with a link. It will get better responses that way :) –  GISKid Jul 28 at 17:43
    
OK, thanks for the suggestion. –  Bob N Jul 28 at 17:46

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.