Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I am trying to install Quantum GIS 1.6.0 from source on Ubuntu 10.10 64-bit OS. I have GRASS GIS 6.4.1svn installed on the machine. When I run 'make' I get the following error:

[ 34%] Built target qgis_analysis
Linking CXX executable qgis
/usr/bin/ld: warning: libnetcdf.so.4, needed by /usr/local/lib/libgdal.so, not found (try using -rpath or -rpath-link)
/usr/local/lib/libgdal.so: undefined reference to `nc_inq_vartype'
/usr/local/lib/libgdal.so: undefined reference to `nc_put_att_double'
/usr/local/lib/libgdal.so: undefined reference to `nc_strerror'
/usr/local/lib/libgdal.so: undefined reference to `nc_get_vara_uchar'
.
.
.
.
/usr/local/lib/libgdal.so: undefined reference to `nc_inq_varname'
/usr/local/lib/libgdal.so: undefined reference to `nc_open'
collect2: ld returned 1 exit status
make[2]: *** [src/app/qgis] Error 1
make[1]: *** [src/app/CMakeFiles/qgis.dir/all] Error 2
make: *** [all] Error 2

I am not able to solve it. Tried installing libnetcdf-dev and libnetcdf6 packages but it was of no help!

share|improve this question
add comment

1 Answer

up vote 0 down vote accepted

The first thing to check is that you actually have a file called libnetcdf.so.4. http://www.rpmfind.net/linux/rpm2html/search.php?query=libnetcdf.so.4 suggests some places to download it from if you don't have it. The next step is to make sure the linker (ld) can find the shared library, either use -L/path/to/lib with the compiler or modify the LD_LIBRARY_PATH environment variable.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.