Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I have just recently downloaded QGIS version 1.9.90-Alpha, Alpha, 5155176. I then went to install the OpenLayers plugin. That successfully downloaded and installed, or so I thought, but when I went to use it I get an error message. It says the TypeError is: 'sip.methoddescriptor' object is not callable

Does anyone know what this means or how I can fix it? I am using Python version 2.5.2 Thanks!

This is the error:

An error has occured while executing Python code:
Traceback (most recent call last):
  File "C:/Users/czuck/.qgis/python/plugins\openlayers_plugin\openlayers_plugin.py", line 48, in addLayer
    self.__plugin.addLayer(self)
  File "C:/Users/czuck/.qgis/python/plugins\openlayers_plugin\openlayers_plugin.py", line 197, in addLayer
    QgsMapLayerRegistry.instance().addMapLayers([layer])
TypeError: 'sip.methoddescriptor' object is not callable

Python version: 2.5.2 (r252:60911, Feb 21 2008, 13:11:45) [MSC v.1310 32 bit (Intel)]

QGIS version: 1.9.90-Alpha Alpha, 5155176

Python path:

['C:/OSGeo4W/apps/qgis-dev/./python', 'C:/Users/czuck/.qgis/python', 'C:/Users/czuck/.qgis/python/plugins', 'C:/OSGeo4W/apps/qgis-dev/./python/plugins', 'C:\\OSGeo4W\\bin\\python25.zip', 'C:\\OSGeo4W\\apps\\Python25\\DLLs', 'C:\\OSGeo4W\\apps\\Python25\\lib', 'C:\\OSGeo4W\\apps\\Python25\\lib\\plat-win', 'C:\\OSGeo4W\\apps\\Python25\\lib\\lib-tk', 'C:\\OSGeo4W\\apps\\qgis-dev\\bin', 'C:\\OSGeo4W\\apps\\Python25', 'C:\\OSGeo4W\\apps\\Python25\\lib\\site-packages', 'C:\\OSGeo4W\\apps\\qgis-dev\\python\\plugins\\fTools\\tools']

share|improve this question
    
Where did you get the open layers plugin from? –  Nathan W Aug 19 '13 at 21:25
    
Through the fetch Python plugins within Quantum...I think the repositories are set to sourcepole and QGIS. –  CZuck Aug 20 '13 at 12:54

4 Answers 4

There is an unofficial version of the OpenLayers plug-in (for Master) here:

http://www.qgis.nl/2013/06/30/english-temporary-fix-for-openlayers-plugin/?lang=en

It works on my system (QGIS Master/Ubuntu 12.04).

N.

share|improve this answer
    
Thanks! I'll try that! :) –  CZuck Aug 27 '13 at 12:38
up vote 1 down vote accepted

I waited for the update to 2.0, and the OpenLayers plugin now works with 2.0! I would suggest to anyone having a similar issue that I had, just upgrade.

share|improve this answer
1  
Agreed. Please "accept" your answer and close out this thread. –  RyanDalton Sep 25 '13 at 19:40

I believe that the API for QGIS 2.0 has changed and therefore the plugins that worked for 1.8 will not work in 2.0. I don't know what the status for openlayers is for the QGIS 2.0 release but you can read some of the discussion here.

share|improve this answer
    
I had found another thread later the next day talking about that, didn't realize it was broken for earlier versions right now! Thanks for letting me know, though! :) –  CZuck Aug 27 '13 at 12:38

Any update on this as I get the error below with QGIS 2.01 and Python 2.7.5 running on OS X 10.9 (although the maps render ok). Every time I highlight the layer the same error message displays.

History: I had the previous version of QGIS 1.8 and Python 2.6.8 on Snow Leopard. Upgrading to OS X 10.9 didn't cause any issues. I then removed the QGIS 1.8 package from Applications, emptied trash, installed ALL frameworks packages from kyngchaos.com, then finally installed QGIS 2.01. I downloaded a 'fixed' version of openlayers plugin from http://www.qgis.nl/2013/06/30/english-temporary-fix-for-openlayers-plugin/?lang=en and installed to the /Users/'my username'/.qgis/python/plugins. This still doesn't resolve the issue.

Should I perform a clean uninstall of ALL the frameworks and QGIS then start from scratch. If so, what is the best method to remove these frameworks cleanly?

An error has occured while executing Python code:

Traceback (most recent call last): File "/Users/jeremylittman/.qgis2/python/plugins/GoogleMapsEngineConnector/googlemapsengineconnector.py", line 266, in handleSelectionChange gmeMap, gmeLayers = self.getAssetsFromLayer(currentLayer) File "/Users/jeremylittman/.qgis2/python/plugins/GoogleMapsEngineConnector/googlemapsengineconnector.py", line 311, in getAssetsFromLayer if self.isGmeConnectorLayer(layer): File "/Users/jeremylittman/.qgis2/python/plugins/GoogleMapsEngineConnector/googlemapsengineconnector.py", line 294, in isGmeConnectorLayer provider = layer.dataProvider() AttributeError: 'OpenlayersLayer' object has no attribute 'dataProvider'

Python version: 2.7.5 (default, Aug 25 2013, 00:04:04) [GCC 4.2.1 Compatible Apple LLVM 5.0 (clang-500.0.68)]

QGIS version: 2.0.1-Dufour Dufour, f738351

Python path: ['/Users/jeremylittman/.qgis2/python/plugins/processing', '/Users/jeremylittman/.qgis2/python/plugins/GeoCoding', '/Applications/QGIS.app/Contents/MacOS/../Resources/python', '/Users/jeremylittman/.qgis2/python', '/Users/jeremylittman/.qgis2/python/plugins', '/Applications/QGIS.app/Contents/MacOS/../Resources/python/plugins', '/Library/Frameworks/SQLite3.framework/Versions/B/Python/2.7', '/Library/Frameworks/GEOS.framework/Versions/3/Python/2.7', '/Library/Frameworks/GDAL.framework/Versions/1.10/Python/2.7/site-packages', '/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python27.zip', '/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7', '/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/plat-darwin', '/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/plat-mac', '/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/plat-mac/lib-scriptpackages', '/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python', '/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/lib-tk', '/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/lib-old', '/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/lib-dynload', '/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/PyObjC', '/Library/Python/2.7/site-packages', '/Users/jeremylittman/.qgis2/python/plugins/mmqgis/forms', '/Users/jeremylittman/.qgis2/python/plugins/QuickMultiAttributeEdit/forms', '/Applications/QGIS.app/Contents/Resources/python/plugins/fTools/tools', '/Users/jeremylittman/Dropbox/01 Engenie Work/00 Site Selection/Mapping & GIS/QGIS Projects']

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.