Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I wish to display a map in QGIS (world country shapefiles) showing all countries but centered on the Pacific area. I am not familiar with Proj4, so is there any way this can be done in QGIS please?

share|improve this question
    
After many troubles, I found out it is better to use Nr;WKT 1;POLYGON ((30.01 90, 29.99 90, 29.99 -90, 30.01 -90, 30.01 90)) Diederik –  user26658 Feb 6 at 19:10

2 Answers 2

Well, not that easy, as QGIS does not come with predefined Robinson or Miller projections.

So I tried a Custom CRS and got this picture (not in first run!):

enter image description here

For a central meridian at 150° West, it is necessary to split the world boundaries shapefile at 30° East (to be precise, at 29.9 and 30.1 to avoid intersections)

So these are the steps:

  • Download Natural Earth world boundaries shapefile and load it into QGIS
  • Save As ... into WGS84, and add that to the canvas
  • Delete the first layer
  • Disable On-the-fly-projection
  • Create the following text file:

Nr;WKT

1;POLYGON ((30.1 89, 29.9 89, 29.9 -89, 30.1 -89, 30.1 89))

  • Add that file as Text delimited layer, using semicolon as separator and WGS84 as CRS
  • Save the layer as shapefile, add it to the canvas and delete the text layer
  • Use Vector -> Geoprocessing -> Difference with the two polygon layers
  • Create a Custom CRS named Robinson with this proj string:

+proj=robin +lon_0=-150 +x_0=0 +y_0=0 +ellps=WGS84 +datum=WGS84 +units=m +no_defs

  • Enable On-the-fly projection and choose Robinson as project CRS

For the Miller projection, you can use the same pre-cut shapefile. In Proj, Miller has some problems with the ellipsoid, so we take a sphere instead (you won't see a difference):

+proj=mill +lon_0=-150 +lat_0=0 +R=6371000 +units=m +no_defs

With on-the fly activated, it does not look as well, New Zealand is missing at full extent, but returns when zooming in. So we need to Save As ... the shapefile in miller projection, and show only that, without on-the-fly reprojection:

enter image description here

share|improve this answer
    
+1 An excellent tutorial. –  Aaron Dec 1 '13 at 17:43

QGIS comes ready supplied with everything you need (i.e. it handles Proj4 for you under the hood). If your data are already in the projection you want, then right-click the layer and choose "Set Project CRS from Layer". This will put the data view into the same projection as your data. You will probably have to also right-click your layer and choose "Zoom to Layer Extent".

If your data are in some other projection, you can either reproject on the fly (in project properties) or reproject the data itself by right-clicking your layer and choosing "Save as". When the save dialog box opens, select the CRS for the output dataset and then use the new reprojected dataset.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.