Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I am using Qgis 1.9 on Ubuntu 13.04, Sextante is a core part of qgis now. I am trying to access the SAGA 2.1 libraries through qgis and I keep getting a popup window that says SAGA is not installed. I can run SAGA and it works. Normally, I would go into the sextante configuration menu and make sure sextante is looking the right directory (/usr/lib/saga) However, that part of the configuration menu is gone.

I went to the qgis options and checked the environment variables and I do not see one for saga, nor is it listed in the PATH variable. I tried adding in a SAGA path variable with no luck. Does anyone here know how to update or add a system variable to qgis 1.9 alpha so that qgis will know where saga is? The end goal will be the ability to have sextante properly access the saga libraries. Many of my Sextante modeller scripts rely HEAVILY on those libraries. I love qgis 1.9 and would hate to have to go back to 1.8 if i do not have to.

Thanks

EDIT: I was able to install the nightly version of 1.9 alpha on my windows work terminal using the OSGeo4w installer. I went into the advanced install options and made sure I installed SAGA (2.0.8.3) at the same time. Same problem seems to be happening. Everything seems to be working just fine when. Based on these findings I purged everything off of my Ubuntu laptop and tried again ( this time installing SAGA first). Still my problem persist.

EDIT 2:

I installed the official release of Qgis 2.0.1 from the Ubuntugis unstable PPA today. In this instillation some of the dependencies are dated and can not be used with SAGA gis 2.1. Here is the error message containing the offending package names.

Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation:

The following packages have unmet dependencies:
 saga : Depends: libgdal1 (>= 1.8.0) but it is not going to be installed
        Depends: liblas1 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

The version of Libgdal1 that gets installed with qgis is 1.7.4 ( something less then 1.8 ) when I try to update these dependencies, it removes half of the dependencies used by qgis effectively removing it.

share|improve this question
    
upgrade to QGIS 2.0, it solves the bug. –  Serge Sep 18 '13 at 20:23
    
This does not provide an answer to the question. To critique or request clarification from an author, leave a comment below their post - you can always comment on your own posts, and once you have sufficient reputation you will be able to comment on any post. –  SS_Rebelious Sep 18 '13 at 21:24
    
I think this would be fine as an answer if you had explained the precise bug that was resolved at QGIS 2.0 e.g. include links to a URL describing it and perhaps another link to where QGIS 2.0 could be downloaded. –  PolyGeo Sep 18 '13 at 22:33
    
@serge OP here, I have upgraded to the official release of Qgis 2.0.1 from the ubuntugis unstable ppa. This does not solve the problem. If fact it has cause a whole new problem. The installation of qgis through ubuntugis removed one of the dependencies needed for saga 2.1. –  G.Oxsen Sep 19 '13 at 1:49
add comment

1 Answer 1

up vote 0 down vote accepted

I found a solution that will work for this issue, please go here if you are having the a similar issue

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.