I am using Qgis 1.9 on Ubuntu 13.04, Sextante is a core part of qgis now. I am trying to access the SAGA 2.1 libraries through qgis and I keep getting a popup window that says SAGA is not installed. I can run SAGA and it works. Normally, I would go into the sextante configuration menu and make sure sextante is looking the right directory (/usr/lib/saga) However, that part of the configuration menu is gone.
I went to the qgis options and checked the environment variables and I do not see one for saga, nor is it listed in the PATH variable. I tried adding in a SAGA path variable with no luck. Does anyone here know how to update or add a system variable to qgis 1.9 alpha so that qgis will know where saga is? The end goal will be the ability to have sextante properly access the saga libraries. Many of my Sextante modeller scripts rely HEAVILY on those libraries. I love qgis 1.9 and would hate to have to go back to 1.8 if i do not have to.
EDIT: I was able to install the nightly version of 1.9 alpha on my windows work terminal using the OSGeo4w installer. I went into the advanced install options and made sure I installed SAGA (188.8.131.52) at the same time. Same problem seems to be happening. Everything seems to be working just fine when. Based on these findings I purged everything off of my Ubuntu laptop and tried again ( this time installing SAGA first). Still my problem persist.
I installed the official release of Qgis 2.0.1 from the Ubuntugis unstable PPA today. In this instillation some of the dependencies are dated and can not be used with SAGA gis 2.1. Here is the error message containing the offending package names.
Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation:
The following packages have unmet dependencies: saga : Depends: libgdal1 (>= 1.8.0) but it is not going to be installed Depends: liblas1 but it is not going to be installed E: Unable to correct problems, you have held broken packages.
The version of
Libgdal1 that gets installed with qgis is 1.7.4 ( something less then 1.8 ) when I try to update these dependencies, it removes half of the dependencies used by qgis effectively removing it.