Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

Linux noob here. I keep getting "Unable to create repository" when trying to add the repo url on the qgis download page to YaST: http://download.opensuse.org/repositories/Application:/Geo/<version>/

I've tried replacing <version> with a few things with no luck:

  • 1.8
  • 1.8.0
  • 12.3
  • qgis-1.8
  • qgis-1.8.0

My search has not come up with any similar cases so far. Anyone know a working repo for installing qgis on openSUSE 12.3?

share|improve this question
1  
if you open download.opensuse.org/repositories/Application:/Geo it seems to be looking for something like openSUSE_12.3 (or other versions). –  iant Sep 5 '13 at 9:44

1 Answer 1

up vote 0 down vote accepted

openSUSE_12.3 would be the correct version string. You can enter the url

http://download.opensuse.org/repositories/Application:/Geo/

in a browser to see what choice is offered.

But you will have no luck in installing QGIS 1.8.0, as there is a dependency bug in the current rpm. RuntimeError: the sip module implements API v9.0 to v9.1 but the qgis.core module requires API v9.2

At least that's what I got with Opensuse 12.3 yesterday.

With QGIS 2.0 being released soon, there will be not much hope of getting the old rpm repaired.

share|improve this answer
    
After correcting the repo URL, I was able to run the 1.8 install without issue. I haven't done anything indepth yet, but I was able to open QGIS and install a couple plugins. –  msayler Sep 12 '13 at 21:25

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.