Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I am using Qgis 1.9 .Just now I downloaded a plugin "mm qgis"But When I run this plugin I am getting following error: An error has occured while executing Python code:

Traceback (most recent call last): File "C:\Documents and Settings\15491/.qgis2/python/plugins\mmqgis\mmqgis_dialogs.py", line 525, in run message = mmqgis_geometry_convert(self.iface, layername, newtype, splitnodes, savename, 1) File "C:\Documents and Settings\15491/.qgis2/python/plugins\mmqgis\mmqgis_library.py", line 1154, in mmqgis_geometry_convert layer.dataProvider().select(layer.dataProvider().attributeIndexes()) AttributeError: 'QgsVectorDataProvider' object has no attribute 'select'

Python version: 2.7.2 (default, Jun 12 2011, 15:08:59) [MSC v.1500 32 bit (Intel)]

QGIS version: 1.9.0-Master Master, 1a723b4

Python path: ['C:\Documents and Settings\15491/.qgis2/python/plugins\sextante_taudem', 'C:\Documents and Settings\15491/.qgis2/python/plugins\sextante_animove', 'C:\Documents and Settings\15491/.qgis2/python/plugins\sextantelwgeomprovider', 'C:\Documents and Settings\15491/.qgis2/python/plugins\sextanteexampleprovider', 'C:\Documents and Settings\15491/.qgis2/python/plugins\sextante', 'C:\Documents and Settings\15491/.qgis2/python/plugins\permaclim', 'C:/OSGeo4W/apps/qgis-dev/./python', 'C:\Documents and Settings\15491/.qgis2/python', 'C:\Documents and Settings\15491/.qgis2/python/plugins', 'C:/OSGeo4W/apps/qgis-dev/./python/plugins', 'C:\OSGeo4W\bin\python27.zip', 'C:\OSGeo4W\apps\Python27\DLLs', 'C:\OSGeo4W\apps\Python27\lib', 'C:\OSGeo4W\apps\Python27\lib\plat-win', 'C:\OSGeo4W\apps\Python27\lib\lib-tk', 'C:\OSGeo4W\bin', 'C:\OSGeo4W\apps\Python27', 'C:\OSGeo4W\apps\Python27\lib\site-packages', 'C:\OSGeo4W\apps\Python27\lib\site-packages\PIL', 'C:\OSGeo4W\apps\Python27\lib\site-packages\win32', 'C:\OSGeo4W\apps\Python27\lib\site-packages\win32\lib', 'C:\OSGeo4W\apps\Python27\lib\site-packages\Pythonwin', 'C:\OSGeo4W\apps\Python27\lib\site-packages\wx-2.8-msw-unicode', 'C:\Documents and Settings\15491\.qgis2\python\plugins\mmqgis/forms', 'C:\OSGeo4W\apps\qgis-dev\python\plugins\fTools\tools', 'C:\Documents and Settings\15491\.qgis2\python\plugins\pdokbaggeocoder/forms'] what is the mistake?

share|improve this question

1 Answer 1

up vote 1 down vote accepted

That version of QGIS is very old. The version of the plugin you have wasn't migrated to the new API.

  1. Download the latest QGIS version
  2. Install plugins via the plugin manger
share|improve this answer
    
can u suggest me the correct website to download the latest version? –  Arun Sep 7 '13 at 5:12
    
the plugin is maintained here - plugins.qgis.org/plugins/mmqgis –  Mark Sep 25 '13 at 11:33

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.