Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

In my previous question I've asked how to can I merge different polygons while converting to GeoJSON and TopoJSON.

After a day of researching I've realized that, rather trying to do it command line, I should use some editor which can handle Shapefile data. So, I've choose QGIS.

I've toggled to edit mode, chose all areas needed and called "merge selected features". After the merge I'm getting something like this: enter image description here

I'm expecting to get all countries in Africa joined into one region. But, as you can see, I'm getting some dangling paths. My question is - what I'm doing wrong, how I can avoid such dangling paths or get rid of them after the merge? Since selecting all this nodes via "Node tool" does not help much.

share|improve this question

2 Answers 2

up vote 0 down vote accepted

I'm not very familiar with QGIS but you can do what you need to do with ThinkGeo's GIS Editor program which has a free trial.

There are a couple different ways to accomplish your task but what I found to be the easiest is to load your shapefile, go to the Edit tab, Select your layer as the one to edit and then select all the features you want to join together. You can do this by using the Select tool and clicking and dragging to select many countries if not all the countries in Africa. Once they are selected hit the Union button on the tool bar under the shape operations section and all of the features will be joined together without dangling paths.

This will union all the features together and you can modify the attribute data if you like. If you didn't get all the countries selected on the first try just go ahead and save your edits and repeat the process until you have all the countries you want in your region.

Let me know if this works for you.

Thanks!

enter image description here

share|improve this answer
    
Thank's, at least now I know there is a bug in QGIS (at least in MacOS version) –  shabunc Sep 11 '13 at 5:13

After running into the same problem myself, I figured out how to fix it in QGIS.

The key bit of information is that those "paths" or "lines" that you think you see are ACTUALLY, in all likelihood, sliver polygons. Go into editing mode, zoom way in, and you'll probably notice that some of the nodes on your little "lines" are marked with brighter red X's than the others. This is because several notes are stacked on top of each other.

Here's how to fix:

  1. Turn on your node editing tool and select one of the brighter red X's so that it turns blue.
  2. Drag that node away from the line. You will probably see that you now have created a small blank polygon. It's not a feature -- it's a tiny ring in the middle of your real polygon.
  3. Select the "Delete Ring" tool from the Advanced Digitizing toolbar.
  4. Click on your empty polygon. Presto! It's gone! Very satisfying.
  5. Repeat for all your dangles.
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.