Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I am Digitizing road line in India using open layer plugin.When I calculate the length of line using field calculator it gives me the result in millimeter . I thought it is the projection problem and defined the projection as wgs 84 UTM 44N . The same problem exixts . but when I measure the line using measure line tool it gives the result in meters . What is the problem? I want the result to be in meters in field calculator itself.

share|improve this question
    
This seems to me more as an issue of measurement unit configuration rather than a projection system problem. –  Ardit Sulce Sep 20 '13 at 13:52
add comment

1 Answer 1

up vote 1 down vote accepted

You should look at what part of the system is calculating the length. If the layer / shapefile is producing the data, then it should be a UTM metres projection. If you are using the measure tool, the canvas CRS needs to be UTM metres projection.

EDIT

Doing some work with 2.01 now, it seems there is a problem with field calculator and $length. There is not the same problem in 2.10

But I can't reproduce it with a blank shapefile....

share|improve this answer
    
For me the shape file only is calculating the length how to define the utm meter projection? –  Arun Sep 17 '13 at 6:11
1  
SAVE AS the shapefile, in that dialog, choose to use a specific projection. So WGS84 UTM44N EPSG:32644 should be metres. spatialreference.org/ref/epsg/32644 –  Willy Sep 17 '13 at 10:36
    
So what base information are you working from? I suspect that is the problem. Was the primary data imported somehow? –  Willy Sep 17 '13 at 10:37
    
I tried as u said @Willy still I am getting in meters only so wat is the problem could be? –  Arun Sep 17 '13 at 11:14
    
So you are referring the shapefile to some other data. Is the other data properly referenced? You could compare all your data to what might be displayed by the Openlayers Plugin. Install that and see if the data is "real world" Also check to make sure that QGIS has On The Fly OTF projection turned on, it is accessed by an icon in the bottom right of the screen and will bring up a detailed dialog, on the top right of the dialog is a checkbox for OTF. –  Willy Sep 17 '13 at 11:35
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.