Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I've just unclicked the export map options (advanced options?) and can't get them back. I'd assumed you'd be given the choice of displaying them again, but they are nowhere to be seen. I now can't choose what file type or resolution to use, which is a huge pain.

http://forums.arcgis.com/threads/42377-Export-map-no-options-for-details-filename..

Of the options above, I've tried deleting normal.mxt, with no luck. There's no 'ExportDlg' folder, so I don't have that option.

I'm going crazy with this. I've Arc 10.1 running on Windows 8. Any workaround / solution would be hugely appreciated. I wont have the time to uninstall.

Here's a screenshot: enter image description here

share|improve this question

2 Answers 2

up vote 1 down vote accepted

I like the python exporting by @Sarah but the options panel should be available for you regardless.

Since you cannot find the 'ExportDlg' folder in your registry, close ArcMap and try renaming the whole 'Export' folder to 'Export_old' in the registry. When ArcMap is restarted it should recreate the folder as well as its subfolder 'ExportDlg.'

HKEY_CURRENT_USER\Software\ESRI\Desktop10.1\Export

share|improve this answer
    
There's no export folder in my Desktop 10.1 folder. I have no idea if it was ever there, but I haven't removed it myself. –  Joules Sep 18 '13 at 16:03
    
I've shut down arc and re-opened it - still no folder. –  Joules Sep 18 '13 at 16:15
    
If that is the case, I would suggest renaming the whole ESRI folder. Keep in mind that you should back up your registry first. Know that your folder and database connections, as well as any toolbar/layout customizations will also be reset. You will only be renaming the folder (rename to ESRI_old) not deleting it so you can revert back if need be. Hopefully this will create the Export key for you when you restart ArcMap. HKEY_CURRENT_USER\Software\ESRI –  amarinel Sep 18 '13 at 17:59
    
I have no idea how to back up my registry, and I have too many folders/database connections to risk projects which I'm currently working on. Thanks for your help though. –  Joules Sep 18 '13 at 18:06
1  
I was incorrect in my last comment...renaming the ESRI folder in the registry DOES NOT reset/remove folder/database connections. I just ran a test to prove this (the connections are reset if you rename the esri folder in %AppData% folder...which you are not doing at this point). Backing up registry is simple. You can always delete the new ESRI folder that is created and rename the one you changed back to original. –  amarinel Sep 18 '13 at 18:29

Have you tried exporting them using the python window as a work around? You could export maps using arcpy.

This website shows how to set up the document for export: http://help.arcgis.com/en/arcgisdesktop/10.0/help/index.html#//00s30000006w000000

While this one goes into more detail about the specifications you can set:

http://resources.arcgis.com/en/help/main/10.1/index.html#//00sm00000004000000

This allows you to specify the size and type of file that you want to export.

share|improve this answer
    
I don't know any python at all. I might try it if I don't find any other solution, but would much rather get my export function up and running again. –  Joules Sep 18 '13 at 16:05
1  
In this case the python is really simple. You only need to open the python window and type: mxd = arcpy.mapping.MapDocument("CURRENT") Then the next line is where you actually export the map, this is an example using PDF, but other options are available arcpy.mapping.ExportToPDF(mxd, r"C:\Users\HSRG1\Desktop\GlobalET\name.pdf", df_export_height = 100, df_export_width = 100, resolution = 96) Change the values for the height, width, resolution and location –  Sarah Sep 18 '13 at 16:38
    
Thanks Sarah - will give it a go. Pretty bad on ESRI's part though - it's the kind of thing that shouldn't really happen. –  Joules Sep 18 '13 at 16:41

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.