Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I'm trying to upgrade to the newest version of qGIS but get the following error message when I open the installer:

QGIS requires the GEOS framework version 3.4 or newer.

I've had no luck maintaining my version of geos via the geos download page, and have instead installed it via homebrew. Is it possible to tell qGIS where the homebrew maintained version of GEOS lives?

I would maintain osgeo via http://trac.osgeo.org/geos/ but keep getting error messages when I run the newest installer (3.4.2) and all advice I've found elsewhere on debugging the installer suggest that I shouldn't bother messing around w/ all the dependencies and should instead use homebrew.

So this brings me back to where I started: is it possible to have homebrew maintain a version of osgeo that qgis can continue to locate? Or, am I forced to keep trying to debug the geos installer?

share|improve this question
2  
What OS are you on? –  Nathan W Sep 22 '13 at 22:31
    
@NathanW: "homebrew" suggests macos. –  BradHards Sep 23 '13 at 2:58
    
I'm running 10.8.5 –  James Conkling Sep 23 '13 at 15:55
    
@James: Have you found an answer to this? I am running into the same issue. –  Morgan Herlocker Dec 17 '13 at 20:12
    
@MorganHerlocker: fixed it by uninstalling everything and reinstalling via kyngchaos. Essentially, forced me to take more care of how I maintain my dependencies by building again from the ground up. Homebrew has it's place, but it's a bad way to maintain qGIS dependencies. –  James Conkling Dec 19 '13 at 4:28

1 Answer 1

up vote 1 down vote accepted

The easiest way to upgrade is to use the binaries at http://www.kyngchaos.com/software/qgis

share|improve this answer
    
I have all the binaries that are maintained by kyngchaos (just reinstalled them to be sure). It's GEOS framework that the qGIS installer tells me I don't have, and when intalling from the GEOS site installer, I get the following error message ld: symbol(s) not found for architecture x86_64 collect2: ld returned 1 exit status make[3]: *** [libgeos.la] Error 1 make[2]: *** [all-recursive] Error 1 make[1]: *** [all-recursive] Error 1 make: *** [all] Error 2 Since I have successfully downloaded geos via homebrew, I was hoping I might be able to move the hb-version to wherever qgis looks for it –  James Conkling Sep 25 '13 at 20:35
    
perhaps a bad idea, perhaps not. i'm still trying to figure out best practices when it comes to maintaining packages for GIS apps. –  James Conkling Sep 25 '13 at 20:38

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.