Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

When I try and save the resource I get: Spatial context extent appears to be invalid (or Default).

The XML:

<?xml version="1.0"?>

OSGeo.Gdal.3.4 Default This coordinate system has been overridden. LOCAL_CS["XY-MT",LOCAL_DATUM["X-Y",10000],UNIT["Meter", 1],AXIS["X",EAST],AXIS["Y",NORTH]] LOCAL_CS["XY-MT",LOCAL_DATUM["X-Y",10000],UNIT["Meter", 1],AXIS["X",EAST],AXIS["Y",NORTH]] Dynamic -10000000 -10000000 10000000 10000000 0.001 0.001

#

These sids are 205mb a piece and theirs 53 of them (sat images). I decoded them to geotiff and they came out 2+gig ea.

What do I need to do to get these to display in MG? Whats the smartest method to get them web ready?

share|improve this question
    
How do you tell if your sids are G3 or G2? –  Zap Rowsdower Mar 16 '11 at 18:52
    
Grab the MrSID GeoInfo tool from here: lizardtech.com/downloads/tools.php - it will tell you if it's MG2 or MG3 encoding. –  mwalker Mar 16 '11 at 19:11
    
Seems I dont have the GDAL plugin dll's and the MrSID dll's in my MG install dirs. Loading the resource went off without a bark though... odd. dlin the lizard tech tool.. Has anyone here got the g3 sids to work on MG 2.1 GDAL 1.6 3.4? –  Zap Rowsdower Mar 16 '11 at 19:16
add comment

2 Answers 2

I'm guessing you're authoring this through Maestro right?

I've gotten this error too. Here's how i fixed it:

I dont remember why, but Gdal 1.6 didn't do it for me, i had to upgrade to the latest stable version of 1.8 (may work with 1.7, but why use older one?). You can probably compile this yourself or get FWTools, which may have the latest version of Gdal.

Then after you've loaded it the mrsid file (i do it from alias directory in mapguide) from Maestro:

  • click the “Edit configuration document” button on the bottom right,
  • scroll to the bottom of the xml document and find the tags MinX MinY MaxX MaxY. You would probably see the messed up extents (something like 1000000)
  • Enter the actual extents of the sid file (you can find this with any other tool like gdalinfo, arcview, and im sure anything from lizardtech)
  • Save that and you should be done

Let me know how it goes. This worked for me... Good luck!

share|improve this answer
    
Theirs 53 of them. Im going to have to put all the values for each? –  Zap Rowsdower Mar 21 '11 at 13:42
    
yea, i had to do that with each of my sid layer.. if they're all the same extent, copy and paste will be your friend. of course, make sure this solution actually works for one of the sid layers first before you fix them all i guess. oh, and my images are mg3 too. –  janechii Mar 21 '11 at 16:07
    
Their a composite of Orthophotos (sat img's). 205mb a piece and 2 gig decoded. Where can I get the right values and where should I plug them it? Theirs like 53 of them. –  Zap Rowsdower Mar 23 '11 at 14:08
    
what about these values: <gml:boundingBox> <gml:pos>-10000000 -10000000</gml:pos> <gml:pos>10000000 10000000</gml:pos> </gml:boundingBox> –  Zap Rowsdower Mar 24 '11 at 14:21
    
Also in arcView should I use the Display extent or the layer extent? –  Zap Rowsdower Mar 24 '11 at 14:41
show 1 more comment

http://trac.osgeo.org/mapguide/wiki/MGOS21GdalProvider This looks promising..

share|improve this answer
    
Still can see any sid. help –  Zap Rowsdower Mar 16 '11 at 20:04
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.