Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I've just tried to install the latest version of QGIS on Linux Mint 15 Mate using 'sudo apt-get update' and 'sudo apt-get install qgis'. However, QGIS gives me the error message 'Couldn't load PyQGIS. Python support will be disabled.'. Also, the installed QGIS version turns out to be 1.7.5 while I would prefer 1.8.0 or even 2.0.

I am pretty new to the world of Linux in general, so any advice how to get the latest QGIS version including a working Python plugin would be highly appreciated.

Best regards, T.

share|improve this question
    
You used very old sources if it wants you to install 1.7.5. You need to edit your sources.list file to download a more recent qgis version. Google it and take sources here download.qgis.org. GIS stackexchange is not a helping site how to use Linux –  Curlew Oct 20 '13 at 13:41
    
You're obviously right. By now, I apparently solved the problem doing this (just in case someone will stumble across this thread in the future): 1. Run 'sudo apt-add-repository ppa:ubuntugis/ubuntugis-unstable'. 2. Run 'sudo apt-get update'. 3. Run 'sudo apt-get install qgis'. 4. Run 'sudo chown username ./.qgis2'. 5. Enjoy QGIS 2.0 without any errors (so far). –  T. K. Oct 20 '13 at 13:48

1 Answer 1

up vote 4 down vote accepted

I think the best option if you want to work with several GIS applications and a Ubuntu-based system is the UbuntuGIS repository. Adding it to your sources is very easy, just enter this commands in the terminal, one at a time.

sudo add-apt-repository ppa:ubuntugis/ubuntugis-unstable
sudo apt-get update
sudo apt-get install qgis

After that you will have QGIS 2.0 installed in your system. There are some plugins available like the grass one wich is very useful for GRASS integration. In my case, I had an error running QGIS without root privileges, which I solved giving permissions to the QGIS folder:

(In the /home/user folder)

sudo chmod -R +rwx .qgis2

After that it should run fine just from the application menu.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.