Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I am so lost and confused. I have spent days on this and not had any luck, so I'm really hoping someone can help!

I am a new opensource user with an Ubuntu 13.04 OS. I used the software GUI (Ubuntu Software Center - it came with the OS) to install QGIS and found that it popped up with an error around installing the Python plugin.

I then deleted QGIS (again, through the Ubuntu Software Center) and battled with different software source options. I finally used the terminal to access ubuntugis directly and install it from there.

It installed QGIS 2.0 Dufour after I typed in the coding lines:

sudo apt-get install python-software-properties sudo add-apt-repository ppa:ubuntugis/ubuntugis-unstable sudo apt-get update sudo apt-get install qgis python-qgis qgis-plugin-grass

More errors! When I open it, I get the error:

[ERROR] Cannot make qgis.db private copy

I can say ok, but then another error pops up that says:

Couldn't load plugin processing due an error when calling its classFactory() method

Folks seem to have had a similar problem fairly commonly - my exact error is here but others had similar errors with Sextante? - but I have not yet read a 'solution' to the problem that I was able to understand as a new user.

I can press ok again and it opens, but I really need to open .dgb files, which I cannot do using the addvector command (it wants me to connect to a server when the file is on my computer). Again, other people have had this problem and downloaded gdal, which I tried to do (again through the Ubuntu Software GUI because the links on the website weren't working for me) but I got the error:

Package dependencies cannot be resolved.

Are the two issues linked? What do I do?

share|improve this question
    
Welcome to gis.SE. We appreciate your frustration, but you're missing a lot of important details. Can you edit your question (just click edit below your question) to tell us: which software GUI you used for install? where you downloaded it from? how you did the removal and how you set up ubuntugis? and how did you try to install gdal? –  BradHards Oct 22 '13 at 21:44
    
Also, are you able to provide some link(s) to where "Folks seem to have had a similar problem fairly commonly"? –  PolyGeo Oct 22 '13 at 22:08
    
Re: [ERROR] Cannot make qgis.db private copy: see this answer. –  Luke Oct 22 '13 at 22:43
    
Great, that worked! It also fixed the processing error. It did not fix the gdal problem, so they must be unrelated. –  Nancy Oct 22 '13 at 23:08
    
What exactly is your GDAL error? –  Luke Oct 24 '13 at 2:53

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.