Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I 've created a web map viewer using OpenLayers, ExtJS, GeoExt and GXP. I've added a LayerTree (gxp_layertree) that shows layers from various WMS servers (GeoServers). I've also configured a FeatureManager (gxp_featuremanager) with 'autoLoadFeatures = true' and a FeatureGrid (gxp_featuregrid).

The problem appears when I click on a layer tree node: the FeatureManager doesn't "autoLoadFeatures", it just fires a WFS DescribeLayer request to get the column names for the FeatureGrid. Trying to isolate the problem for a couple of hours by commenting and changing code I've discovered it works perfectly with projection setted to EPSG:4326, but not with EPSG:3857 or 900913.

Do you have any idea about why this is happening or how to solve it?? I need the map projection to be 3857 because I have Google base layers.

Thanks in advance.

Cristian.

share|improve this question

2 Answers 2

up vote 2 down vote accepted

I think this could be by two reasons:

You must set the plugin parameter paging to false to show data always, not depending of the map view. In other way you can take a look at the Geoserver layer to set the parameters "Encuadre Lat/Lon" properly ( sorry i don't know the parameter name in english) . Try like this:

    { ptype: "gxp_featuremanager",id: "gcapas",autoLoadFeatures: true,maxFeatures:100, autoSetLayer : true,paging: true, autoZoomPage:true}
share|improve this answer
    
Bingo!!! thank you so much!! I was so frustrated because I couldn't fix it.. I setted paging:false and it works perfectly now! –  cristianzamar Dec 19 '13 at 14:30

I don't work with geoserver but mapserver, and once I did a request on google maps. It turned out that it didn't return any features because of google map, the URL took by default its projection because they were working as basemap layers. Ater that I knew that OpenLayers worked in that way. I think you have to examine the URLs with firebug or some similar tools and see if that's the actual problem.

Btw I did two tests at that time: (1) without google maps (ie. only my layers), and (2) with it. In that way I found the reason. All my layers were in 4326.

share|improve this answer
    
thanks for you answer. I have already examined and debugged the app with firebug but the problem is that the request never fires, so I can't see the url and parameters.. –  cristianzamar Oct 30 '13 at 15:59
1  
I'd then say that the only way to know what is going on with your code is taking a look at it, post some and see what other people suggest you. –  Gery Oct 30 '13 at 18:30

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.