Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I am installing ArcSDE on a new development box. I have executed the setup.exe, created an Enterprise database called "GDB123" and created a new sde service called "sde_123". I need some clarification on how to register the service using the administrative commands. The install guide says if your are using dbo-schema register the service with this command

sdeservice -o register -d SQLSERVER,MYSERVER\SSINSTANCE -r SDE_DBA_USER -v sa -i sdesvc

I do not understand what value I am suppose to type in for the -r and -v options. I think -r needs to be the database name "GDB123" but I have no idea what to put for the -v option. Heres what I have so far

sdeservice -o register -d SQLSERVER -r ?? -v ?? -i sde_123

How do I make this work?

ArcSDE 10.1 install for SQL Server on Windows 2008 RS box

Install Guid: http://resources.arcgis.com/en/help/install-guides/arcsde-application-server-microsoft-sql-server/10.1/index.html#/Creating_an_ArcSDE_service_on_Windows_using_the_sdeservice_command/00950000003v000000/

SDE Service Commands Options: http://resources.arcgis.com/en/help/install-guides/arcsde-application-server-microsoft-sql-server/10.1/index.html#/The_sdeservice_command/00950000004m000000/

share|improve this question
add comment

1 Answer 1

The '-r' parameter is the registered variable name; it should not be changed. You only need provide the login name for dbo user (sa). Note that this is only necessary if you are using a dbo-schema geodatabase (which I never do).

You also need to specify the Admin_database variable, so that the service knows which database to use:

sdeservice -o register -d SQLSERVER -i sde_123 -r Admin_database -v GDB123 

It is not best practice to include "sde" or "gdb" in the database name. The database is your project, and it should reflect your project ("transportation", "global", "projecta"), not the trivial fact that ArcSDE is present. Using upper-case database names may cause issues further down the road.

It's also no longer best practice to use an application server at all. Instead, you can establish Direct Connect logins for all your users and services. This would of course obviate the need to seek instruction on the use 'sdeservice'.

share|improve this answer
    
I’m still confused about –r. You said the Admin_database variable should be the database name that the sde service is associated with. In this case GDB123. Does that make the –r and –v value the same, GDB123? Your command post: sdeservice -o register -d SQLSERVER -i sde_123 -r Admin_database -v GDB123 –  user19300 Nov 25 '13 at 13:51
    
'-r' is the variable name and '-v' is the variable contents. Think of it as a "set {-r}={-v}". You can specify any variable name, but if you don't specify one that's expected, it will be ignored. "Admin_database" is required to be "Admin_database" for the command to work. –  Vince Nov 25 '13 at 18:26
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.