Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I have followed the instructions-a link to install QGIS 2.0. Everything worked fine until the punch line, installing QGIS ( I do have Ubuntu 13.10);

sudo apt-get install qgis python-qgis qgis-plugin-grass 
eyalak@eyalak-ThinkPad-X220:~$ sudo apt-get install qgis python-qgis  qgis-plugin-grass
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:


The following packages have unmet dependencies:
 python-qgis : Depends: python-qgis-common (= 2.0.1-2+precise1) but it is   
 not going to be installed
           Depends: libqgis2.0.1 but it is not going to be installed
           Depends: sip-api-8.1 but it is not installable
 qgis : Depends: libgdal1-1.7.0 but it is not installable
        Depends: libqgis2.0.1 but it is not going to be installed
        Depends: qgis-providers (= 2.0.1-2+precise1) but it is not going
        to be installed
        Recommends: qgis-plugin-globe but it is not going to be installed 
 qgis-plugin-grass : Depends: libgdal1-1.7.0 but it is not  installable
     Depends: libqgis2.0.1 but it is not going to be installed
     Depends: grass641 but it is not installable
 E: Unable to correct problems, you have held broken packages.

Not sure what to do on this one

share|improve this question
1  
Just for reference: askubuntu.com/questions/351899/… –  Spießbürger Feb 22 at 10:18
    
i have the same problem as you, i tried harder to install it root@khalid-Pc:/etc/apt# sudo apt-get install qgis python-qgis Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation: The following packages have unmet dependencies: python-qgis : Depends: python-qscintilla2 but i –  user28173 Mar 18 at 9:38

3 Answers 3

I encountered the same problem and I did some trials before solving it. Finally this worked for me:

  1. remove qgis and all the related packages
  2. change the repository from ubuntugis to

    deb http://qgis.org/debian saucy main

  3. remove GRASS and existing version of libgdal
  4. install qgis again
Hope this can help.

share|improve this answer

It seems like you are trying to use the repositories for Ubuntu Precise 12.04 but you say that you are running Ubuntu 13.10. Make sure that you have only the correct repositories on your list.

The official instructions can be found on http://www.qgis.org/en/site/forusers/alldownloads.html#ubuntu

share|improve this answer
    
I'm having the same issue: when trying to install the QGIS GRASS plugin, I get: The following packages have unmet dependencies: qgis-plugin-grass : Depends: grass641 I have installed both QGIS 2.0 and GRASS and they are both working fine... –  mapBaker Dec 13 '13 at 22:58

use the second method in this link

http://askubuntu.com/questions/351899/qgis-quantum-gis-install-fails-unmet-dependencies

1.Remove http://qgis.org/debian related line from /etc/apt/sources.list.

2.Uninstall any qgis and grass related packages using apt-get autoremove and then use the following command to install qgis.

   sudo apt-get install python-software-properties
   sudo add-apt-repository ppa:ubuntugis/ubuntugis-unstable
   sudo apt-get update
   sudo apt-get install qgis python-qgis qgis-plugin-grass
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.