Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

This shapefile represents the counties of NM. I am trying to compute the area of each polygon (yes, I know there is an area field, but this is a simpler example of a problem I'm having which doesn't have the areas).

  1. I load the shapefile into qgis and set the projection to UTM 13 NAD 83.
  2. I open the attribute table, enable editing, open the field calculator, select new field, real number, 20 digits, 4 digits precision, and set the expression to $area.

Of the 33 counties, all but 3 show an area of 0. The 3 with non-zero values have values that bear no relationship to the actual area.

I also tried reprojecting the shapefile to Conus Albers, open that in a project with the Conus Albers CRS, and get the same result. Obviously I'm doing something very wrong, but I'm not seeing it.

qgis 2.02 64 bit Windows 7 Pro, 64 bit

share|improve this question

1 Answer 1

up vote 9 down vote accepted

You are doing nothing wrong: In QGIS Lisboa and 2.1.0 (dev) the areas calculate perfectly, in QGIS 2.01-3 (standalone) not.

This is a known QGIS 2.0.1 bug and has a ticket: https://hub.qgis.org/issues/9031

Simply turn off On-the-fly-reprojection while calculating the new field, or try again with the latest dev build from OSGEO4W.

share|improve this answer
    
that did the trick. Thanks. –  Llaves Dec 1 '13 at 15:03
    
This problem still exists in version 2.6.1 (Brighton) –  George Dec 17 at 0:55

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.