Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

For an ArcGIS project opened in ArcMap 10, we have added polygon layers representing different geographical features.

After all the polygons were created, we opened the attribute tables for those layers, and to our shock/dismay, the cells in the "shape_area" column all showed zero! (The "shape_length" field was correctly filled.) We also tried the Measure tool in the toolbar, but it could only measure distances, and the Area button was greyed out.

We checked to make sure that all layers were in the correct geographical coordinate system (WGS 1984).

What did we do wrong? Is there any way to obtain the areas of the polygons we created? Thanks!

P.S. As Brad suggested, I tried to right click on the "SHAPE_Area" column (both on the column label and in the column), but the "Calculate geometry" (and "Field calculator") options were also greyed out.

share|improve this question
How were your features created? Have you tried running repair geometry against your feature class? – Derek Swingley Apr 4 '11 at 20:26
@Swingley: Thanks for the tip. I just tried both Check and Repair Geometry against the feature class in question. The problem remains..... – hpy Apr 4 '11 at 20:42
When the areas are all zero usually one (or both) of two things has occurred: no area has been calculated or else the shapes are relatively small (such as parcels) and areas are computed in squared decimal degrees. (One square kilometer is less than 0.000001 squared DD.) The latter arises from not using a projected coordinate system. – whuber Apr 4 '11 at 21:07
I had the same problem, but I tried to project the shape, and still didn't work. What could it be? – user24087 Nov 18 '13 at 12:19
This does not really answer the question. If you have a different question, you can ask it by clicking Ask Question. You can also add a bounty to draw more attention to this question once you have enough reputation. – Simbamangu Nov 18 '13 at 12:45
up vote 3 down vote accepted

Are you definitely working with a projected shapefile? If the shapefile is in ArcMap, right-click on the shapefile, click on Source and look to see that is in a Projected Coordinate System rather than a Geographic Coordinate System

If it's geographic, go to Data Management Tools ->Projections and Transformations -> Feature -> Project. Then add the shapefile you want to project, and choose your output coordinate system. If you have any other file for this project that is projected, navigate to that file for the Output Coordinate System or choose one from the default appropriate to your location (e.g. by US state, or country).

Then try running the calculate polygons again on the projected shapefile.

share|improve this answer
There is a field called Datum, which reads "D_WGS_1984". I think the project (all layers, feature classes) is all in the GEOGRAPHICAL coordinate system WGS 1984. Is that an issue? If so, how can I fix it? Thanks! – hpy Apr 4 '11 at 20:47
@penyuan just added a a little more info on how to project. – djq Apr 4 '11 at 20:54
It worked, thank you very much! – hpy Apr 4 '11 at 21:41

right click on the area column and hit calculate geometry. select the correct unit. and the area.

share|improve this answer
Just tried to right click on the "SHAPE_Area" column (both on the column label and in the column), but the "Calculate geometry" (and "Field calculator") options were also greyed out! Any other ideas? Thanks. – hpy Apr 4 '11 at 20:11
Add a new field to your shapefile, then calculate geometry. Or import shapefile into a geodatabase. This way Shape_Area will be calculated dynamically. – Jakub Apr 4 '11 at 20:52
@penyuan SHAPE_Area is one of the fields maintained by ArcMap, and is rarely in a desired unit of measurement. As Jakub said, add a new field before calculating geometry, and be sure that you are in a Projected Coordinate System (WGS 1984 isn't one!) like celenius said. – Nathanus Apr 4 '11 at 21:10
if it is a gdb you have to turn on editing before calculating a field value. – Brad Nesom Apr 4 '11 at 22:01

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.