Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

Logged in as development user. Not able to import a .zip or a csv file.

Ruby console has this error log

1.9.2p320 :004 > DataImport[1].log

2014-01-07T05:44:44Z || Using database connection with {:adapter=>"postgres", :encoding=>"unicode", :host=>"localhost", :port=>5432, :database=>"cartodb_dev_user_1_db", :username=>"postgres", :user=>"development_cartodb_user_1"}
2014-01-07T05:44:44Z || ogr2ogr output:    -nlt PROMOTE_TO_MULTI: type not recognised.


2014-01-07T05:44:44Z || ogr2ogr exit code: 256
2014-01-07T05:44:44Z || CartoDB::Importer2::LoadError
2014-01-07T05:44:44Z || CartoDB::Importer2::LoadError

2014-01-07T05:44:44Z || ERROR!

The error message screen shows:

Error 2001. Not able to solve from the error log.
share|improve this question
    
ogr2ogr output: -nlt PROMOTE_TO_MULTI: type not recognised would appear to be the relevant error. Did you look for information on that? –  Craig Ringer Jan 7 at 11:52
    
Yep, it sounds like a GDAL version issue. Check ogr2ogr --version. It needs to be 1.10.x –  andrewxhill Jan 8 at 2:18
    
Solved. Thanks @andrewxhill –  varun Jan 8 at 13:47

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.