Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I've created a Visual Studio 08 Active X - MXCommands dll for a VBA button within ArcMap 9.3.1. I'm able to load and use the .tlb on my computer; however when I try it on my test computer the .tlb file is not visible. The MXCommand is not listed in the Component Category Manager under ESRI MXCommands on the test computer. I used RegAsm (e.g. C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\RegAsm.exe C:\Temp\Mydll.dll) to try and register it on the test computer, but this did not help. Both computers are running MS XP professional. Any suggestions of what I could do or try next would be greatly appreciated.

I also tried this command to register it:

C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\RegAsm.exe C:\Temp\Mydll.dll/tlb: Mytlb.tlb/codebase

And received a RegAsm Error - RA0000 The given path's format is not supported.

Thank you!

share|improve this question
1  
I would be surprised if RegAsm accepted mixed back and forward slashes as delimiters in filenames. If the forward slashes indicate switches, they likely need to be preceded by whitespace. This might explain the error. –  whuber Apr 6 '11 at 16:19
    
Thanks for your comments, I'll give it a try. –  artwork21 Apr 6 '11 at 16:28
add comment

2 Answers 2

up vote 3 down vote accepted

I believe your command line should read:

C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\RegAsm.exe C:\Temp\Mydll.dll /tlb:Mytlb.tlb /codebase

Not directly related to your problem, but I would also advise against naming the type library file differently than the DLL as it violates the standard naming convention. I.e. use Mydll.tlb instead of Mytlb.tlb.

share|improve this answer
    
That worked, thank you! –  artwork21 Apr 6 '11 at 16:44
add comment

In addition, the reason I was not seeing the .tlb file extension was because the windows folder option, "Hide extensions for known file types" was checked. After un- checking it, I could then see the .tlb extension in the Open dialog.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.