Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I've set up my layer to use hyperlinks based on a script. When I use the Hyperlink tool and click on a link, often times it loads just fine.

enter image description here

The problem I have is when there are multiple points on top of each other, each with their own hyperlinks. A window opens that allows me to select the hyperlink I'd like to use. The problem is, I can't seem to activate the hyperlink.

Note that these links are used by a script hyperlink. That's why they aren't websites or document paths.

I've tried selecting the link, and clicking "Jump". I've tried double-clicking the link. I tried pressing "Enter" on the keyboard. I tried the Space Bar. Nothing seems to activate the links.

Are multiple script links from multiple points not supported in ArcMap 10? Is there another way to activate these links that I haven't thought of yet?

share|improve this question
    
As a test, I tried using website URLs. The "Jump" button worked just fine in this case. Must be a problem with hyperlinks that use scripts. –  dangowans Feb 7 at 18:17
1  
I've the same problem with ArcMap 10.0. When I receive the message that suggest to jump between the hyperlinks I try to click on any of the link and I get the message: "Unable to open 'C:\dir\foobar.lyr' Please, make sure the path is correct and the document exists" But if I click on the single layer then the raster load properly. Note that if I open the same mxd project into ArcMap 10.2.1 no problem occours and jump function work fine. Have you suggestions? –  Claudio Feb 27 at 9:32
    
So perhaps it is a bug in version 10 that has since been corrected. I know my GIS provider plans to upgrade this year. Hopefully sooner than later. –  dangowans Feb 27 at 12:50

1 Answer 1

up vote 1 down vote accepted

The bug was fixed installing the Service Pack #5 of ESRI. The JUMP function works fine in ArcMAP 10.0 with SP5.

share|improve this answer
    
That makes sense. I'm using service pack 3. Now if only I had control over the updates. Thank you for confirming there is a fix. –  dangowans Mar 3 at 16:53

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.