Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I am making a map for an orienteering class at the environmental education center that I work at. In order for us to easily calculate the distance between orienteering points, I need the scale to be 1 cm = 100 meters. I am not sure how to set this under the map item properties in the print map composer. I thought that it would be a 1:10 000 ratio, but in the print map composer this is way too zoomed in to possible be correct. Once I have this scale set is there some way to lock it in place so it does not change again?

Also, on my working map in QGIS, the project CRS is set to WGS 84 with on the fly projection enabled. When I switch the map units from decimal degrees to meters, it appears to be incorrect. Distances that I know to be approximately 100 meters in real life appear to be thousands of km apart on the map when I am using the measuring tool. I also get an error message that says

"This map is defined with a geographic coordinate system (latitude/longitude) but the map extents suggests that it is actually a projected coordinate system (e.g., Mercator). If so, the results from line or area measurements will be incorrect. To fix this, explicitly set an appropriate map coordinate system using the Settings:Project Properties menu."

What am I not understanding here!? Please help!

share|improve this question

1 Answer 1

What is the source of your map data? You should look for the projection it uses (maybe something like a UTM Zone number with WGS 84, NAD 83, or similar specified).

Once you know that, open the layer properties (right-click on the layer in the QGIS Layers window, click Properties) and click the Specify button in the "Coordinate reference system" section. Use the Filter box to narrow down the list or Coordinate Reference Systems, find the appropriate one, click on it to select it, then click OK.

It sounds as if the source of your problem may be that a distance of 100 meters is being interpreted by QGIS as being 100 degrees, because it doesn't have the correct projection information. And since 100 degrees can be over 11,000 km, things appear to be going crazy to you.

share|improve this answer
    
Hi Michael, Thank you for your reply. Your suggestions helped me fix my problem with the scale. Now it seems to be working properly. However, I am still having difficulty with the print map composer. I would like to lock my scale in place, but then when I change the map extent (x min and y max values) the scale changes again. I need the map to start in a certain place in the top left corner(it does not matter how far it extends to the right or to the bottom) but when I set the x min and y max values the whole scale changes. Any suggestions for that? –  nwoodworth Feb 14 at 1:07
    
I'm afraid I'm not familiar enough with the print composer to have any good suggestions right now, sorry. It might be worth posting a new question for how to pin a particular geographic coordinate to one corner of the page, since that is somewhat different from what you ask here about setting the map scale. –  Michael Underwood Feb 16 at 0:33

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.