Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

After importing OSM-Data to my qgis-project (as SpatiaLite database and/or shapefile-extract from planet.osm), some features are missing or have no attribute values. For example that lake: http://www.openstreetmap.org/relation/552029 Its just missing in the shapefile-import and the SpatiaLite import have the gemoetries of the lake, but no values!

enter image description here

The most other features are fine.

share|improve this question

1 Answer 1

up vote 3 down vote accepted

What you display is not the relation, but the closed way http://www.openstreetmap.org/way/55075809 (look for the id field).

This way has no tags, because they are in the relation http://www.openstreetmap.org/relation/552092.

The OSM plugin import lacks full relation support as it is done by osm2pgsql. With that, relations get a negative ID to distinguish them from ways.

Try to load the data with Add vector layer. It can handle multipolygon relations a bit better (but still not optimal).

The shapefile extracts only cover most wanted features. Your relation does not belong to that group. You get full data support in shapefile format only when you pay for it.

share|improve this answer
    
I don't think there is a service that converts relation with non standard tags. –  neogeomat Feb 17 at 10:49
1  
Well, there is: geofabrik.de/en/data/shapefiles.html –  AndreJ Feb 17 at 11:01
    
Thank you so far! But I hoped to hear something else... So, It seems that there are no (free) solution yet, to use OSM-Data in QGIS with its relations? –  MAP Feb 18 at 12:26
    
osm2pgsql is absolutely free! You just have to set up a postgis database yourself. It even runs on my Windows laptop (not the whole world). Have you tried with Add Vector layer? –  AndreJ Feb 18 at 12:37
    
I tried it with "add Vector layer", but the polygons are still missing. With postgis, the relations will work? Why not with SpatiaLite? I have trouble getting postgis running on my ubuntu... –  MAP Feb 25 at 9:24

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.