Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

During the past weeks, I have tried QGIS to recognize SAGA via the processing toolbox, both being installed from the ubuntugis-unstable repository. I have tried this on several virtual ubuntu operating systems which I specifically set up for using QGIS. However, I always get the same "Missing dependency.This algorithm cannot be run" (sic) error message. Here's some more information:

  • I have tried (l)ubuntu 12.04, 13.04 and 13.10 (each 64bit), installing packages from the respective repos. I
  • I am now an ubuntu 12.04 32bit VM
  • I am well aware of this post, and yes, this workaround would do the trick! However, installing from the qgis repositories is not an option for me, as I also need the orfeo toolbox packages, which are not provided there :(
  • Package versions are qgis 2.2.0-1, saga 2.1.1 and python-saga 2.1.1. I had the same problem with the preceding QGIS version.
  • I checked the PATH variable and successfully launched saga_cmd, so everything seems to be in its place.

Any help is appreciated -- including first guesses on what may be the problem :)

share|improve this question
    
I suppose it could be possible to install QGIS like it was described in post you mentioned, and then install OTB from another repo or from source. –  SS_Rebelious Feb 24 at 11:03
    
I have this Problem as a recurring issue on my Ubuntu Precise with multiple users in multiple groups. In my case, the Problem is that /tmp/processing gets created by userA with ownership and no write Access outside the Group. If I fix the permissions on /tmp/processing with sudo chown root.root /tmp/processing and sudo chmod 0777 /tmp/processing, then saga (and grass) will work fine. Don't know if that's your Problem, though. –  MonsterMushroom Jun 12 at 9:33
    
Same problem here, no solution. –  user two seven two three nine Jun 17 at 1:11
    
Which algorithm are you trying to run? –  johanvdw Jul 3 at 19:53
    
I have QGIS 2.4.0, SAGA 2.1.2 on Kubuntu x86_64 4.13.3, and the same problem. No idea why. @johanvdw, I've tried clicking on all the kriging algorithms and the "Reclassify grid values" algorithm. Seems like it doesn't matter which one you try, QGIS says it cannot find SAGA. –  foobarbecue Sep 24 at 15:00

1 Answer 1

Another Thing to try:

  1. Go to Processing->Options and Configuration
  2. Click on Providers->SAGA
  3. Uncheck "Enable SAGA 2.0.8 compatibility"
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.