Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I run the function "Join attributes by location" in Qgis 2.2 between a point vector layer and a polygon vector layer. When I open the resulting table of contents of point layer there is a column of numbers (fields from 10 to 13) that fail, because there is the same value in every row. For example "-214", a value that does not exist in the overlay polygon shape. However, this column is the one I need for doing further process. Does anyone know what the problem could be? Any tricks? Perhaps problem of "encoding" systems is causing this?

Additional information: I tried with Saga process but in Qgis 2.2 there is no option for Saga folder in the configuration menu. I tried to change encoding (UTF-8, System) but the results is the same!

Carlo Z

share|improve this question
Please add information about the input layers' columns and the output layer's columns. What would be the expected value in the column? – underdark Mar 19 '14 at 19:22
In "input" a list of unique numeric values (example: 100000000001, 100000000002, 100000000003...), in output results the same value in every row (example: -12345678, -12345678, -12345678...). – Carlo Mar 21 '14 at 9:54
Seems like an integer overflow problem. Is it acceptable to convert the numeric values to string? – underdark Mar 21 '14 at 16:25
Ok it works. By setting the field: either as "real" (length - 16; precision - 2) or as "text". Many thanks for your suggestions! – Carlo Mar 25 '14 at 18:29

You're running into an integer overflow problem.

You can change the field to real or text to fix that.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.