Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I've Installed Linux Mint 16 mate and install PostGIS with PostGreSQL (I've tried many ways in the Internet from original source to some suggestion) but all is too error: " ERROR: could not load library "/usr/lib/postgresql/9.3/lib/rtpostgis-2.1.so": libxerces-c-3.1.so: cannot open shared object file: No such file or directory"

Please help me for fix this problem because I can't understand how to fix this. Please, note that in "/usr/lib/postgresql/9.3/lib" has file rtpostgis-2.1.so.

Thanks.

share|improve this question
    
Edit your question to add the output of the command sudo ldd /usr/lib/postgresql/9.3/lib/rtpostgis-2.1.so please. Also, how exactly did you install PostGIS - from where, using which packages, which commands, etc? (Comment when you've made the edit, it'll notify me). –  Craig Ringer Mar 29 at 6:53
    
Thanks pro Underdark but I think the problem is that with Linux Mint OS because I can easily install PostGIS in same Linux Ubuntu OS. Thanks for your help. –  Bằng Rikimaru Mar 31 at 1:32
    
Yours is not the first report I've seen of brokenness in Linux Mint, so I would not be surprised. My previous request stands: You're missing some important details in your question. –  Craig Ringer Mar 31 at 1:34
    
Looks like you are getting hung up on a GDAL dependency. rtpostgis-2.1.so depends on GDAL which in turn can depend on a ton of other packages depending on how its compiled. Sounds like your GDAL is missing the libxerces dependency its looking for. As Craig says do do an ldd to better see where the error is. –  LR1234567 Apr 5 at 4:22

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.