Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

Last week, I went to View -> Data Frame Properties... -> General tab to change the data frame map display units from Decimal Degrees to Degrees Decimal Minutes. (the Map Units were still in Decimal Degrees, in fact it is greyed out and can't be changed)

Today, I wanted to change the Display units back to Decimal Degrees, but after I click Apply and OK, the map status bar still shows coordinates in Degrees Decimal Minutes as I move my cursor around the map. I went back to Data Frame Properties and the Display units have reverted back to Degrees Decimal Minutes!

Why is this happening, and what should I do? Thanks.

share|improve this question
1  
are you re-projecting on the fly? even if one transformation is slightly out you will need to re-project the data sources. –  Mapperz May 15 '11 at 17:13
    
Some of my layers were transformed from NAD27 into WGS 1984, while the Data Frame is defined as WGS 1984. Would this be the problem? If so, how do I correct this? –  hpy May 15 '11 at 17:52
1  
define your data sources and then use 'project' help.arcgis.com/en/arcgisdesktop/10.0/help/index.html#//… - look at 'usage' and geographic projections from NAD27 –  Mapperz May 15 '11 at 17:57
2  
You might be hitting a bug. I seem to remember hearing about something similar. I would try setting the data frame coordinate system to a projected one, OK the dialog, then change it back to the geographic coordinate system. –  mkennedy May 16 '11 at 0:52
1  
I work for a state agency in Louisiana, and our GIS specialists say there is nothing wrong. I have told them and showed them time again that when you apply changes to the data frame properties - they do not register in ARC 10. perhaps there should be a recalculation and this task should be tempered - but wowee, I would think you should be able to freely change the units. This is unacceptable Jack! –  user8860 Jul 13 '12 at 17:48

3 Answers 3

Check ArcMap Options > Data View and see if the option "Use these units instead of the data frame's Display units" is set.

share|improve this answer

I just had exactly the same problem. It was using a data frame in wgs84 but unprojected. I tried projecting and unprojecting it and changing to decimal degrees but it didn't work.

My solution: For some reason choosing "kilometers" as the display units worked and then I could go back to decimal degrees. No Idea why but it seemed to fix the bug...

share|improve this answer

I had the same problem. The solution I found was to go into Data Frame Properties click the Coordinate System tab and then double-click on the projection you are using to bring up the Projected Coordinate System Properties window and change the Linear Unit (it's a drop down near the middle) to feet or yards or whatever unit you want. It will still be greyed out when you go back, but the units will be whatever you set in the Projected Coordinate System Properties window.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.