Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

enter image description here

I'm having trouble with a model that is supposed to truncate data from the attribute table of a feature class (which is in a file geodatabase not ArcSDE) and then append it with new data. The truncate operation returns a success result but the geometry remains intact after the truncate. I also tried the delete features and delete rows tools but they each return a generic function error.

I'm not sure if this problem is due to the fact that the feature class being truncated is associated with a published map service.

I should note that this custom geoprocessing tool is being published to a server from where it will be invoked programatically in a flex arcgis web application. What worries me is whether truncating data directly from a feature class which is associated with a published map service is a bad idea. Also, this model worked fine initially until the first time that it was invoked from the flex application through the published geoprocessing tool.

I am using ArcGis 10.1, ArcGIS Viewer for Flex 3.6.

share|improve this question
    
It seems the truncate table operation was not working correctly for some reason –  IQ_HiGh May 28 at 14:15
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.