A webapp that is bundled with the OpenGeo Suite. It is a basic viewer and editor.

learn more… | top users | synonyms

0
votes
0answers
10 views

POST not implemented

I'm developing a client wps modifying the example WPSDemo.js from http://suite.opengeo.org/4.1/processing/wpsclient/index.html . I'm using zoo-proyect as wps server. I'm trying to invoke the "buffer" ...
0
votes
1answer
20 views

GXP Hidden layer switcher - composer.html

I am working with GEOSERVER, GeoExplorer, GXP. I am creating a WPS client and need to generate a vector layer that serves to make operations on vector data, such as buffer, split polygon. I know how ...
2
votes
1answer
28 views

Permanent add Geoserver Server on Geoexplorer different URL

I have my Geoexplorer run on Open shift (asume http://geoexplorer-aaa-rhcloud.com) using this Git (https://github.com/jason-callaway/geoexplorer-on-openshift). My geoexplorer run perfectly, ...
0
votes
0answers
12 views

How to stop multiple labes showing for a single item [duplicate]

On top of some other styling, I have used GeoExplorer to edit the scale based rendering of labels for the names of fields in an area. It all works fine but when I zoom in of fields that have a large ...
0
votes
2answers
73 views

Load Geoexplorer into Tomcat

I have installed Tomcat on a Windows server and have successfully deployed Geoserver. I am trying to deploy geoexplorer by building the war file from github and loading it into tomcat to deploy. It ...
1
vote
1answer
28 views

More than one group for a single layer in Geoserver?

I have a huge number of layers in my geoserver that I have painstakingly imported and they all work correctly when viewed with GeoExplorer etc. I want to know if there is any way to create set maps ...
0
votes
0answers
24 views

Upload layers in Geoexplorer

I have OGS 4.02, OS is Windows Server 2008 R2 Standard.I have questions about Geoexplorer. I know that anonymous users can not save and publish map and also they can not upload layers. If I create ...
0
votes
0answers
18 views

Roles for uploading layers in geoexplorer

What kind of users I have to create for uploading layers? I tried with users that are not admins and they have specific role with write access on workspace, but it works only once or twice. What I ...
0
votes
0answers
13 views

GeoExplorer Limit by Filter layer property not filtering correctly?

Using GeoExplorer to visualize data from GeoServer, I'm able to use the layer's Display "limit by filter" feature to remove certain features from the map, but when I use the Identify tool to expose ...
1
vote
0answers
70 views

Help with customizing GeoExplorer

I'm just beginning to play with BoundlessGeo's GeoExplorer interface. I'm trying to figure out if I can customize it for use in-house. We basically need an intra-net type web mapping app to display ...
0
votes
1answer
49 views

problem login geoexplorer - redirect IP

I have problems when I want to log the administrative user through GeoExplorer when geoserver is running on a server with public ip but redirection to a private ip. GeoExplorer takes too long to load ...
1
vote
0answers
82 views

How can we generate GeoJSON from SQL data with latlong

Is there any way we can create GeoJSON from SQL server table with Latitude & Longitude Data?
0
votes
1answer
113 views

GeoExplorer: Setting more/custom zoom levels

I have BoundlessGeo's OpenGeo Suite (Geoserver,PostGIS,GeoWebCache,GeoExplorer) installed, and love the web functionality of GeoExplorer, but need my maps to zoom in a few steps further. So far the ...
0
votes
1answer
32 views

Specify layer and BBOX in URL when opening GeoExplorer

I'd like to specify the state that the GeoExplorer map window and which layers are turned on when opening it up by a URL. I've started to go through the code but I feel this must be quite a common ...
0
votes
1answer
71 views

Geoexplorer (Opengeo Suite) cannot upload data

i am following the tutorial how to create a simple map. However, I got stuck in the step to upload the data. It gives me an error and I dont know why (see photo). I zipped the shapefile with all the ...
0
votes
0answers
41 views

GeoExplorer - Show layer by default in published map

I am able to publish a map using GeoExplorer and can add the icon on the published map to show the legend. However, I'd like the legend to appear on the published map by default. Is there a way to do ...
0
votes
0answers
40 views

How to use “outputConfig” to configure LayerPanel from GXP

Can outputConfig be used for functions too - not just configuration? I have this code in geoexplorer.js (using GeoExplorer 2.4.3) which doesnt work: var GeoExplorer = Ext.extend(gxp.Viewer, { ... ...
0
votes
0answers
71 views

Geoexplorer ../proxy/url=? fails with 'moz-nullprincipal' when run in Tomcat7, not Jetty7

There's a remote WMS service (not running on port 80) that can be accessed from a machine - it's getCap URL can be reached by a browser. When attempting to add this WMS source in a Geoexplorer ...
0
votes
0answers
71 views

How to activate Upload Layers and other functions in Geoexplorer using OpenGeoSuite 4.x

We installed recently the Community Edition of Opengeosuite 4 on our system. Compared to the OpenGeoSuite 3 (which run perfectly) we encounter many problems. We need to be able to edit and upload ...
0
votes
1answer
128 views

Where to upload layers in geoexplorer?

I just install opengeo suite (boundless) in my machine and try to explore it. I followed the instruction in user manual and I encountered a problem. In "Load your data with GeoExplorer" part, after ...
1
vote
1answer
46 views

Geoserver getlegend graphic returning diagonal lines for polygon

I have been developing a dot density map using certain attributes and have been successful in doing so. But there has been a problem while getting the legend from geoserver wms using a ...
0
votes
0answers
165 views

How to configure tools in GeoExplorer composer?

I'm running GeoExplorer within the opengeo suite sdk, how do I override the tools configuration in composer.html ? It's only when i edit Composer.js that tools are configured the way I want. For ...
2
votes
1answer
68 views

Geoexplorer Class Diagram

Does anyone know where I could find a class diagram for the different modules of geoexplorer (geoext and gxp)?
2
votes
1answer
79 views

GeoServer/Geoexplorer: How do I hide the WMSLegend on some layers?

I'm developing with the geoexplorer sdk and extending the composer and am working on the master branch of boundless/suite/geoexplorer. My geoserver version is 2.4-SNAPSHOT. I want to hide the ...
0
votes
0answers
136 views

Errors when building OpenGeo Suite with Maven 3.1.1

I am trying to build the OpenGeo(Boundless) Suite with Maven 3.1.1 I am following the instructions on GitHub. When building I am getting the next error : GitHub : ...
0
votes
0answers
73 views

GEOExplorer - Get Feature Info doesn't work in IE or Firefox

I published a map here using GEOExplorer and I can only get the "Get Feature Info" to work in Google Chrome. Nothing happens when I use Internet Explorer or Firefox. Can anyone help fix this?
0
votes
1answer
173 views

Custom project of Geoexplorer

Is there some custom project existing of geoexplorer free downloadable? I'm student and I'm doing a stage. I need to have a query mask for my map but I'm not able to do it with sdk-suite.
1
vote
0answers
157 views

how to create the Layer Properties button as geoexplorer?

I was in the debug mode.And I create a Layer Properties button ,but it is only show the title. the code for it, * @require plugins/LayerProperties.js -------------------- { ptype: ...
1
vote
0answers
182 views

GeoServer and GeoExplorer issues setting up per-layer security

I can't get per-layer security working... I have the following set up: A user USER, with no group membership and one role EXAMPLE_ROLE and a password the role has no parent role and no properties ...
1
vote
1answer
773 views

Error with GeoExplorer/GeoServer and Apache Proxy Authentication

I use a customized version of the OpenGeo Suite Community Edition. After everything was going well I now run into proxy timeouts. First some details about the application architectur. I work with ...
0
votes
1answer
48 views

Geoexplorer not displaying geoserver layers

I have a problem with geoexplorer not displaying my geoserver layers anymore. It gives me an error of "Non-existing source 'local' referenced in layer config." I really dont know hwta went wrong or ...
1
vote
1answer
70 views

Limit what fields can be edited GeoExplorer OpenGeoSuite

I have an issue with limiting what fields can be edited by the user. If I link my layer to my PostGIS table, the user is able to edit all the fields for a specific point. -If I create a view I can ...
0
votes
1answer
90 views

Refreshing the GeoCache and Boundaries in OpenGeo suite

Currently if I add a new site i can query the layer and see where the point should be however it does not always display in Geoexplorer or OpenLayers preview. However sometimes it does show in ...
0
votes
1answer
132 views

Opengeo Geoexplorer WMS source singleTile property?

I was wondering whether there is a way to control what layers should be fetched as a single tile in a GeoExplorer composer application? OpenLayers.Layer.WMS objects have a singleTile property but it ...
0
votes
1answer
133 views

Recipes on OpenGeo Suite

could someone tell me how to add a recipe in OpenGeo Suite please. I would like to submit a Tree sub-layer in a geoexplorer map. Thanks Filippo
1
vote
0answers
213 views

Saved maps in geoexplorer (geoserver layer security)

I am a bit confused with the save maps function in geoexplorer. I have a vps server with the opengeo suite 3.1, I added a table to the vps local postgis db server to the geoserver.public database. I ...
1
vote
1answer
98 views

GeoServer Layer Preview Opens OpenLayers instead of GeoExplorer

I am using OpenGeo 3.0 and trying to get GeoExplorer to launch through the Layer Preview. I imported PostGIS tables into GeoServer and created a layer. However, when I go to view the layer and select ...
1
vote
1answer
368 views

GeoExplorer provokes “401 Unauthorized” request and lacks login

Currently I have a login problem with my deployed GeoExplorer. Everything works fine in debug mode on my local VM with the geoserver from my remote server connected. Firebug gives the following output ...
0
votes
1answer
85 views

GeoExplorer dependencies are missing after git clone

When I set up GeoExplorer in development mode today I had to manually clone the external js libs that are referenced in git (buildkit, stick, geoext, gxp, openlayers, printpreview, proj4js). They ...
0
votes
1answer
54 views

Problem running mvn install for geoexplorer

What's the solution to this: http://www.paste.to/MjU5ODE= I'm getting the same error on Ubuntu 12.04. Installed with: Java 1.6.0_27 (OpenJDK), Maven 2.2.1 and Ant 1.8.2 Is the Ant version the ...
2
votes
1answer
266 views

GeoExplorer: “Could not create layer record for layer group”

I installed GeoServer via OpenGeo Suite, and still working on it. I created a "Layer Group" and add layers from local PostGIS. I tried to preview it from "Layer Preview" and show perfectly through ...
1
vote
1answer
177 views

OpenGeo Suite 3.1 doesn't work anymore when setting up Client SDK 3.0.2

We've installed OpenGeo Suite 3.1 on Ubuntu 12.04 LTS and everything works fine. When trying to set up the OpenGeo Client SDK 3.0.2 (following ...
0
votes
0answers
168 views

Should I be using the OpenGeo Suite SDK or GeoEXT?

Im new to the OpenGeo Suite, and was wondering if I should create my apps using the SDK Link Here Or I should use openlayers and GeoEXT Link here I believe the SDK uses openlayers / geoext but makes ...
0
votes
1answer
321 views

OpenGeo displays layer in openlayer, but not geoexplorer

My test server updated today I think it was a php update, and since I can no longer view data in geoexplorer, only openlayers. The geoexplorer can not see my local server. any hints? Update: Firebug ...
2
votes
1answer
568 views

geoserver wms issues

My WMS on a local test server was working fine with GeoExplorer but suddenly stopped working and now I don't get the LocalServer in the datasources list. I have tried reboot/restart. I tried adding ...
0
votes
1answer
375 views

A couple GeoExplorer questions

I just started working with the OpenGeo Suite. I'd really like to use it for a County web map, but have a couple questions... 1) Is there a way to add a lat/lon or other X/Y location to the URL and ...
1
vote
1answer
34 views

What each stack element does

Im using the opengeo stack, and want to double check my understanding of each element. PostGIS - The database for storing my data GeoServer - The link between the online part / the database Here's ...
0
votes
1answer
99 views

Geoexplorer displays the layers I import, but not the table behind them

If I import layers into GeoSrver, they display in GeoExplorer, and I can use the identify tool to find more info about areas of the layer I select. However the table from which this data comes from ...
0
votes
2answers
124 views

GetFeatureInfo for gxp_olsource in OGS GeoExplorer

We have an OpenGeo Suite GeoExplorer 3.0.1 and want to make GetFeatureInfo-requests, via the identify button, for WMS-layers of type gxp_olsource but it doesn't work, I get no response at all and I ...
3
votes
2answers
839 views

Geoexplorer cannot Save and Publish maps

I installed Geoexplorer 3.0.2 according to instructions. I also setup GEOEXPLORER_DATA in web.xml file and it seems that it works fine because http://localhost:8080/geoexplorer/maps/? returns: ...