0
votes
0answers
20 views

Openlayers WMS GetFeature Info Pop Up Not Working / Mapserver

I am new to OpenLayers and Mapserver .. I have been trying for days and am not able to make it work I want to make a Pop Up for Get Feature Info but nothing appears when i click any place This is ...
0
votes
0answers
64 views

Point Layer WMS GetFeatureInfo failing when zoom in

I have a problem that i think is related with the interaction between OpenLayers and my Google map Base Layer (inconsistencies with coordinates systems, or something like that). Maybe also this could ...
0
votes
0answers
15 views

ArcGis Server 10 - GetFeatureInfo issue

I've got an OL 2.13 client where I use a hack on GetFeatureInfo to be able to get objects within a bounding box. I can't use WFS which would be the natural choice for this scenario, which forces me to ...
1
vote
1answer
50 views

GeoServer: Combining multiple raster stores into one wms layer

I would like to publish a DTM as WMS using GeoServer. For the visual part I have a hillshaded version of the DTM and the original DTM contains the height as floating points (level above sea). ...
4
votes
1answer
107 views

Does WMS GetFeatureInfo takes into account the applied Style (SLD)?

As the title says, does WMS GetFeatureInfo takes into account the applied style to a layer? For example I have layer of all US States and I applied the following SLD: <PropertyIsEqualTo> ...
0
votes
2answers
479 views

Google Maps with shapefile/WMS - get feature info problem

I've just created my first Geoserver "portal". For this I created 2 .js files. In first .js file I have Google Maps API and in the second .js file I have my shapefile. Directly from Geoserver I can ...
0
votes
0answers
85 views

OpenLayers - feaures from WMSGetFeatureInfo are not shown on layer (but they exists)

I have a project with google as base layer and geoserver serving WMS layers (structures - multipolygons) that are in EPSG:2039 The layers are showing fine on google base layer (I guess OL re-project ...
0
votes
2answers
304 views

Use GetFeatureInfo with OpenLayers and a Bounding Polygon

I want to be able to draw a bounding polygon and have my MapServer WMS layer return every feature within that bounding box. I have it working for a single point, but I would like for the query to ...
2
votes
0answers
149 views

WMSGetFeatureInfo : No feature found on click

My map displays well my WMS layers. When i try to get the feature info, the debugger tells me no feature is found features: Array[0] , length :0 I don't know if it is because of a projection issue: ...
0
votes
1answer
275 views

OpenLayers CQL filter gets info about NOT VISIBLE features

I have a WMS layer and a control WMSGetFeatureInfo. If I apply a CQL Filter to the layer and I redraw it, the WMSGetFeatureInfo control continue querying also NOT VISIBLE features. Why in your ...
0
votes
1answer
369 views

How to determine the accuracy of getFeatureInfo on a WMS layer?

I have added a WMS layer to the ArcGIS Server JSAPI and am attempting to query it using getFeatureInfo when the user clicks on the map. A reproducible sample is available here. This is mostly ...
0
votes
0answers
12 views

GeoServer use MapGuide as data store [duplicate]

I try to use MapGuide as GeoServer's data sources, by choosing WMS - Cascades a remote Web Map Service at the bottom of "New data source". It works fine when add as a wms layer var wms_dip = new ...
1
vote
0answers
101 views

WMS: point “pointer” symbol with offset - getFeatureInfo search area slight mismatch

I'd like to ask what ways there might be to adjust a point's getFeatureInfo search area so that it matches a "pointer" (i.e slightly offset) symbol. We are running GeoServer 2.2.0 (part of an Opengeo ...
0
votes
0answers
28 views

WMSGetFeatureInfo Not working [duplicate]

I am using openlayers with the wmsgetfeatureinfo feature which will allow the user to query on the wms layers. If the geoserver and the wmsgetfeatureinfo is on the same domain. Do i need to set a ...
0
votes
0answers
340 views

WMSGetFeatureInfo returns an empty popup

I am building a web map application using Openlayers and Geoserver. Both the application and the geoserver are hosted on amazon. I would like to include a feature info tool and am using ...
0
votes
0answers
235 views

Customize display of WMS GetFeatureInfo results

i have a popup that get the featureInfo on the map, what i want to do is to customize the display of the WMS GetInfo Results, i don't want to avoid automatic alphabetic sortingof the attribute ...
1
vote
0answers
137 views

Restrict featureinfo fetched with the WMSGetFeatureInfo request in geoserver

i followed a GeoEXT example to create popup menu that gets WMSFeatureinfo on click on the map, What i want to do is to get some specific fields not all the fields, i try the propertyName (with ...
2
votes
2answers
2k views

Openlayers & WMS - GetFeatureInfo problem

I'm making a small project but I encounter some problems. Let me explain that : Having generated mapfile with mapserver and they are viewable by the openlayers interface, I would like to make me ...
0
votes
1answer
108 views

WMS - Export Retrieved XML Data

I use WMS layer in my app and could successfully retrieved Feature Info by click like so: http://openlayers.org/dev/examples/getfeatureinfo-control.html My question is: Is there any way to export the ...
0
votes
1answer
743 views

uncaught typeerror: undefined is not a function

Using some examples from internet, I found this code that shows WMSGetfeatureinfo I don't know where's the problem: Here goes my code: <!DOCTYPE HTML> <meta http-equiv="Content-Type" ...
3
votes
2answers
196 views

GeoServer cascading WMS, FeatureInfo is lost

I'm trying to cascade a WMS service in GeoServer (http://grb.agiv.be/geodiensten/raadpleegdiensten/GRB/wms?REQUEST=GetCapabilities&SERVICE=WMS). I can view the cascaded layers just fine, but ...
1
vote
0answers
153 views

Get info from WMS layer with Openlayers mobile

I am trying to build a webapp for iPad using OpenLayers Mobile. One of the features it should have is that you can tap on a tree displayed on a basemap and get info about this tree. These trees are ...
1
vote
1answer
186 views

Geoserver 2.1.3 no GetFeatureInfo-Response when multiple Features found on same location within same layer

I have a Geoserver postgis layer with multiple point features on the same location. GetFeatureInfo returns results when only one feature is found. But Geoserver returns nothing (empty html) when ...
0
votes
2answers
240 views

prevent popup from appearing when clicking outside wms layer

Any help with this would be appreciated. I am projecting a WMS-layer on a map using OpenLayers and Geoserver. The next thing I want to do is to display info on any given feature in my WMS-layer in a ...
2
votes
2answers
1k views

GetFeatureInfo doesn't work!

I'm new at openlayers and I am having some trouble when trying to display the feature info. I have the map working, with the layers I want to add in, but it seems that when I try to ask for the info ...
7
votes
2answers
3k views

How to make geoserver return JSON for WMS GetFeatureInfo?

I wish to get the results of a WMS GetFeatureInfo request as a JSON instead of the table that comes up by default. Out of the box, the only options for the response from a WMS GetFeatureInfo are the ...
0
votes
1answer
52 views

What kind of different results or what is the difference between two URL based WMS requests [closed]

I am trying to retrieve some WMS layers from geoserver so that I can display them in leaflet and I need to populate a URL field and I noticed that many of the layers that I opened up in openlayers had ...
3
votes
0answers
177 views

How do I format tilelayer.wms url properties such that I add an overlay iteratively to my base map in leaflet

My base map was created using hard-coded template variables. I am using the leaflet tilelayer.wms constructor and including the url like so: url: ...
1
vote
1answer
1k views

How to get feature info from wms layer

I have used your code for picking feature info from wms layer using WMSGetFeatureInofo function.I have used you this link. ...
1
vote
1answer
405 views

Creating a GeoExt Action from OpenLayers Function

I am trying to create a GeoExt function out of this OpenLayers function, which displays the getFeatureInfo. I was able to create this GeoExt.Action() but it does not give me any output. Any idea ...
5
votes
2answers
4k views

OpenLayers custom request for WMS GetFeatureInfo

In OpenLayers, there is a WMSGetFeatureInfo control that can be attached to a layer and listen to click or hover events on the map, requesting info on the feature being currently clicked (or pointed) ...
1
vote
0answers
88 views

Wrong data with FEATURE_COUNT=1 for GetFeatureInfo

When I am querying the WMS service with FEATURE_COUNT=1 then I get the wrong meta data. Once I make FEATURE_COUNT=2 then first row contains the correct data. I am executing the URL directly in ...
1
vote
1answer
186 views

How show some fields only when using WMSGetFeatureInfo?

How to show some important field only when using WMSGetFeatureInfo.I use this example. When I click on maps it show all the fields of attribute table.What part should I modify in above mentioned code. ...
1
vote
2answers
765 views

Prevent layer from WMSGetFeatureInfo request on openlayers web map

I use this example code get feature info from my openlayers web map.I add 4 layers to map including raster image as base map. But i don't need feature info from that raster layer.But when clicking on ...
1
vote
1answer
821 views

Displaying Feature Info for a user defined polygon

To retrieve feature info for a polygon selection, I have the OpenLayers code below: var featureTypes = ["nig_admin1", "nig_admin2", "nig_admin3", "nig_landscan"]; var populationCtrl ...
2
votes
2answers
1k views

How to select multiple polygons or points from WFS or WMS and getFeatureInfo

Is there a way to select multiple polygons and/or points from a WFS or WMS service and then get the feature information for each selected item? There are numerous examples on the OpenLayers website ...
1
vote
3answers
2k views

WMSGetFeatureInfo not showing in Firefox and chrome

This code set works for me in IE but not in Firefox and chrome.What is the problem? Map is showing in all browsers ,but when i click on point of map nothing showing in Firefox and chrome. Welcome ...
3
votes
2answers
5k views

Use OpenLayers WMSGetFeatureInfo on Mapserver Layer?

I'm able to use OpenLayers' OpenLayers.Layer.Mapserver declaration to generate a raster from GRIB data. I've read in the MapServer docs and on forums that it should be possible to get point ...
2
votes
1answer
1k views

How to deactive Vector Selection In OpenLayers wms features

This is my sample code and work fine :), But I have a little problem, I'm using multiple layer (WMS), when I zooming the layer will be shown or hidden. In my example bellow when OpenLayers level zoom ...
2
votes
1answer
1k views

WMS GetFeatureInfo and Google maps api V3

Is there a way to request GetFeatureInfo from a WMS service with the Google maps api v3?
1
vote
1answer
2k views

WMS Request Returns nothing with Geoserver

I'm having trouble with a select feature example in Geoserver and open layers. For some reason the request returns nothing. Here's the stripped down version that produces this: I have a small wms ...
2
votes
1answer
983 views

ArcGIS Server WMS GetFeatureInfo tolerance

is there a way to specify pixel tolerance when requesting feature info via GetFeatureInfo WMS request for an ArcGIS Server WMS-published map service? I have not been able to find any such information ...
7
votes
4answers
8k views

How to select fields returned by GeoServer WMS GetFeatureInfo request?

I'm running simple local mapping service based on PostGIS/GeoServer/OpenLayers stack. Following opengeo tutorial I've tied click events in OpenLayers to WMS GetFeatureInfo call using: ...