a WMS (Web Map Server) standard call that retrieves the underlying data, including geometry and attribute values, for a pixel location on a map.

learn more… | top users | synonyms (1)

0
votes
1answer
223 views

How can I get ArcGIS Server to give a GML GetFeatureInfo response?

Although I have read the following document (http://help.arcgis.com/en/arcgisdesktop/10.0/help/index.html#//005300000228000000) I am still totally unsure about how to enable a gml GetFeatureInfo ...
0
votes
0answers
28 views

Why do I get multiple GetFeatureInfo responses from ArcGIS Server WMS when the layers are not visible?

I am serving 3 identical layers in ArcGIS Server 10.0 as one wms service. Layer 1 is visible from scales 1:2000,000 to 1:250,010, layer 2 from 1:250,000 to 1:50,010 and the 3rd layer from 1:50,000 to ...
1
vote
0answers
147 views

WMS: point “pointer” symbol with offset - getFeatureInfo search area slight mismatch

I'd like to ask what ways there might be to adjust a point's getFeatureInfo search area so that it matches a "pointer" (i.e slightly offset) symbol. We are running GeoServer 2.2.0 (part of an Opengeo ...
0
votes
0answers
53 views

Why is ArcGIS Server 10.0 getFeatureInfo not being buffered?

Using AGS10.0 I have a point featureclass published as wms. In my Openlayers client, I am not able to click on the point and recieve the GetFeatureInfo response unless I hit the target very ...
0
votes
2answers
49 views

WMS GetFeatureInfo with No Location

I am using Geoserver with OpenLayers. I would like to return all the feature type details in a specific layer exactly as GetFeatureInfo does for a specified location. I tried using GetFeatureInfo ...
0
votes
3answers
949 views

Google Maps with shapefile/WMS - get feature info problem

I've just created my first Geoserver "portal". For this I created 2 .js files. In first .js file I have Google Maps API and in the second .js file I have my shapefile. Directly from Geoserver I can ...
1
vote
0answers
142 views

Configuring Mapproxy + Mapnik for using Getfeatureinfo

This is probably a duplicate of this question: How to configure mapproxy and mapnik for getfeatureinfo requests, however, that one is old and still unanswered. I'm trying to configure a Mapproxy ...
0
votes
0answers
483 views

Openlayers WMS GetFeature Info Pop Up Not Working / Mapserver

I am new to OpenLayers and Mapserver .. I have been trying for days and am not able to make it work I want to make a Pop Up for Get Feature Info but nothing appears when i click any place This is ...
1
vote
1answer
161 views

WMTS GetFeatureInfo in android

I want to create something in android like this: http://openlayers.org/dev/examples/wmts-getfeatureinfo.html I'm able to load the costum tiles with WMTS but now i need to get data to show in some kind ...
0
votes
0answers
199 views

Point Layer WMS GetFeatureInfo failing when zoom in

I have a problem that i think is related with the interaction between OpenLayers and my Google map Base Layer (inconsistencies with coordinates systems, or something like that). Maybe also this could ...
0
votes
2answers
302 views

prevent popup from appearing when clicking outside wms layer

Any help with this would be appreciated. I am projecting a WMS-layer on a map using OpenLayers and Geoserver. The next thing I want to do is to display info on any given feature in my WMS-layer in a ...
1
vote
0answers
59 views

No Popup for bottom layers, only top layer works

I have an OpenLayers Map. On this map, I have three overlay layers. The first 2 layers come from one GeoServer Layer/data source, with two alternate styles. The 3rd layer is a separate GeoServer Layer ...
0
votes
2answers
104 views

How to get information about only one data point?

I have a vector-point shapefile. The data are not dense (about 1 x 1 degree). Lets say that every point includes value of average wind speed. I would like to create a interactive web-map so that ...
1
vote
1answer
36 views

GetFeatureInfo on TMS layer with OpenLayers

I'm using OpenLayers.Layer.TMS to display external layers that have a different projection than EPSG3857/EPSG900913. I followed this tutorial. Now I can't use OpenLayers.Control.WMSGetFeatureInfo or ...
1
vote
1answer
302 views

How to get the result of wms getFeatureInfo Request result into a array

I am using openlayers 2.1.3 and using open layers i get the featureinfo result but it is a web page i want to get the output fields into a variable so i can display them in grid, Plz help me
1
vote
0answers
134 views

openLayers and geoserver: WMSGetFeatureInfo does not return feature beyond wrapdateline

I built a map made of several layers. I need to display the layers features fields at the place where the user clicks (see the controler code hereafter). The layers are correctly displayed and go ...
1
vote
1answer
229 views

GeoServer: Combining multiple raster stores into one wms layer

I would like to publish a DTM as WMS using GeoServer. For the visual part I have a hillshaded version of the DTM and the original DTM contains the height as floating points (level above sea). ...
1
vote
1answer
67 views

How to query data like only for point by from a grouplayer by using WMSGetFeatureInfo in Openlayers?

till now I have been known how to query data from a groupLayer by using WMSGetFeatureInfo while the point is it shows a lot of associate results features,so I aim to query a single layer infomation ...
1
vote
1answer
146 views

How to activate and deactivate popup feature in OpenLayers?

I am a beginner in OpenLayers and I want to activate and deactivate a popup feature, which has to show lat,long of the click, which is initiating the popup [no markers]. I am currently using ...
0
votes
0answers
126 views

OpenLayers - feaures from WMSGetFeatureInfo are not shown on layer (but they exists)

I have a project with google as base layer and geoserver serving WMS layers (structures - multipolygons) that are in EPSG:2039 The layers are showing fine on google base layer (I guess OL re-project ...
5
votes
1answer
185 views

Does WMS GetFeatureInfo takes into account the applied Style (SLD)?

As the title says, does WMS GetFeatureInfo takes into account the applied style to a layer? For example I have layer of all US States and I applied the following SLD: <PropertyIsEqualTo> ...
1
vote
1answer
2k views

How can I add an infowindow to an OpenLayers GeoJSON layer?

In my OpenLayers script I refer to an geojson layer. Is it possible to add an info window?If yes, how can I create this. Script is as follows: var lon = 5, lat = 52, zoom = 7, epsg4326 = ...
0
votes
1answer
2k views

open layers: how to acces an event attribute value from WMSGetFeatureInfo

My open layers script tries to get some features values from a WMS (which is a shapefile), to open a page in function of the attribute value returned. My problem is the following: - the code returns ...
1
vote
1answer
300 views

Is a proxy required to use OpenLayer's GetFeatureInfo?

My domain is hosted on HostGator and apparently they don't allow the use of proxies. I have a map that has a WMS point feature hosted from my GeoServer using OpenLayers. I want to be able to select ...
0
votes
2answers
657 views

Use GetFeatureInfo with OpenLayers and a Bounding Polygon

I want to be able to draw a bounding polygon and have my MapServer WMS layer return every feature within that bounding box. I have it working for a single point, but I would like for the query to ...
1
vote
0answers
37 views

Handling loading time for WMSGetFeatureInfo [closed]

I've got this code for a WMSGetFeatureInfo on Hover event: info.events.register("getfeatureinfo", this, function (evt){ ('#rastervalue').val(...)... }); my request to Geoserver takes ...
0
votes
1answer
459 views

OpenLayers CQL filter gets info about NOT VISIBLE features

I have a WMS layer and a control WMSGetFeatureInfo. If I apply a CQL Filter to the layer and I redraw it, the WMSGetFeatureInfo control continue querying also NOT VISIBLE features. Why in your ...
2
votes
0answers
237 views

WMSGetFeatureInfo : No feature found on click

My map displays well my WMS layers. When i try to get the feature info, the debugger tells me no feature is found features: Array[0] , length :0 I don't know if it is because of a projection issue: ...
0
votes
1answer
2k views

uncaught typeerror: undefined is not a function

Using some examples from internet, I found this code that shows WMSGetfeatureinfo I don't know where's the problem: Here goes my code: <!DOCTYPE HTML> <meta http-equiv="Content-Type" ...
6
votes
4answers
3k views

WMS GetFeatureInfo and CQL on Multiple Layers

I am having issues with querying CQL filtered layers with OpenLayers and GeoServer, using the GetFeatureInfo control. It is ignoring the CQL filter and just querying the entire layer (as evidenced by ...
0
votes
1answer
746 views

How to determine the accuracy of getFeatureInfo on a WMS layer?

I have added a WMS layer to the ArcGIS Server JSAPI and am attempting to query it using getFeatureInfo when the user clicks on the map. A reproducible sample is available here. This is mostly ...
1
vote
1answer
285 views

How to define HTML templates with QGIS Server?

I usually use HTML templates in map files to show nicely formatted popups on my WMS layers with Openlayers. Here is the doc on templating with mapserver I'd like to know if it is possible to do the ...
0
votes
0answers
1k views

OpenLayers.Protocol.WFS.fromWMSLayer not working

Hi I am trying to follow the example here http://openlayers.org/dev/examples/getfeature-wfs.html to select features from a WMS layer on Geoserver. var wms27 = new OpenLayers.Layer.WMS( ...
0
votes
0answers
595 views

WMSGetFeatureInfo returns an empty popup

I am building a web map application using Openlayers and Geoserver. Both the application and the geoserver are hosted on amazon. I would like to include a feature info tool and am using ...
0
votes
0answers
165 views

several fields and GEOMETRY GetFeatueInfo from Geoserver

Good day!. I have a table in PostGIS 2.0 with several fields of type GEOMETRY. In the geometry_columns they are published in Geoserver 2.2 as layers. This is done as here - geoserver docs, but ...
0
votes
0answers
390 views

Customize display of WMS GetFeatureInfo results

i have a popup that get the featureInfo on the map, what i want to do is to customize the display of the WMS GetInfo Results, i don't want to avoid automatic alphabetic sortingof the attribute ...
1
vote
0answers
209 views

Restrict featureinfo fetched with the WMSGetFeatureInfo request in geoserver

i followed a GeoEXT example to create popup menu that gets WMSFeatureinfo on click on the map, What i want to do is to get some specific fields not all the fields, i try the propertyName (with ...
3
votes
2answers
335 views

GeoServer cascading WMS, FeatureInfo is lost

I'm trying to cascade a WMS service in GeoServer (http://grb.agiv.be/geodiensten/raadpleegdiensten/GRB/wms?REQUEST=GetCapabilities&SERVICE=WMS). I can view the cascaded layers just fine, but ...
1
vote
0answers
198 views

Get info from WMS layer with Openlayers mobile

I am trying to build a webapp for iPad using OpenLayers Mobile. One of the features it should have is that you can tap on a tree displayed on a basemap and get info about this tree. These trees are ...
0
votes
1answer
1k views

I create getfeatureinfo with popup but it dosn't work (error 404) [duplicate]

This is my code for my page (index.html) info = new OpenLayers.Control.WMSGetFeatureInfo({ url: 'http://localhost:8080/geoserver/wms', title: 'get feature info', ...
0
votes
0answers
421 views

WMS getfeatureinfo() giving incorrect result

I am using openlayers and Geoserver. I have created a base layer using OSM and then added wms layer topp:states. I want to show a world map and on that show US states. I have added onclick ...
1
vote
3answers
2k views

WMSGetFeatureInfo not showing in Firefox and chrome

This code set works for me in IE but not in Firefox and chrome.What is the problem? Map is showing in all browsers ,but when i click on point of map nothing showing in Firefox and chrome. Welcome ...
7
votes
4answers
9k views

How to select fields returned by GeoServer WMS GetFeatureInfo request?

I'm running simple local mapping service based on PostGIS/GeoServer/OpenLayers stack. Following opengeo tutorial I've tied click events in OpenLayers to WMS GetFeatureInfo call using: ...
1
vote
1answer
2k views

How to get feature info from wms layer

I have used your code for picking feature info from wms layer using WMSGetFeatureInofo function.I have used you this link. ...
2
votes
2answers
1k views

GetFeatureInfo doesn't work!

I'm new at openlayers and I am having some trouble when trying to display the feature info. I have the map working, with the layers I want to add in, but it seems that when I try to ask for the info ...
5
votes
2answers
6k views

OpenLayers custom request for WMS GetFeatureInfo

In OpenLayers, there is a WMSGetFeatureInfo control that can be attached to a layer and listen to click or hover events on the map, requesting info on the feature being currently clicked (or pointed) ...
0
votes
1answer
63 views

What kind of different results or what is the difference between two URL based WMS requests [closed]

I am trying to retrieve some WMS layers from geoserver so that I can display them in leaflet and I need to populate a URL field and I noticed that many of the layers that I opened up in openlayers had ...
3
votes
0answers
263 views

How do I format tilelayer.wms url properties such that I add an overlay iteratively to my base map in leaflet

My base map was created using hard-coded template variables. I am using the leaflet tilelayer.wms constructor and including the url like so: url: ...
2
votes
2answers
2k views

How to select multiple polygons or points from WFS or WMS and getFeatureInfo

Is there a way to select multiple polygons and/or points from a WFS or WMS service and then get the feature information for each selected item? There are numerous examples on the OpenLayers website ...
1
vote
1answer
3k views

How to use getfeatureinfo with MapServer and OpenLayers?

I'm trying to use the getfeatureinfo function of Openlayers with MapServer. When I click on a point on my map, I get the following error in Firebug: <?xml version='1.0' encoding="ISO-8859-1" ...