a WMS (Web Map Server) standard call that retrieves the underlying data, including geometry and attribute values, for a pixel location on a map.

learn more… | top users | synonyms (1)

0
votes
0answers
111 views

OpenLayers - feaures from WMSGetFeatureInfo are not shown on layer (but they exists)

I have a project with google as base layer and geoserver serving WMS layers (structures - multipolygons) that are in EPSG:2039 The layers are showing fine on google base layer (I guess OL re-project ...
1
vote
1answer
142 views

WMTS GetFeatureInfo in android

I want to create something in android like this: http://openlayers.org/dev/examples/wmts-getfeatureinfo.html I'm able to load the costum tiles with WMTS but now i need to get data to show in some kind ...
0
votes
1answer
219 views

WMSGetFeatureInfo Not Returning Results

I am having a problem getting the results back from a WMSGetFeatureInfo call to my GeoServer. Using OpenLayers 2.12, GeoServer 2.4.0, Windows Server2008, and Microsoft IIS 7.5 with Application Request ...
3
votes
1answer
374 views

GeoServer GetFeatureInfo Template

I have for now just used the standard Get Feature Template in the documentation. The first example should make all the returned data format into bullets instead of little tables. For some reason my ...
0
votes
1answer
2k views

open layers: how to acces an event attribute value from WMSGetFeatureInfo

My open layers script tries to get some features values from a WMS (which is a shapefile), to open a page in function of the attribute value returned. My problem is the following: - the code returns ...
1
vote
1answer
252 views

Is a proxy required to use OpenLayer's GetFeatureInfo?

My domain is hosted on HostGator and apparently they don't allow the use of proxies. I have a map that has a WMS point feature hosted from my GeoServer using OpenLayers. I want to be able to select ...
0
votes
2answers
542 views

Use GetFeatureInfo with OpenLayers and a Bounding Polygon

I want to be able to draw a bounding polygon and have my MapServer WMS layer return every feature within that bounding box. I have it working for a single point, but I would like for the query to ...
1
vote
0answers
37 views

Handling loading time for WMSGetFeatureInfo [closed]

I've got this code for a WMSGetFeatureInfo on Hover event: info.events.register("getfeatureinfo", this, function (evt){ ('#rastervalue').val(...)... }); my request to Geoserver takes ...
2
votes
0answers
222 views

WMSGetFeatureInfo : No feature found on click

My map displays well my WMS layers. When i try to get the feature info, the debugger tells me no feature is found features: Array[0] , length :0 I don't know if it is because of a projection issue: ...
0
votes
1answer
380 views

OpenLayers CQL filter gets info about NOT VISIBLE features

I have a WMS layer and a control WMSGetFeatureInfo. If I apply a CQL Filter to the layer and I redraw it, the WMSGetFeatureInfo control continue querying also NOT VISIBLE features. Why in your ...
0
votes
1answer
620 views

How to determine the accuracy of getFeatureInfo on a WMS layer?

I have added a WMS layer to the ArcGIS Server JSAPI and am attempting to query it using getFeatureInfo when the user clicks on the map. A reproducible sample is available here. This is mostly ...
1
vote
1answer
247 views

How to define HTML templates with QGIS Server?

I usually use HTML templates in map files to show nicely formatted popups on my WMS layers with Openlayers. Here is the doc on templating with mapserver I'd like to know if it is possible to do the ...
0
votes
0answers
939 views

OpenLayers.Protocol.WFS.fromWMSLayer not working

Hi I am trying to follow the example here http://openlayers.org/dev/examples/getfeature-wfs.html to select features from a WMS layer on Geoserver. var wms27 = new OpenLayers.Layer.WMS( ...
1
vote
0answers
132 views

WMS: point “pointer” symbol with offset - getFeatureInfo search area slight mismatch

I'd like to ask what ways there might be to adjust a point's getFeatureInfo search area so that it matches a "pointer" (i.e slightly offset) symbol. We are running GeoServer 2.2.0 (part of an Opengeo ...
0
votes
0answers
539 views

WMSGetFeatureInfo returns an empty popup

I am building a web map application using Openlayers and Geoserver. Both the application and the geoserver are hosted on amazon. I would like to include a feature info tool and am using ...
0
votes
2answers
149 views

GetFeatureInfo for gxp_olsource in OGS GeoExplorer

We have an OpenGeo Suite GeoExplorer 3.0.1 and want to make GetFeatureInfo-requests, via the identify button, for WMS-layers of type gxp_olsource but it doesn't work, I get no response at all and I ...
0
votes
0answers
145 views

several fields and GEOMETRY GetFeatueInfo from Geoserver

Good day!. I have a table in PostGIS 2.0 with several fields of type GEOMETRY. In the geometry_columns they are published in Geoserver 2.2 as layers. This is done as here - geoserver docs, but ...
0
votes
0answers
339 views

Customize display of WMS GetFeatureInfo results

i have a popup that get the featureInfo on the map, what i want to do is to customize the display of the WMS GetInfo Results, i don't want to avoid automatic alphabetic sortingof the attribute ...
1
vote
0answers
180 views

Restrict featureinfo fetched with the WMSGetFeatureInfo request in geoserver

i followed a GeoEXT example to create popup menu that gets WMSFeatureinfo on click on the map, What i want to do is to get some specific fields not all the fields, i try the propertyName (with ...
2
votes
2answers
3k views

Openlayers & WMS - GetFeatureInfo problem

I'm making a small project but I encounter some problems. Let me explain that : Having generated mapfile with mapserver and they are viewable by the openlayers interface, I would like to make me ...
0
votes
1answer
134 views

WMS - Export Retrieved XML Data

I use WMS layer in my app and could successfully retrieved Feature Info by click like so: http://openlayers.org/dev/examples/getfeatureinfo-control.html My question is: Is there any way to export the ...
0
votes
1answer
1k views

uncaught typeerror: undefined is not a function

Using some examples from internet, I found this code that shows WMSGetfeatureinfo I don't know where's the problem: Here goes my code: <!DOCTYPE HTML> <meta http-equiv="Content-Type" ...
0
votes
1answer
170 views

How to configure mapproxy and mapnik for getfeatureinfo requests

I'm wondering if its possible to configure mapproxy and mapnik for getfeatureinfo requests. I've made this combination work for getmap requests, but when I request getfeatureinfo I receive layer xxx ...
3
votes
2answers
272 views

GeoServer cascading WMS, FeatureInfo is lost

I'm trying to cascade a WMS service in GeoServer (http://grb.agiv.be/geodiensten/raadpleegdiensten/GRB/wms?REQUEST=GetCapabilities&SERVICE=WMS). I can view the cascaded layers just fine, but ...
1
vote
2answers
104 views

How to specify one layer among many with getWMSInfo?

I am using getWMSFeatureInfo with multiple point layers. When I click on a point on map, how to specify which layer that point belongs to?
1
vote
0answers
191 views

Get info from WMS layer with Openlayers mobile

I am trying to build a webapp for iPad using OpenLayers Mobile. One of the features it should have is that you can tap on a tree displayed on a basemap and get info about this tree. These trees are ...
0
votes
1answer
1k views

I create getfeatureinfo with popup but it dosn't work (error 404) [duplicate]

This is my code for my page (index.html) info = new OpenLayers.Control.WMSGetFeatureInfo({ url: 'http://localhost:8080/geoserver/wms', title: 'get feature info', ...
1
vote
1answer
329 views

Get feature from two overlapping KML layers doesn't work

I did an implementation similar to http://openlayers.org/dev/examples/sundials.html The difference is that I have two or more kml layers at the same location and want to show their information ...
1
vote
1answer
245 views

Geoserver 2.1.3 no GetFeatureInfo-Response when multiple Features found on same location within same layer

I have a Geoserver postgis layer with multiple point features on the same location. GetFeatureInfo returns results when only one feature is found. But Geoserver returns nothing (empty html) when ...
0
votes
0answers
359 views

WMS getfeatureinfo() giving incorrect result

I am using openlayers and Geoserver. I have created a base layer using OSM and then added wms layer topp:states. I want to show a world map and on that show US states. I have added onclick ...
0
votes
2answers
272 views

prevent popup from appearing when clicking outside wms layer

Any help with this would be appreciated. I am projecting a WMS-layer on a map using OpenLayers and Geoserver. The next thing I want to do is to display info on any given feature in my WMS-layer in a ...
3
votes
0answers
232 views

Geoserver create SqlView Layer with Geoserver Manager

I would like to register a new sql view layer to geoserver through the rest api. I am using geoserver-manager. The registration is ok, the layer is working fine, except wms getFeatureInfo, which ...
2
votes
2answers
1k views

GetFeatureInfo doesn't work!

I'm new at openlayers and I am having some trouble when trying to display the feature info. I have the map working, with the layers I want to add in, but it seems that when I try to ask for the info ...
7
votes
2answers
4k views

How to make geoserver return JSON for WMS GetFeatureInfo?

I wish to get the results of a WMS GetFeatureInfo request as a JSON instead of the table that comes up by default. Out of the box, the only options for the response from a WMS GetFeatureInfo are the ...
1
vote
1answer
2k views

How can I add an infowindow to an OpenLayers GeoJSON layer?

In my OpenLayers script I refer to an geojson layer. Is it possible to add an info window?If yes, how can I create this. Script is as follows: var lon = 5, lat = 52, zoom = 7, epsg4326 = ...
0
votes
1answer
62 views

What kind of different results or what is the difference between two URL based WMS requests [closed]

I am trying to retrieve some WMS layers from geoserver so that I can display them in leaflet and I need to populate a URL field and I noticed that many of the layers that I opened up in openlayers had ...
3
votes
0answers
236 views

How do I format tilelayer.wms url properties such that I add an overlay iteratively to my base map in leaflet

My base map was created using hard-coded template variables. I am using the leaflet tilelayer.wms constructor and including the url like so: url: ...
1
vote
1answer
3k views

How to use getfeatureinfo with MapServer and OpenLayers?

I'm trying to use the getfeatureinfo function of Openlayers with MapServer. When I click on a point on my map, I get the following error in Firebug: <?xml version='1.0' encoding="ISO-8859-1" ...
1
vote
1answer
2k views

How to get feature info from wms layer

I have used your code for picking feature info from wms layer using WMSGetFeatureInofo function.I have used you this link. ...
1
vote
1answer
497 views

Creating a GeoExt Action from OpenLayers Function

I am trying to create a GeoExt function out of this OpenLayers function, which displays the getFeatureInfo. I was able to create this GeoExt.Action() but it does not give me any output. Any idea ...
5
votes
2answers
5k views

OpenLayers custom request for WMS GetFeatureInfo

In OpenLayers, there is a WMSGetFeatureInfo control that can be attached to a layer and listen to click or hover events on the map, requesting info on the feature being currently clicked (or pointed) ...
0
votes
1answer
455 views

add grid to GetFeature Info tool

I have added the GetFeatureInfo Tool to my Viewer but the PopUp does not have a grid in it to display the Feature Info neatly. How do I get the grid layout in the Feature Info PopUp, like the one ...
1
vote
0answers
99 views

Wrong data with FEATURE_COUNT=1 for GetFeatureInfo

When I am querying the WMS service with FEATURE_COUNT=1 then I get the wrong meta data. Once I make FEATURE_COUNT=2 then first row contains the correct data. I am executing the URL directly in ...
1
vote
1answer
199 views

How show some fields only when using WMSGetFeatureInfo?

How to show some important field only when using WMSGetFeatureInfo.I use this example. When I click on maps it show all the fields of attribute table.What part should I modify in above mentioned code. ...
1
vote
2answers
960 views

Prevent layer from WMSGetFeatureInfo request on openlayers web map

I use this example code get feature info from my openlayers web map.I add 4 layers to map including raster image as base map. But i don't need feature info from that raster layer.But when clicking on ...
1
vote
1answer
958 views

Displaying Feature Info for a user defined polygon

To retrieve feature info for a polygon selection, I have the OpenLayers code below: var featureTypes = ["nig_admin1", "nig_admin2", "nig_admin3", "nig_landscan"]; var populationCtrl ...
2
votes
3answers
2k views

OpenLayers GetFeatureInfo for GeoServer Layer Groups

I've created a GeoServer layer group. I'm using OpenLayers.Layer.WMS to retrieve the layer group, and this works fine. In addition, I'd like to pull feature info for the layer. For this, I'm using ...
1
vote
1answer
1k views

How to use cql_filter in OpenLayers.Control.WMSGetFeatureInfo?

I am a newbie and I am using OpenLayers, GeoServer 2.1.3. I have a function that works to filter the markers on the map with a CQL_FILTER function. But when I click on a marker it shows a popup with ...
2
votes
2answers
1k views

How to select multiple polygons or points from WFS or WMS and getFeatureInfo

Is there a way to select multiple polygons and/or points from a WFS or WMS service and then get the feature information for each selected item? There are numerous examples on the OpenLayers website ...
1
vote
3answers
2k views

WMSGetFeatureInfo not showing in Firefox and chrome

This code set works for me in IE but not in Firefox and chrome.What is the problem? Map is showing in all browsers ,but when i click on point of map nothing showing in Firefox and chrome. Welcome ...