A WMS (Web Map Server) request that retrieves data, for a pixel location on a map.

learn more… | top users | synonyms (1)

0
votes
2answers
73 views

WMS GetFeatureInfo with No Location

I am using Geoserver with OpenLayers. I would like to return all the feature type details in a specific layer exactly as GetFeatureInfo does for a specified location. I tried using GetFeatureInfo ...
1
vote
3answers
2k views

Google Maps with shapefile/WMS - get feature info problem

I've just created my first Geoserver "portal". For this I created 2 .js files. In first .js file I have Google Maps API and in the second .js file I have my shapefile. Directly from Geoserver I can ...
1
vote
0answers
371 views

Configuring Mapproxy + Mapnik for using Getfeatureinfo

This is probably a duplicate of this question: How to configure mapproxy and mapnik for getfeatureinfo requests, however, that one is old and still unanswered. I'm trying to configure a Mapproxy ...
2
votes
1answer
246 views

WMTS GetFeatureInfo in android

I want to create something in android like this: http://openlayers.org/dev/examples/wmts-getfeatureinfo.html I'm able to load the costum tiles with WMTS but now i need to get data to show in some kind ...
0
votes
0answers
312 views

Point Layer WMS GetFeatureInfo failing when zoom in

I have a problem that i think is related with the interaction between OpenLayers and my Google map Base Layer (inconsistencies with coordinates systems, or something like that). Maybe also this could ...
1
vote
0answers
74 views

No Popup for bottom layers, only top layer works

I have an OpenLayers Map. On this map, I have three overlay layers. The first 2 layers come from one GeoServer Layer/data source, with two alternate styles. The 3rd layer is a separate GeoServer Layer ...
0
votes
2answers
127 views

How to get information about only one data point?

I have a vector-point shapefile. The data are not dense (about 1 x 1 degree). Lets say that every point includes value of average wind speed. I would like to create a interactive web-map so that ...
1
vote
1answer
53 views

GetFeatureInfo on TMS layer with OpenLayers

I'm using OpenLayers.Layer.TMS to display external layers that have a different projection than EPSG3857/EPSG900913. I followed this tutorial. Now I can't use OpenLayers.Control.WMSGetFeatureInfo or ...
1
vote
1answer
563 views

How to get the result of wms getFeatureInfo Request result into a array

I am using openlayers 2.1.3 and using open layers i get the featureinfo result but it is a web page i want to get the output fields into a variable so i can display them in grid, Plz help me
2
votes
0answers
196 views

openLayers and geoserver: WMSGetFeatureInfo does not return feature beyond wrapdateline

I built a map made of several layers. I need to display the layers features fields at the place where the user clicks (see the controler code hereafter). The layers are correctly displayed and go ...
1
vote
1answer
581 views

GeoServer: Combining multiple raster stores into one wms layer

I would like to publish a DTM as WMS using GeoServer. For the visual part I have a hillshaded version of the DTM and the original DTM contains the height as floating points (level above sea). ...
1
vote
1answer
102 views

How to query data like only for point by from a grouplayer by using WMSGetFeatureInfo in Openlayers?

till now I have been known how to query data from a groupLayer by using WMSGetFeatureInfo while the point is it shows a lot of associate results features,so I aim to query a single layer infomation ...
1
vote
1answer
233 views

How to activate and deactivate popup feature in OpenLayers?

I am a beginner in OpenLayers and I want to activate and deactivate a popup feature, which has to show lat,long of the click, which is initiating the popup [no markers]. I am currently using ...
0
votes
0answers
186 views

OpenLayers - feaures from WMSGetFeatureInfo are not shown on layer (but they exists)

I have a project with google as base layer and geoserver serving WMS layers (structures - multipolygons) that are in EPSG:2039 The layers are showing fine on google base layer (I guess OL re-project ...
5
votes
1answer
307 views

Does WMS GetFeatureInfo takes into account the applied Style (SLD)?

As the title says, does WMS GetFeatureInfo takes into account the applied style to a layer? For example I have layer of all US States and I applied the following SLD: <PropertyIsEqualTo> <...
1
vote
1answer
4k views

How can I add an infowindow to an OpenLayers GeoJSON layer?

In my OpenLayers script I refer to an geojson layer. Is it possible to add an info window?If yes, how can I create this. Script is as follows: var lon = 5, lat = 52, zoom = 7, epsg4326 = ...
0
votes
1answer
3k views

open layers: how to acces an event attribute value from WMSGetFeatureInfo

My open layers script tries to get some features values from a WMS (which is a shapefile), to open a page in function of the attribute value returned. My problem is the following: - the code returns ...
1
vote
1answer
413 views

Is a proxy required to use OpenLayer's GetFeatureInfo?

My domain is hosted on HostGator and apparently they don't allow the use of proxies. I have a map that has a WMS point feature hosted from my GeoServer using OpenLayers. I want to be able to select ...
2
votes
2answers
1k views

Use GetFeatureInfo with OpenLayers and a Bounding Polygon

I want to be able to draw a bounding polygon and have my MapServer WMS layer return every feature within that bounding box. I have it working for a single point, but I would like for the query to ...
0
votes
1answer
738 views

OpenLayers CQL filter gets info about NOT VISIBLE features

I have a WMS layer and a control WMSGetFeatureInfo. If I apply a CQL Filter to the layer and I redraw it, the WMSGetFeatureInfo control continue querying also NOT VISIBLE features. Why in your opinion?...
3
votes
0answers
352 views

WMSGetFeatureInfo : No feature found on click

My map displays well my WMS layers. When i try to get the feature info, the debugger tells me no feature is found features: Array[0] , length :0 I don't know if it is because of a projection issue: ...
0
votes
1answer
3k views

uncaught typeerror: undefined is not a function

Using some examples from internet, I found this code that shows WMSGetfeatureinfo I don't know where's the problem: Here goes my code: <!DOCTYPE HTML> <meta http-equiv="Content-Type" ...
6
votes
4answers
5k views

WMS GetFeatureInfo and CQL on Multiple Layers

I am having issues with querying CQL filtered layers with OpenLayers and GeoServer, using the GetFeatureInfo control. It is ignoring the CQL filter and just querying the entire layer (as evidenced by ...
1
vote
1answer
439 views

How to define HTML templates with QGIS Server?

I usually use HTML templates in map files to show nicely formatted popups on my WMS layers with Openlayers. Here is the doc on templating with mapserver I'd like to know if it is possible to do the ...
0
votes
0answers
1k views

OpenLayers.Protocol.WFS.fromWMSLayer not working

Hi I am trying to follow the example here http://openlayers.org/dev/examples/getfeature-wfs.html to select features from a WMS layer on Geoserver. var wms27 = new OpenLayers.Layer.WMS( ...
0
votes
0answers
760 views

WMSGetFeatureInfo returns an empty popup

I am building a web map application using Openlayers and Geoserver. Both the application and the geoserver are hosted on amazon. I would like to include a feature info tool and am using ...
0
votes
0answers
247 views

several fields and GEOMETRY GetFeatueInfo from Geoserver

Good day!. I have a table in PostGIS 2.0 with several fields of type GEOMETRY. In the geometry_columns they are published in Geoserver 2.2 as layers. This is done as here - geoserver docs, but ...
0
votes
0answers
588 views

Customize display of WMS GetFeatureInfo results

i have a popup that get the featureInfo on the map, what i want to do is to customize the display of the WMS GetInfo Results, i don't want to avoid automatic alphabetic sortingof the attribute ...
1
vote
0answers
248 views

Get info from WMS layer with Openlayers mobile

I am trying to build a webapp for iPad using OpenLayers Mobile. One of the features it should have is that you can tap on a tree displayed on a basemap and get info about this tree. These trees are ...
0
votes
1answer
2k views

I create getfeatureinfo with popup but it dosn't work (error 404) [duplicate]

This is my code for my page (index.html) info = new OpenLayers.Control.WMSGetFeatureInfo({ url: 'http://localhost:8080/geoserver/wms', title: 'get feature info', ...
0
votes
0answers
601 views

WMS getfeatureinfo() giving incorrect result

I am using openlayers and Geoserver. I have created a base layer using OSM and then added wms layer topp:states. I want to show a world map and on that show US states. I have added onclick ...
1
vote
3answers
2k views

WMSGetFeatureInfo not showing in Firefox and chrome

This code set works for me in IE but not in Firefox and chrome.What is the problem? Map is showing in all browsers ,but when i click on point of map nothing showing in Firefox and chrome. Welcome ...
1
vote
1answer
2k views

How to get feature info from wms layer

I have used your code for picking feature info from wms layer using WMSGetFeatureInofo function.I have used you this link. http://underdark.wordpress.com/2011/03/17/picking-a-features-attribute-value-...
2
votes
2answers
2k views

GetFeatureInfo doesn't work!

I'm new at openlayers and I am having some trouble when trying to display the feature info. I have the map working, with the layers I want to add in, but it seems that when I try to ask for the info ...
5
votes
2answers
8k views

OpenLayers custom request for WMS GetFeatureInfo

In OpenLayers, there is a WMSGetFeatureInfo control that can be attached to a layer and listen to click or hover events on the map, requesting info on the feature being currently clicked (or pointed) ...
0
votes
1answer
68 views

What kind of different results or what is the difference between two URL based WMS requests [closed]

I am trying to retrieve some WMS layers from geoserver so that I can display them in leaflet and I need to populate a URL field and I noticed that many of the layers that I opened up in openlayers had ...
3
votes
0answers
351 views

How do I format tilelayer.wms url properties such that I add an overlay iteratively to my base map in leaflet

My base map was created using hard-coded template variables. I am using the leaflet tilelayer.wms constructor and including the url like so: url: "http://localhost:8080/geoserver/sf/wmsservice=WMS&...
2
votes
2answers
2k views

How to select multiple polygons or points from WFS or WMS and getFeatureInfo

Is there a way to select multiple polygons and/or points from a WFS or WMS service and then get the feature information for each selected item? There are numerous examples on the OpenLayers website ...
1
vote
1answer
5k views

How to use getfeatureinfo with MapServer and OpenLayers?

I'm trying to use the getfeatureinfo function of Openlayers with MapServer. When I click on a point on my map, I get the following error in Firebug: <?xml version='1.0' encoding="ISO-8859-1" ...
1
vote
1answer
673 views

Creating a GeoExt Action from OpenLayers Function

I am trying to create a GeoExt function out of this OpenLayers function, which displays the getFeatureInfo. I was able to create this GeoExt.Action() but it does not give me any output. Any idea ...
0
votes
1answer
533 views

add grid to GetFeature Info tool

I have added the GetFeatureInfo Tool to my Viewer but the PopUp does not have a grid in it to display the Feature Info neatly. How do I get the grid layout in the Feature Info PopUp, like the one ...
1
vote
1answer
1k views

Displaying Feature Info for a user defined polygon

To retrieve feature info for a polygon selection, I have the OpenLayers code below: var featureTypes = ["nig_admin1", "nig_admin2", "nig_admin3", "nig_landscan"]; var populationCtrl =...
1
vote
0answers
175 views

Wrong data with FEATURE_COUNT=1 for GetFeatureInfo

When I am querying the WMS service with FEATURE_COUNT=1 then I get the wrong meta data. Once I make FEATURE_COUNT=2 then first row contains the correct data. I am executing the URL directly in ...
1
vote
1answer
209 views

How show some fields only when using WMSGetFeatureInfo?

How to show some important field only when using WMSGetFeatureInfo.I use this example. When I click on maps it show all the fields of attribute table.What part should I modify in above mentioned code. ...
1
vote
2answers
1k views

Prevent layer from WMSGetFeatureInfo request on openlayers web map

I use this example code get feature info from my openlayers web map.I add 4 layers to map including raster image as base map. But i don't need feature info from that raster layer.But when clicking on ...
1
vote
1answer
2k views

How to use cql_filter in OpenLayers.Control.WMSGetFeatureInfo?

I am a newbie and I am using OpenLayers, GeoServer 2.1.3. I have a function that works to filter the markers on the map with a CQL_FILTER function. But when I click on a marker it shows a popup with ...
3
votes
2answers
6k views

Use OpenLayers WMSGetFeatureInfo on Mapserver Layer?

I'm able to use OpenLayers' OpenLayers.Layer.Mapserver declaration to generate a raster from GRIB data. I've read in the MapServer docs and on forums that it should be possible to get point ...
6
votes
1answer
3k views

How to select multiple Features from multiple Layers in OpenLayers?

Is there a way to select multiple features from multiple vector layers by using clickTolerance in click? I checked the documents of getFeature control and selectFeature control, seems not work in ...
2
votes
1answer
3k views

WMS Request Returns nothing with Geoserver

I'm having trouble with a select feature example in Geoserver and open layers. For some reason the request returns nothing. Here's the stripped down version that produces this: I have a small wms ...
2
votes
1answer
3k views

'Select' and 'hover over' features are not working although no error is displayed (openlayers)

On the following html code i get no errors when i check it on firebug. When i select or hover over features i want to see them "highlighted". When i move my cursor onto a feature i can see that ...