A WMS (Web Map Server) request that retrieves data, for a pixel location on a map.

learn more… | top users | synonyms (1)

3
votes
1answer
58 views

Click event returning wrong Y container point in Leaflet

I am using QGIS Server and Leaflet to display geotiffs on my website. I have created an onMapClick function which uses a GetFeatureInfo request to QGIS Server which returns the value of the geotiff in ...
2
votes
1answer
2k views

How to deactivate Vector Selection In OpenLayers wms features

This is my sample code and work fine :), But I have a little problem, I'm using multiple layers (WMS), when I zoom the layer will be shown or hidden. In my example bellow when OpenLayers level zoom ...
1
vote
1answer
34 views

wmsgetfeatureinfo and GWC

I have one layer group glayer1 cached and I get the tiles from GWC. In glayer1, some layers are not queryable. I have layer2 which is queryable and contains short information. glayer1 is visible, ...
1
vote
1answer
53 views

GetFeatureInfo on TMS layer with OpenLayers

I'm using OpenLayers.Layer.TMS to display external layers that have a different projection than EPSG3857/EPSG900913. I followed this tutorial. Now I can't use OpenLayers.Control.WMSGetFeatureInfo or ...
1
vote
1answer
294 views

Restrict featureinfo fetched with the WMSGetFeatureInfo request in geoserver

i followed a GeoEXT example to create popup menu that gets WMSFeatureinfo on click on the map, What i want to do is to get some specific fields not all the fields, i try the propertyName (with name1,...
1
vote
1answer
437 views

Geoserver 2.1.3 no GetFeatureInfo-Response when multiple Features found on same location within same layer

I have a Geoserver postgis layer with multiple point features on the same location. GetFeatureInfo returns results when only one feature is found. But Geoserver returns nothing (empty html) when ...
0
votes
1answer
114 views

scripting getfeatureinfo for multiple wms layers

I am not really a programmer and I'm trying to create a webservice. I copy and pasted some script examples which made my script what it is now. I have multiple wms layers, but want to show different ...
0
votes
1answer
103 views

Making get feature request to forget between clicks in OpenLayers 3

I currently have a map with projects on it that when you click on it, it returns the information of said project using the code below. The issue i'm having is that every so often it will duplicate ...
5
votes
0answers
335 views

Geoserver create SqlView Layer with Geoserver Manager

I would like to register a new sql view layer to geoserver through the rest api. I am using geoserver-manager. The registration is ok, the layer is working fine, except wms getFeatureInfo, which ...
3
votes
0answers
355 views

WMSGetFeatureInfo : No feature found on click

My map displays well my WMS layers. When i try to get the feature info, the debugger tells me no feature is found features: Array[0] , length :0 I don't know if it is because of a projection issue: ...
3
votes
0answers
352 views

How do I format tilelayer.wms url properties such that I add an overlay iteratively to my base map in leaflet

My base map was created using hard-coded template variables. I am using the leaflet tilelayer.wms constructor and including the url like so: url: "http://localhost:8080/geoserver/sf/wmsservice=WMS&...
2
votes
0answers
69 views

Openlayers 3, getfeatureinfo and geowebcache

I am having a bit of trouble using the getGetFeatureInfo function on the TileWMS source in OL3. It works, but it represents the X/Y-parameters as I/J in the generated URL. /geowebcache/service/wms?...
2
votes
0answers
196 views

openLayers and geoserver: WMSGetFeatureInfo does not return feature beyond wrapdateline

I built a map made of several layers. I need to display the layers features fields at the place where the user clicks (see the controler code hereafter). The layers are correctly displayed and go ...
2
votes
0answers
536 views

Extending Identify widget and connect it with Legend widget

Sorry if it's a very basic question but I am new in Flex. I am using latest Flex Identify widget and I have created my own legend widget. What I am trying to do is, when a user select a point using ...
1
vote
0answers
18 views

Displaying GeoServer WMS GetFeatureInfo in ArcGIS Pro?

I recently set-up a GeoServer WMS endpoint with GeoWebCache. I can get the WMS layer to display fine in ArcGis Pro 1.2. When I click on the map to get feature information then I can see the ...
1
vote
0answers
16 views

How to print various wms layers of geoserver dynamically?

i want to print various layers of Geoserver dynamically.the printing code should extract all the layers present in geoserver. the user may some times add or remove the layers therefore the print ...
1
vote
0answers
34 views

WMS Layer Properties

I have created a gxp client where I have added some layer in the initial map settings and some layer can be added using gxp Add Layers plugin. When I add these layers to the map there is no issue with ...
1
vote
0answers
59 views

Geoserver 2.5.4 getfeatureinfo intermittent: [freemarker.runtime] - Template processing error: "Expression feature.<column> is undefined

We have a Geoserver serving a number of WMS layers from a PostGIS backend. Two are polygon layers with a content.ftl defined for getfeatureinfo requests. These two randomly but rather often fail to ...
1
vote
0answers
64 views

WMSGetFeatureInfo from two WMS layers with different parameters

I have a map with two layers, which can (and almost always do) overlap. These layers are WMS from GeoServer using SQL views (POSTGIS). They use the same query but with a different parameter. My hover ...
1
vote
0answers
81 views

GetFeatureInformation Button Won't Retrieve data in a shapefile

I'm using HERON with google maps,everything seems to be fine except for the getFeatureInformation. I'm not really sure what the problem is as I'm still a beginner. I don't know if it's the layer ...
1
vote
0answers
91 views

Getfeatureinfo is not working with geoserver point line sources

I'm not able to get information with Getfeatureinfo when clicking on point & line layers. For polygons it works fine. I'm using the code below to execute the WMS service: google.maps.event ....
1
vote
0answers
325 views

How to get feature on vector layer in Openlayers 3?

I'm try to get feature of a vector layer, but I'll have 3 or more Vector layer. When I click the map, I didn't get the feature. My vector layer definition; var vectorAltAlan = new ol.layer.Vector({ ...
1
vote
0answers
190 views

edit openlayers feature attribute and save in geoserver

I have a layer in geoserver and I want to get this layer with WMS in OpenLayers. population = new OpenLayers.Layer.WMS("population", "http://localhost:8080/geoserver/world/wms", {'layers': '...
1
vote
0answers
372 views

Configuring Mapproxy + Mapnik for using Getfeatureinfo

This is probably a duplicate of this question: How to configure mapproxy and mapnik for getfeatureinfo requests, however, that one is old and still unanswered. I'm trying to configure a Mapproxy ...
1
vote
0answers
74 views

No Popup for bottom layers, only top layer works

I have an OpenLayers Map. On this map, I have three overlay layers. The first 2 layers come from one GeoServer Layer/data source, with two alternate styles. The 3rd layer is a separate GeoServer Layer ...
1
vote
0answers
230 views

WMS: point “pointer” symbol with offset - getFeatureInfo search area slight mismatch

I'd like to ask what ways there might be to adjust a point's getFeatureInfo search area so that it matches a "pointer" (i.e slightly offset) symbol. We are running GeoServer 2.2.0 (part of an Opengeo ...
1
vote
0answers
248 views

Get info from WMS layer with Openlayers mobile

I am trying to build a webapp for iPad using OpenLayers Mobile. One of the features it should have is that you can tap on a tree displayed on a basemap and get info about this tree. These trees are ...
1
vote
0answers
175 views

Wrong data with FEATURE_COUNT=1 for GetFeatureInfo

When I am querying the WMS service with FEATURE_COUNT=1 then I get the wrong meta data. Once I make FEATURE_COUNT=2 then first row contains the correct data. I am executing the URL directly in ...
0
votes
0answers
11 views

Problem with Proxy url for geoserver WMS service

I am using Proxy to access geoserver service in openlayer 3, but my problem is when I am using proxy to access wfs service it is working fine but when I am using proxy url to access WMS service it is ...
0
votes
0answers
17 views

WMS GetFeatureInfo html popup

I need to publish WMS service with GetFeatureInfo but I want to hide some fields. I've made them not visible using layer properties in ArcMap but it resolved the problem partially. When I add WMS ...
0
votes
0answers
46 views

GetFeatureInfo with a Bounding Polygon

I am currently developing an application using Openlayers. I have a function in which I query a WMS service with the coordinate of a point in which a click to get the pixel value of a raster layer at ...
0
votes
0answers
28 views

GetFeatureInfo on a cascading WMS Connection using GeoServer

I have a web application developed in OpenLayers 2.13 that makes a GetFeatureInfo request on a layer, ws:gl_structure, published by a GeoServer (GeoServer_front). The layer gl_structure is a layer ...
0
votes
0answers
186 views

getGetinfoFeature problem. openlayers 3, geoserver

I am very new in Web mapping. Here I managed to code this. I have a layer in geoserver that is overlayed on a basemap in openlayers. then I wanted to get the feature info. <html> <head> ...
0
votes
0answers
31 views

Date format in GeoServer WMS requests strange

I got some date values in layer properties. When i use GetFeatureInfo request to WMS, i got date on day back, for example in DB or in WFS requests or in layer preview it is '2015-04-10', but i got '...
0
votes
0answers
47 views

select a feature by drawing a circle and selecting the contents

Using openLayers Two....Select a feature with a circle select tool....Is this possible? I can draw a circle polygon on the map using a regularPolygon with 100 sides : g_vectorTable[layerIndex]....
0
votes
0answers
65 views

Android call WFS getFeature Service returns empty

I am trying t call a WFS getFeature service to "implement" onClick get feature attribute popup (info window) but i am getting empty json . here is WFS link that i am calling http://geo-polis.gistemp....
0
votes
0answers
91 views

WMSGetFeatureInfo from layer with stackedpoint style

I have problem with WMSGetFeatureInfo. When i try it with layer styling stackedpoint i get exception: java.lang.IllegalArgumentException: Can't find neither a FeatureType nor a CoverageInfo or ...
0
votes
0answers
121 views

GetFeatureInfo / Geoserver + Openlayers 3 take values?

I have a problem with my GetfeatureInfo I use this code: map.on('singleclick', function(evt) { document.getElementById('info').innerHTML = ''; var viewResolution = /** @type {number} */ (...
0
votes
0answers
430 views

TileWMS JSONP getGetFeatureInfoUrl request using OpenLayers 3

I have a web map in Open Layers 3 which has some TileWMS layers from GeoServer 2.5 that I would like to query when the user clicks on the map. I am trying to use the tutorial here (https://...
0
votes
0answers
139 views

How to expose map sublayers on qgis web client

Within the QGIS Web Client, how does one enable the sublayers of Map Layers to be exposed? On my QGIS application, I have created a QGIS project file comprised of a chloropleth map (or a graduated ...
0
votes
0answers
14 views

List of default attribute of a feature?

I am working with c++/!qt with the c++ api qgis 2.8.2 for a stand alone project application I had to change and add attribute for feature Does anyone know where i can find the default attribute of a ...
0
votes
0answers
217 views

WMS GetFeatureInfo not returning all coordinates of geometry

I have some geoserver layers created from PostGIS tables. I load them on map using OpenLayers and use WMS GetFeatureInfo to get features on mouse click. I have observed that GetFeatureInfo request ...
0
votes
0answers
94 views

Why is ArcGIS Server 10.0 getFeatureInfo not being buffered?

Using AGS10.0 I have a point featureclass published as wms. In my Openlayers client, I am not able to click on the point and recieve the GetFeatureInfo response unless I hit the target very accurately....
0
votes
0answers
312 views

Point Layer WMS GetFeatureInfo failing when zoom in

I have a problem that i think is related with the interaction between OpenLayers and my Google map Base Layer (inconsistencies with coordinates systems, or something like that). Maybe also this could ...
0
votes
0answers
186 views

OpenLayers - feaures from WMSGetFeatureInfo are not shown on layer (but they exists)

I have a project with google as base layer and geoserver serving WMS layers (structures - multipolygons) that are in EPSG:2039 The layers are showing fine on google base layer (I guess OL re-project ...
0
votes
0answers
1k views

OpenLayers.Protocol.WFS.fromWMSLayer not working

Hi I am trying to follow the example here http://openlayers.org/dev/examples/getfeature-wfs.html to select features from a WMS layer on Geoserver. var wms27 = new OpenLayers.Layer.WMS( ...
0
votes
0answers
760 views

WMSGetFeatureInfo returns an empty popup

I am building a web map application using Openlayers and Geoserver. Both the application and the geoserver are hosted on amazon. I would like to include a feature info tool and am using ...
0
votes
0answers
248 views

several fields and GEOMETRY GetFeatueInfo from Geoserver

Good day!. I have a table in PostGIS 2.0 with several fields of type GEOMETRY. In the geometry_columns they are published in Geoserver 2.2 as layers. This is done as here - geoserver docs, but ...
0
votes
0answers
589 views

Customize display of WMS GetFeatureInfo results

i have a popup that get the featureInfo on the map, what i want to do is to customize the display of the WMS GetInfo Results, i don't want to avoid automatic alphabetic sortingof the attribute ...
0
votes
0answers
602 views

WMS getfeatureinfo() giving incorrect result

I am using openlayers and Geoserver. I have created a base layer using OSM and then added wms layer topp:states. I want to show a world map and on that show US states. I have added onclick ...