A WMS (Web Map Server) request that retrieves data, for a pixel location on a map.

learn more… | top users | synonyms (1)

8
votes
5answers
11k views

How to select fields returned by GeoServer WMS GetFeatureInfo request?

I'm running simple local mapping service based on PostGIS/GeoServer/OpenLayers stack. Following opengeo tutorial I've tied click events in OpenLayers to WMS GetFeatureInfo call using: ...
7
votes
3answers
9k views

How to make geoserver return JSON for WMS GetFeatureInfo?

I wish to get the results of a WMS GetFeatureInfo request as a JSON instead of the table that comes up by default. Out of the box, the only options for the response from a WMS GetFeatureInfo are the ...
6
votes
4answers
5k views

WMS GetFeatureInfo and CQL on Multiple Layers

I am having issues with querying CQL filtered layers with OpenLayers and GeoServer, using the GetFeatureInfo control. It is ignoring the CQL filter and just querying the entire layer (as evidenced by ...
6
votes
1answer
3k views

How to select multiple Features from multiple Layers in OpenLayers?

Is there a way to select multiple features from multiple vector layers by using clickTolerance in click? I checked the documents of getFeature control and selectFeature control, seems not work in ...
5
votes
2answers
8k views

OpenLayers custom request for WMS GetFeatureInfo

In OpenLayers, there is a WMSGetFeatureInfo control that can be attached to a layer and listen to click or hover events on the map, requesting info on the feature being currently clicked (or pointed) ...
5
votes
1answer
292 views

Does WMS GetFeatureInfo takes into account the applied Style (SLD)?

As the title says, does WMS GetFeatureInfo takes into account the applied style to a layer? For example I have layer of all US States and I applied the following SLD: <PropertyIsEqualTo> ...
5
votes
1answer
39 views

WMS GetFeatureInfo Request

I am attempting to teach myself how to make a basic GetFeatureInfo request on a WMS (specifically from Geomet, GetCapabilities here). The following returns 400 Bad Request, and I'm not sure if it is a ...
5
votes
0answers
330 views

Geoserver create SqlView Layer with Geoserver Manager

I would like to register a new sql view layer to geoserver through the rest api. I am using geoserver-manager. The registration is ok, the layer is working fine, except wms getFeatureInfo, which ...
4
votes
3answers
588 views

GeoServer cascading WMS, FeatureInfo is lost

I'm trying to cascade a WMS service in GeoServer (http://grb.agiv.be/geodiensten/raadpleegdiensten/GRB/wms?REQUEST=GetCapabilities&SERVICE=WMS). I can view the cascaded layers just fine, but ...
4
votes
1answer
194 views

Can ArcGIS Server 10.1 getFeatureInfo return the geometry?

Using GeoServer I can make a WMS getFeatureInfo request using the application/vnd.ogc.gml info_format and it returns the full GML of the feature, including the geometry. This is really useful as I ...
4
votes
1answer
720 views

GeoServer GetFeatureInfo Template

I have for now just used the standard Get Feature Template in the documentation. The first example should make all the returned data format into bullets instead of little tables. For some reason my ...
3
votes
2answers
6k views

Use OpenLayers WMSGetFeatureInfo on Mapserver Layer?

I'm able to use OpenLayers' OpenLayers.Layer.Mapserver declaration to generate a raster from GRIB data. I've read in the MapServer docs and on forums that it should be possible to get point ...
3
votes
2answers
2k views

WMS GetFeatureInfo and Google maps api V3

Is there a way to request GetFeatureInfo from a WMS service with the Google maps api v3?
3
votes
1answer
257 views

Openlayers: how to remove the FID field with the WMSGetFeatureInfo function?

I'm using the WMSGetFeatureInfo control of Openlayers in order to have a pupop in the map with the WMS layer info. Automatically Openlayers inserts a FID field at the beginning of the popup. Is there ...
3
votes
0answers
339 views

WMSGetFeatureInfo : No feature found on click

My map displays well my WMS layers. When i try to get the feature info, the debugger tells me no feature is found features: Array[0] , length :0 I don't know if it is because of a projection issue: ...
3
votes
0answers
342 views

How do I format tilelayer.wms url properties such that I add an overlay iteratively to my base map in leaflet

My base map was created using hard-coded template variables. I am using the leaflet tilelayer.wms constructor and including the url like so: url: ...
2
votes
2answers
1k views

Use GetFeatureInfo with OpenLayers and a Bounding Polygon

I want to be able to draw a bounding polygon and have my MapServer WMS layer return every feature within that bounding box. I have it working for a single point, but I would like for the query to ...
2
votes
3answers
2k views

How send Geoserver WMS GetFeatureInfo query to an area

I am using GetFeatureInfo query to WMS service. When I click a WMS object on the map, the response is coming. http://localhost:8080/geoserver/wms? request=GetFeatureInfo &service=WMS ...
2
votes
3answers
3k views

OpenLayers GetFeatureInfo for GeoServer Layer Groups

I've created a GeoServer layer group. I'm using OpenLayers.Layer.WMS to retrieve the layer group, and this works fine. In addition, I'd like to pull feature info for the layer. For this, I'm using ...
2
votes
1answer
1k views

Specifying ArcGIS Server WMS GetFeatureInfo tolerance?

is there a way to specify pixel tolerance when requesting feature info via GetFeatureInfo WMS request for an ArcGIS Server WMS-published map service? I have not been able to find any such information ...
2
votes
1answer
237 views

WMTS GetFeatureInfo in android

I want to create something in android like this: http://openlayers.org/dev/examples/wmts-getfeatureinfo.html I'm able to load the costum tiles with WMTS but now i need to get data to show in some kind ...
2
votes
1answer
3k views

WMS Request Returns nothing with Geoserver

I'm having trouble with a select feature example in Geoserver and open layers. For some reason the request returns nothing. Here's the stripped down version that produces this: I have a small wms ...
2
votes
2answers
486 views

Reducing GetFeatureInfo radius / buffer in Geoserver 2.5.2

When clicking some features on the map to get FeatureInfo in OpenLayers i'm getting also info of other near features that i'm not clicking on. I've notice that this is more accurate in GeorSever ...
2
votes
1answer
287 views

How to show in a custom QGIS form the feature and/or geometry info?

I need to show point coordinates on the from dialog used to edit the attributes of a point.. I see that in the formOpen the dialog receives a layerId and a featureId, but no iface object, so how can ...
2
votes
1answer
464 views

Get feature from two overlapping KML layers doesn't work

I did an implementation similar to http://openlayers.org/dev/examples/sundials.html The difference is that I have two or more kml layers at the same location and want to show their information ...
2
votes
2answers
2k views

GetFeatureInfo doesn't work!

I'm new at openlayers and I am having some trouble when trying to display the feature info. I have the map working, with the layers I want to add in, but it seems that when I try to ask for the info ...
2
votes
2answers
2k views

How to select multiple polygons or points from WFS or WMS and getFeatureInfo

Is there a way to select multiple polygons and/or points from a WFS or WMS service and then get the feature information for each selected item? There are numerous examples on the OpenLayers website ...
2
votes
1answer
3k views

'Select' and 'hover over' features are not working although no error is displayed (openlayers)

On the following html code i get no errors when i check it on firebug. When i select or hover over features i want to see them "highlighted". When i move my cursor onto a feature i can see that ...
2
votes
0answers
58 views

Openlayers 3, getfeatureinfo and geowebcache

I am having a bit of trouble using the getGetFeatureInfo function on the TileWMS source in OL3. It works, but it represents the X/Y-parameters as I/J in the generated URL. ...
2
votes
0answers
50 views

Click event returning wrong Y container point in Leaflet

I am using QGIS Server and Leaflet to display geotiffs on my website. I have created an onMapClick function which uses a GetFeatureInfo request to QGIS Server which returns the value of the geotiff in ...
2
votes
0answers
190 views

openLayers and geoserver: WMSGetFeatureInfo does not return feature beyond wrapdateline

I built a map made of several layers. I need to display the layers features fields at the place where the user clicks (see the controler code hereafter). The layers are correctly displayed and go ...
2
votes
2answers
4k views

Openlayers & WMS - GetFeatureInfo problem

I'm making a small project but I encounter some problems. Let me explain that : Having generated mapfile with mapserver and they are viewable by the openlayers interface, I would like to make me ...
2
votes
1answer
2k views

How to deactivate Vector Selection In OpenLayers wms features

This is my sample code and work fine :), But I have a little problem, I'm using multiple layers (WMS), when I zoom the layer will be shown or hidden. In my example bellow when OpenLayers level zoom ...
2
votes
0answers
534 views

Extending Identify widget and connect it with Legend widget

Sorry if it's a very basic question but I am new in Flex. I am using latest Flex Identify widget and I have created my own legend widget. What I am trying to do is, when a user select a point using ...
1
vote
2answers
1k views

Prevent layer from WMSGetFeatureInfo request on openlayers web map

I use this example code get feature info from my openlayers web map.I add 4 layers to map including raster image as base map. But i don't need feature info from that raster layer.But when clicking on ...
1
vote
2answers
125 views

WMS getFeatureInfo and Leaflet

I've got an app running www.carstenhogertz.de/c_section. It has a popUp function showing the underlaying point attribute. This function shows a strange behaviour on lower zoom levels. For instance ...
1
vote
1answer
399 views

Is a proxy required to use OpenLayer's GetFeatureInfo?

My domain is hosted on HostGator and apparently they don't allow the use of proxies. I have a map that has a WMS point feature hosted from my GeoServer using OpenLayers. I want to be able to select ...
1
vote
1answer
4k views

How to use getfeatureinfo with MapServer and OpenLayers?

I'm trying to use the getfeatureinfo function of Openlayers with MapServer. When I click on a point on my map, I get the following error in Firebug: <?xml version='1.0' encoding="ISO-8859-1" ...
1
vote
3answers
2k views

WMSGetFeatureInfo not showing in Firefox and chrome

This code set works for me in IE but not in Firefox and chrome.What is the problem? Map is showing in all browsers ,but when i click on point of map nothing showing in Firefox and chrome. Welcome ...
1
vote
1answer
507 views

OpenLayers - URL hyperlink in GetFeatureInfo table?

I am serving numerous WMS layers through GeoServer, many of which have URLs leading to extended data for any particular feature embedded in their attribute table. The URL, if present, is always ...
1
vote
1answer
840 views

Query individual features of Tile WMS

I have several tile WMS layers with about 5000 earthquakes and I want to query their features by clicking: example That works fine for me, but I would like to query individual features, like only the ...
1
vote
1answer
428 views

How works Openlayers GetFeature Filter strategy

I want to select on map that "res_id = 182" but that is selecting all objects on the map. var filter = new OpenLayers.Filter.Comparison({ type: OpenLayers.Filter.Comparison.EQUAL_TO, ...
1
vote
1answer
487 views

Leaflet WMS GetFeatureInfo gives result only on zoom level 10

I am using GetFeatureInfo with wms layer to get the data behind. The request returns data only after zoom level 10 before that it returns empty features. Does anyone having same issue? I think it ...
1
vote
1answer
602 views

Openlayers WMS getFeatureInfo get features with geometry attribute

I am displaying map using WMSlayer and implemented WMSGetFeatureInfo control on wms layer. Tap on a location and get the features using WMS getFeatureInfo service. This service is returning me all ...
1
vote
1answer
224 views

How to activate and deactivate popup feature in OpenLayers?

I am a beginner in OpenLayers and I want to activate and deactivate a popup feature, which has to show lat,long of the click, which is initiating the popup [no markers]. I am currently using ...
1
vote
1answer
1k views

How to determine the accuracy of getFeatureInfo on a WMS layer?

I have added a WMS layer to the ArcGIS Server JSAPI and am attempting to query it using getFeatureInfo when the user clicks on the map. This is mostly working, except that the accuracy of the ...
1
vote
1answer
3k views

How can I add an infowindow to an OpenLayers GeoJSON layer?

In my OpenLayers script I refer to an geojson layer. Is it possible to add an info window?If yes, how can I create this. Script is as follows: var lon = 5, lat = 52, zoom = 7, epsg4326 = ...
1
vote
1answer
2k views

How to use cql_filter in OpenLayers.Control.WMSGetFeatureInfo?

I am a newbie and I am using OpenLayers, GeoServer 2.1.3. I have a function that works to filter the markers on the map with a CQL_FILTER function. But when I click on a marker it shows a popup with ...
1
vote
1answer
21 views

Geoserver getfeatureinfo returns big number with exponential format

I have a Geoserver layer, which contains numbers on a million scale in one of the attributes. If I query these features, I get back a number in this format: 4.1E7 instead of this: 410000000 Is there ...
1
vote
1answer
18 views

send a GetFeatureInfo to Geoserver over a time range

I want query geoserver about FeatureInfo from a set of images temporally spaced. How I should build this route?