1
vote
0answers
81 views

qgis-2.2.0 database tab missing

I have recently installed QGIS-2.2.0 but the Database tab in the top-menu bar is missing. It looks the main reason is missing libgdal1h library. But when I am installing it, it's removing ...
0
votes
0answers
92 views

Setting up PostGIS: Postgres can't see the PostGIS extensions?

I've just installed Postgres 9.3.4 and PostGIS 2.1 on OSX Mavericks using the very latest versions of the KyngChaos libraries. This is a new machine, and I deliberately haven't installed Postgres ...
0
votes
0answers
29 views

Double version of PostGIS installed on my server

For some reason I messed up an installation of Postgis on my PostgreSQL 9.2.8 server. I had version 2.0.3 installed and when I tried to upgrade to 2.1 it did so. The problem comes when I dump the ...
0
votes
0answers
126 views

PostGIS 2.1 error install with shared object (rtpostgis-2.1.so") Linux Mint

I've Installed Linux Mint 16 mate and install PostGIS with PostGreSQL (I've tried many ways in the Internet from original source to some suggestion) but all is too error: " ERROR: could not load ...
1
vote
0answers
300 views

Creating a spatial database using EXTENSIONS: error loading legacy.sql

I am using Postgres 9.3 and PostGIS 2.1, installed in a Docker container via RUN echo "deb http://apt.postgresql.org/pub/repos/apt/ precise-pgdg main" >> /etc/apt/sources.list RUN apt-get -y ...
0
votes
1answer
143 views

Install both postgis and postgresql-9.1-postgis packages?

I've installed the PostgreSQL package (ver. 9.1) on a Debian 7 server using the command "apt-get install postgresql postgresql-contrib". I now want to install PostGIS as well. Should I install both ...
2
votes
2answers
296 views

Possible to downgrade Postgresql and PostGIS versions and still be compatible with latest OpenGeo Suite?

I'm trying to connect ArcGIS Desktop 10.1 to PostGreSQL/PostGIS tables. I have PostGreSQL 9.2/PostGIS 2.0, which was installed with the latest OpenGeo suite. Unfortunately ArcGIS direct connections to ...
1
vote
1answer
363 views

Installation question: initdb is missing after install of postgis2 via RPMS on RHEL 6.4

I'm attempting to install postgis2 on RHEL 6.4 by using the instructions postgis.net/install, but after the postgis2 install, neither initdb nor /etc/init.d/postgreql92 is present. The same thing ...
0
votes
0answers
918 views

How to install PostGIS and pgrouting on Windows if Stack Builder fails to connect?

I know this has probably been covered and that there are plenty of guides out there, but for the life of me I cannot get pgrouting installed. All guides/how-tos are different or assume prior ...
1
vote
1answer
633 views

Compiling PostGIS fails when it can't find GDALAllRegister

I'm trying to compile the latest PostGIS 2.1.0 beta and the configure process fails at: checking GDAL version... 1.10.0 checking for OGR enabled... yes checking gdal.h usability... yes checking ...
0
votes
1answer
141 views

Solving flagrant shared object errors when compiling postgis 2.1SVN from source on Ubuntu 12.04

I have spent the past few days of my life trying to figure out how to get postgis to function properly with a non-standard directory installation of postgres 9.3, but have been unable to resolve the ...
1
vote
5answers
2k views

Unable to install the PostGIS extension to PostgreSQL on Ubuntu 12.04 LTS

I just installed Linux Ubuntu 12.04 LTS (on a virtual machine). I then successfully installed the PostgreSQL 8.4 database management system. I am now trying to install PostGIS, which is an extension ...
3
votes
1answer
2k views

PostGIS installation on Ubuntu 10.12 (Amazon Services)

On Ubuntu 10.12 (AMI on Amazon), I use aptitude to install Postgresql and PostGis. On terminal running psql interactive prompt, I type CREATE EXTENSION postgis and ERROR: could not open extension ...
5
votes
1answer
679 views

Why isn't StackBuilder installation of PostGIS working?

I've installed PostGIS (ver. 2.0.1) on my Mac using EnterpriseDB's StackBuilder, which I also used for my PostgreSQL (9.2.2) installation. Although StackBuilder says that PostGIS is now installed, and ...
9
votes
3answers
2k views

How to install PostGIS on Windows?

I want to create an application platform based on PostGIS data. I read the documentation where I saw the prerequisite to install GEOS, GDAL and Proj4. The main problem is I am using windows platform. ...
1
vote
2answers
4k views

How to install PostGIS shp2pgsql-gui on CentOS 6?

I am installing PostGIS 1.5.3 on a CentOS 6.2 virtual machine to get started web mapping with Geoserver.I have successfully installed PostgreSQL 9.1, PostGIS 1.5.3 and PgAdminIII on the system. ...
6
votes
1answer
172 views

How to install a patch in PostGIS

Can anybody tell me how to install this patch in PostGIS? http://trac.osgeo.org/postgis/ticket/413 http://trac.osgeo.org/postgis/changeset/7534 I need to use the ST_OffsetCurve function. but it ...
3
votes
1answer
599 views

postgis compilation error

I'm just having a problem compiling postgis on a second machine, I wonder if anyone has any pointers: ./autogen.sh ./configure gives PostGIS is now configured for i686-pc-linux-gnu ...
1
vote
0answers
416 views

PostGIS installation error [closed]

Try to install PostGIS 2.0 from svn in Ubuntu 11.04. After running postgis.sql file I get an error: ERROR: could not load library "/usr/lib/postgresql/9.0/lib/postgis-2.0.so": ...
3
votes
2answers
3k views

Postgis installation error

I am using fedora machine. I want to install postgis on my system. So this is what I have done Installed Postgresql and supporting packages using YUM. Created directory /sources to put all the ...