0
votes
0answers
21 views

Openlayers stylemap default style doesn't render until mouseover in IE 7/8

I'm using Drupal 7 Openlayers, and adding my own custom behavior. I have no trouble getting my code included, and it works well on other browsers. But in IE 7/8, the layer features render with a null ...
0
votes
1answer
64 views

Open Layers Performance issue with IE 7 & 8

I'm using open layers to draw the world map and below is the code. Basically there's a json file which contains the coordinates of all countries which will be read by open layers and the fill color ...
0
votes
0answers
82 views

IE8 Openlayers load thousands objects problem

My client works only with IE8. He has openlayers map that he want to load 3000 polygons on it. Chrome and IE9 can do this easily, but IE8 freeze. Objects come from web service as json xml , being ...
1
vote
0answers
437 views

openlayers 2.13.1 vector layer and CQL does not work in IE11

I have implemented a search functionality for a vector layer in openlayers 2.13.1. I use CQL. I take the values from an html form and I use javascript to pass them to a CQL filter and execute it. ...
1
vote
1answer
376 views

How to disable all mouse event in openlayers' map div?

version: OpenLayers-2.13.1 brower : IE8 (I Hit it!!! But I need to work on it) I create a div with id 'map' to display openlayer map. Sometimes, I need disable map div catch any mouse events, let me ...
0
votes
1answer
120 views

How to drag label using DragFeature or ModifyFeature?

I am new to openlayer. I have seen the examples in which DragFeature is able to move my points, polygon and lines. But when it comes to test the Label moving in IE8, then the dragging functionality ...
1
vote
1answer
174 views

WMS Pop Up not working…? [closed]

I have created a web based GIS using Geoserver-Postgis-Openlayers... Every thing was working fine till I changed the server path from 'Testing to LIVE.' WMS POP up Function has stopped working in ...
0
votes
0answers
342 views

Openlayers Vector Feature label not Visible in IE 8 but visible in Google Chrome…?

I have created a WEB MAP using Openlayers-Geoserver-Postgis.... The Label of one of the Vector feature layer is not visible in Internet Explorer 8(IE 8) ,but clearly visible in Google Chrome ...
0
votes
1answer
233 views

GeoJSON won't show in IE, but works fine in FF

I’m not sure if this question isn’t too specific for Stack Exchange, but I really can’t find a solution, and even extensive web search hasn’t brought up any help. There are similar, but different ...