Linux is a Unix-like computer operating system assembled under the model of free and open source software development and distribution.

learn more… | top users | synonyms

2
votes
2answers
1k views

Error installing GDAL 1.9.0 python package

I'm trying to install the GDAL python package in a python 2.7.1 environment on RHEL 5. I am using the command 'pip install GDAL'. I have no problem installing other packages like numpy, etc. in this ...
1
vote
2answers
88 views

Problem when converting sosi to shapefile with ogr2ogr on Linux

I am trying to convert a SOSI file (Norwegian geodata format) to a shapefile. I have set up gdal, but apparantly there is a lot of things that I dont have support for. When I do a ./configure, this is ...
0
votes
1answer
499 views

How to set up an offline maps viewer application on linux?

I'm having an 8-years old notebook (pentium 4 3Ghz 1Gb Ram) with Debian (installed recently), I just want to be able to navigate through the map around 1-2 cities, with ability to seek adresses and ...
1
vote
1answer
334 views

Converting Tab to Shp Using OGR2OGR with Python on linux

First i downloaded http://svn.osgeo.org/gdal/trunk/gdal/swig/python/samples/ogr2ogr.py and i am importing this. How can i get ogr2ogr to run in my script? nothing seems to be working and i not sure ...
6
votes
3answers
1k views

Generating TIN from DEM using MacOSX/Unix tools?

I'd like to generate a 3d terrain model moving from a DEM dataset (currently in shp and GeoTIFF format). As far as I understand it, the first step of the better path would be generating a TIN, but I ...
4
votes
1answer
246 views

How do I install Orfeo toolbox and Qgis 1.9?

I'm having a lot of trouble getting Orfeo toolbox and Qgis 2.0 working. I followed the qgis wiki instructios, added the ppa, installed qgis 1.9 (it's beautiful, great work!). But when i tried to ...
2
votes
1answer
60 views

scaling of results: the comparing of osm-files for a few days - a statistical approach

i am pretty new to Geographic-information Systems so do not bear with me if i ask newby questions: i am interested in gatherin information on schools Some days before i have heard that it is ...
2
votes
2answers
92 views

schools: how are they tagged - with the same method all over the world?

are all schools tagged in the same way? or do some countries do use a specal tag-(system)? update: thanks to the responders: what does this mean ...
3
votes
2answers
856 views

How to install Mapserver in nginx?

I was istalled Mapserver: sudo apt-get install libgd2-xpm-dev sudo add-apt-repository ppa:ubuntugis/ubuntugis-unstable sudo apt-get update sudo apt-get install cgi-mapserver mapserver-bin and ...
1
vote
2answers
483 views

Installing python GDAL with pip in local (user) space on RHEL6 server: failure due to missing headers

There are similar themed questions for other platforms, but the solutions out there do not work for me. (e.g. ...
2
votes
1answer
85 views

Open Street Map “no map for: default”

I'm hitting my head off a wall! I Have installed renderd and mapnik on Debain squeeze v6.0.5. Renderd(version 0.7.1) is starting without error. But when I request the /osm_tiles2/0/0/0.png . The ...
-2
votes
1answer
60 views

complete list of poi-types in Germany

look for a complete list of poi-types I use foursquare because it contains a lot of POIs. Which database do you use when you need a point of interest in North America? Which database you use for ...
0
votes
0answers
382 views

Cannot install OpenGeo Suite on Ubuntu 12.04

I originally posted this on this forum post, but thought it would be best to open a new thread. If I should have simply posted on the other forum, my apologies. I am also having issues installing OG ...
0
votes
0answers
31 views

Opticks 4.11.0 (Ubuntu 64bit) - unable to load TIFF file

I am trying Opticks 4.11.0-1 - have official release opticks_4.11.0-1_amd64.deb but unlike in Windows I am totally unable to load Landsat 7 TIFF files. In Windows I can do this using auto importer. In ...
1
vote
1answer
119 views

overpass-api or osmconvert: which method is more appropiate to use for files from 10 to 400 mb?

new to openstreetmap and this technology. update: some mentioned postgis: well - The database schema of postgis allready contains the following tables: nodes, ways, relations, node_tags, way_tags, ...
0
votes
2answers
337 views

QGIS 2.0 and Debian Jessie

I added the official QGIS repos to my installation of Debian Jessie using the instructions on the official QGIS page. As of now, there appears to be some packages missing from the repos that resolve ...
1
vote
1answer
93 views

Union multiple shapefiles with overlapping shapes

I have several shapefiles that overlap and I would like to union their geometries to get rid of those overlaps. I know how to do this with OGR and Python for single geometries. from osgeo import ogr ...
15
votes
3answers
11k views

ArcGIS for Desktop on Linux?

Will ArcGIS 10 work properly on Linux using wine or crossweaver?
0
votes
0answers
14 views

overpass-api on opensuse 13.1

i want to install overpass.api on opensuse 13.1 what is needed to do that. are there things i have to get via YAST - or do i need to get all via Terminal!? Any and all help will be greatly ...
7
votes
2answers
534 views

Building FGDB support for GDAL 1.10 on Ubuntu

Because data.gc.ca is now distributing some of its data in FGDB format (example: Plant Hardiness Zones), I would like to be able to use it with gdal/QGIS. The compile/install is not going as planned, ...
1
vote
0answers
18 views

Using STDIN with degrib

We are using the latest version of degrib (2.02) http://www.nws.noaa.gov/mdl/degrib/tutorial.php with some grib files but I am having a hard time getting the "Input on stdin" feature to work. See ...
0
votes
0answers
25 views

processing with xslt-

on opensuse 13.1 i try to do some gis-works with a large file: france-latest.osm.bz2 which i gathered from here: http://download.geofabrik.de/europe.html what do i do with that file ...
1
vote
1answer
40 views

How to mask the images in GRASS

I have MODIS NDVI images, which needs to be masked with VI_Quality. I am using GRASS software and executing GRASS commands using shell scripts. I need to perform raster calculation (multiplication) ...
0
votes
0answers
45 views

Arcgis Server failed to create site?

Failed to create the site. Admin URL 'http://my.site.url:6080/arcgis/admin' is not reachable from 'LOCALHOST': 'Connection timed out'. Anyone have any idea why i am facing this error? i have ...
0
votes
0answers
135 views

PostGIS 2.1 error install with shared object (rtpostgis-2.1.so") Linux Mint

I've Installed Linux Mint 16 mate and install PostGIS with PostGreSQL (I've tried many ways in the Internet from original source to some suggestion) but all is too error: " ERROR: could not load ...
1
vote
0answers
64 views

How to use USGS Bulk Download on EC2 linux Server?

I am interesting in downloading Landsat 8 rasters to an Amazon EC2 instance and would like to know how to do it. I already install USGS Bulk Download but I do not know how to use it in terminal mode ...
-1
votes
2answers
122 views

What software for direct editing of a DBF file?

I am currently processing GPS log data from my holiday and need to add information to the points. I remember I used OpenOffice and later LibreOffice to directly edit the files but currently I am ...
1
vote
0answers
27 views

Comparing TIGER 2013 with TIGER 2006

I'm doing a project when I want to compare TIGER 2013 data with the TIGER 2006 data. Essentially, the Census updated the data between 2002-2008, and a number of the counties were updated in the 2006 ...
0
votes
0answers
154 views

QGIS cannot open output layers

I have problem with QGIS 2.0.1. Everytime I run tool from SAGA or GRASS, I get exactly the same error, for example: Oooops! The following output layers could not be open Channel Network: ...
6
votes
7answers
1k views

Open source tool to convert a DEM to a 3D model

I would like to convert a DEM (Digitial Elevation Model) file (e.g. from SRTM) into a 3D model that I can then edit with regular 3D modeling tools (e.g. Meshlab/Blender/etc.). However I'm using Ubuntu ...
1
vote
1answer
57 views

Does charactermarkersymbol work differently in linux?

I have just started working in GIS. i am trying to project an aeroplane glyph font (character index=111) using charactermarkersymbol but unable to do it in linux. I am getting the same spherical ...
1
vote
1answer
78 views

How do I include libfcgi files when installing QGIS on SUSE Linux?

I'm using SUSE Linux Enterprise Desktop 11 SP2. When I try to install QGIS from YAST, it seems that the package "libfcgi.so.0" and "libfcgi.so.1" are missing. Is there anyone else that has experienced ...
1
vote
1answer
365 views

Installation question: initdb is missing after install of postgis2 via RPMS on RHEL 6.4

I'm attempting to install postgis2 on RHEL 6.4 by using the instructions postgis.net/install, but after the postgis2 install, neither initdb nor /etc/init.d/postgreql92 is present. The same thing ...
0
votes
1answer
284 views

Installing Geoserver on Ubuntu 13.04 - “ trying to overwrite '/usr/bin/shp2pgsql-gui' ”

I am trying to upgrade Opengeo Suite from 2.0 to 4.0, specifically for the upgrade of PostGis 2.0 to 2.1, I followed the instructions outlined on this page: ...
3
votes
1answer
115 views

Where can I find a python GDAL 1.8.0 package?

I have python 2.7.4 installed on my RHEL 5 machine along with gdal-devel-1.8.0 and gdal-1.8.0. I tried to install the GDAL 1.9.1 package available on python's page ...
1
vote
1answer
67 views

arcgis 10.1 account manager, authorizeSoftware script

I am trying to run "authorizeSoftware" file to complete creating new account manager in Arcgis 10.1, but after running ./authorizeSoftware I got this message: ...
0
votes
1answer
185 views

Installing ArcGIS for server 10.1 on linux server

I am trying to install ArcGIS for server 10.1 on my linux system. When I run "./startserver.sh" I get following error: ERROR: Unable to start Xvfb on any port in the range 6600 - 6619. I have ...
0
votes
1answer
143 views

Install both postgis and postgresql-9.1-postgis packages?

I've installed the PostgreSQL package (ver. 9.1) on a Debian 7 server using the command "apt-get install postgresql postgresql-contrib". I now want to install PostGIS as well. Should I install both ...
0
votes
1answer
536 views

What can I do with this unzipped GDB file in QGIS?

I have a zip file that I got from the City department of information technology. Unzipped, it is a directory called DOITT_ZIP_CODE_01_29JUL2009.gdb containing a bunch of .gdbtable and .gdbtablex ...
2
votes
1answer
53 views

Transferring from Windows to Linux OS for ESRI ArcReader

I have a .pmf file and I would like to open it under ubuntu. However all the layers are directing to a C:/ source. As Linux OS does not have such drive, how can I change the layer source path? Thanks! ...
0
votes
0answers
102 views

Encoding in ESRI, unable to encode with UTF-8 when publishing .pmf files

I have a map currently made from ArcMap on a Windows OS. Now I would like to publish that map and then allowing it to open/read at a Linux OS (I'm using ArcReader to read on Linux). Everything is ...
10
votes
2answers
2k views

How to run ArcGIS in a virtual machine?

I'm trying to run ArcGIS Desktop 10.0 in a Windows 7 (32bit) virtual machine. I don't have any native Microsoft Windows available. I'm using VirtualBox from Oracle for virtualization in a native linux ...
1
vote
1answer
36 views

Is it possible to install Geoserver on Zentyal?

We want to setup a small WebGIS environment based on Geoserver/PostGIS or even the OpenGeoSuite if possible. Our Server runs on Zentyal. Is it possible to install Geoserver and PostGIS on Zentyal and ...
1
vote
1answer
98 views

Fiona: won't install in Debian7.x-64bits/Python2.7

I need to install Fiona in my Debian7.x-64bits/Python2.7 machine. I already installed GDAL/OGR, pip, virtualenv, and six. I am using Python 2.7 so argparse is also installed. The installation protocol ...
2
votes
1answer
884 views

QGIS, Installation on Linux Mint 15 Mate

I've just tried to install the latest version of QGIS on Linux Mint 15 Mate using 'sudo apt-get update' and 'sudo apt-get install qgis'. However, QGIS gives me the error message 'Couldn't load PyQGIS. ...
1
vote
0answers
28 views

What is the best way to manage permissions as root installing postgresql and postgis?

I've encountered an issue numerous times where I lock myself out of my postgres installation as a result of modifying my pg_hba.conf file and therefore screw up my postgres installation because I ...
2
votes
2answers
105 views

Can I deploy .NET server object extension to a linux box hosting ArcGIS Server 10.1?

We have developed a server object extension in Visual Studio 2010, and successfully deployed to the ArcGIS Server hosted on a windows box. However, when we try to deploy it to a linux server, it ...
3
votes
1answer
170 views

install opengeo on Arch Linux

I am trying to install the opengeo suite (community) for a project I have. The thing is that my Linux distribution is Arch Linux, for which the package manager is pacman and not apt-get as it is the ...
2
votes
1answer
196 views

QGIS Arch Linux compilation error

Just pulled QGIS from git and am trying to compile it, here's the relevant error: [ 89%] Building CXX object python/CMakeFiles/python_module_qgis_core.dir/core/sipcorepart3.cpp.o In file included ...
1
vote
0answers
82 views

Editor to work on GML files

I am looking for a good way to work on GML files and would appreciate some personal experience. At the moment I am using nXML or SGML mode for Emacs but I wouldnt mind having an IDE/Emacs mode/... ...