(UMN) MapServer is an Open Source platform for publishing spatial data and interactive mapping applications to the web.

learn more… | top users | synonyms (1)

0
votes
0answers
176 views

Map doesn't show anything in img file (WMS-Mapserver)

Actually in a practical Project we wanted to use OpenLayer and MapServer to display our data using WMS, but We can't find a proper srs or EPSG code. One of the ITC students said, we have to change our ...
0
votes
0answers
275 views

How to add a legend for mapfile (Raster Data)

What I would like to do is shown in the figure below. How can I add this color ramp legend in a mapfile which will also be linked to a raster. I don't know how to get it working while drawing a figure ...
0
votes
0answers
205 views

MapServer Mapfile: Scalebar not displaying correct distances?

Scalebar: SCALEBAR LABEL COLOR 0 0 0 SIZE SMALL END STYLE 0 SIZE 180 8 POSITION lc COLOR 0 0 0 UNITS MILES INTERVALS 2 TRANSPARENT TRUE STATUS EMBED END I didn't even ...
0
votes
0answers
67 views

MapServer Templates: Javascript function won't recognize [LONG] or [LAT]

Tested this in js console with a 'normal' variable and working fine: js function in map_header.html var toFixed = function(val, n) { var result = val.toFixed(n); if (result == val) ...
0
votes
2answers
243 views

MapServer Mapfile: One layer, disable the label but not the point for first two zoom levels

This map is not using OpenLayers, just MapServer with a mapfile. There is a layer that displays both the point and the label. Looking through the documentation, I'm not entirely sure what the best ...
0
votes
0answers
205 views

Dynamically generating data for map tiles from Python function

I'm brand-new to GIS and relatively new to web services. I've found a ton of great resources on the web, but I'm having trouble addressing one specific issue: One of the data layers on my planned map ...
0
votes
0answers
163 views

“could not get any sources: no image returned from source WMS” error in mapproxy demo

I am trying to connect my mapserver to MapProxy. First part of the map file is shown below MAP FONTSET "fonts.lst" IMAGETYPE png MAXSIZE 4000 SIZE 800 800 EXTENT -20000000 -20000000 20000000 20000000 ...
0
votes
0answers
97 views

What do we have to set in mapfile´s data parameter for SOS?

We are trying to run the MapServer SOS example at this link. However, we don´t know how to configure the data parameter in the mapfile. What do we have to set in mapfile´s data parameter? We need to ...
0
votes
1answer
20 views

Is there a way to tell the supported input formats of libmap.dll without the associated .exe?

I have only compiled Mapscript_csharp and supporting dlls used in a .NET application - not the executables. Is there a way to tell what input / output formats are supported by these dlls?
0
votes
0answers
247 views

Is it possible to automatically create categories with mapserver?

I have a mapfile connecting to a postgres/postgis database. To create a thematic map I can set a class item and a number of classes, for example: CLASSITEM "aantal" CLASS NAME "0" ...
0
votes
1answer
247 views

Border style in MapServer

I have WMS polygonal layer and want to draw polygon's border with the following style: My symbol's description: SYMBOL NAME "double_line" TYPE vector POINTS 0 0 1 0 -99 -99 0 1 1 1 ...
0
votes
0answers
110 views

tilecache problem with LABELMAXSCALEDENOM

I use tilecahce and mapserver and I have problem to showing labels. In mapfile when I use LABELMAXSCALEDENOM option the label layers not show in map. when I delete tis option the layer render without ...
0
votes
1answer
116 views

Mapserver: “Premature end of script headers: mapserv,”

Some of requests to the Mapserver return "Internal server error". When I checked the Apache log I saw that there are several error messages: GDAL: In GDALDestroy - unloading GDAL shared library., ...
-1
votes
1answer
347 views

One of my WMS layer is not loading the image tiles.

One of my WMS layer is not loading the image tiles. See the code: <script type="text/javascript"> var map, ia_wms; function init(){ map = new OpenLayers.Map('map', ...
-1
votes
1answer
483 views

My wms vector data overlay on openlayer vmap work fine but on osm img is not rendering

i am try to overlay my India roads vector over an openlayer (http://vmap0.tiles.osgeo.org/wms/vmap0) vmap work fine.but i want to do the sam task over osm(open street map), i am trying many different ...