(UMN) MapServer is an Open Source platform for publishing spatial data and interactive mapping applications to the web.

learn more… | top users | synonyms (1)

0
votes
1answer
82 views

Openlayers Load Blank Tiles - How To Combine OpenLayers 3 to MapServer version 6.0.3 (MS4W 3.0.6)

I Have Some Experiences With Openlayers 2 Now I Want To Combine OpenLayers 3 And Mapserver And I Tried The Below Configs And Code On OpenLayers And MapServer But The Openlayers Load White And Blank ...
0
votes
1answer
103 views

How to use openlayers 3 and Mapserver (WMS

I'm not able to centralize my map in OpenLayers / MapServer , it appears at the top . The " center " do not work . Below my code to better analyze . I did not post the mapfile why I did an experiment ...
0
votes
1answer
60 views

Technical requirements for installing Geoserver and having a web mapping platform

I have taken up a new job, and I need to undertake some web mapping sing Geoserver. I have no idea the hardware required to install Geoserver and do web mapping. I know there is a server involved, is ...
0
votes
1answer
49 views

How to make MapServer only accessible via MapCache?

I installed MapServer and MapCache on Ubuntu (see here). Now I would like to prevent the direct access to MapServer - requests should only be allowed via MapCache. I thought I could achieve this by ...
0
votes
1answer
285 views

How to add wms overlay layer to google map

I have a WMS server (using MapServer and Apache on windows). i read this document about Mapserver's Tile Mode and use that's example to overlay my map on Google maps.but not work. my code: function ...
0
votes
1answer
33 views

what does “msLoadMap not incl.” mean?

I receive "mapserv request processing time (msLoadMap not incl.)" in my ms_error.log, but no idea what that means, is that an error or the normal behavior of MapServer? It appears regardless the layer ...
0
votes
1answer
48 views

installing mapserver in cygwin - regex.c problem

This is my first time installing mapserver in cygwin, but I'm a quite old user of both cygwin and mapserver (but still young =D ). The thing is that I'm getting a regex issue after doing cmake in the ...
0
votes
1answer
98 views

Rollback error when restoring SQL dump file in postgresql using PSQL console via Pgadmin

I am trying to restore a pg_dump SQL file into my postgresql database using PSQL console , where I typed the below command: \i 'c:/../path/to/sample.sql' when I run this I get an error saying ...
0
votes
2answers
736 views

How do I install PostgreSQL + PostGIS + MapServer + Python-MapScript on Ubuntu 12.04 LTS w/o compiling from source?

This question is similar to the one posted here... How to have PostGIS 2.1 and the Python osgeo library installed together without compiling from source? ...but since I'm new GIS Stack exchange, I ...
0
votes
1answer
97 views

Export my map in various formats

I want to implement a sort of content negotiation so as to export my map in formats like pdf jpg etc. Is there any way to export my current map view (with all the enabled options so far) in various ...
0
votes
1answer
149 views

Syntax for using ArcGIS for Server layer with WMS service?

I am having some issues with getting an image/png format from an ArcGIS Server. The console returns: Resource interpreted as Image but transferred with MIME type application/vnd.ogc.se_xml: ...
0
votes
1answer
35 views

Passing the value of runtime variable in WMS request

I'm trying to make runtime variable inside the where clause of my sql query like "select geom from table1 where sname = '%s%'. but when I'm trying to pass the value of s during WMS request (from the ...
0
votes
1answer
251 views

Get all columns from postgis table when doing a getFeatureInfo request from mapserver's WMS layer

some background: im using openlayers WMSGetFeatureInfo control to get feature info from a WMS layer. the data is in postgis (its a table of points). im using mapserver, and you need to define a ...
0
votes
2answers
106 views

OpenLayers WMSGetFeatureInfo on MapServer WMS layer

I am trying to get a WMSGetFeatureInfo request to work on my MapServer WMS layer but I am not sure how to correctly configure my map file and the request in OpenLayers. I have setup a jsFiddle with ...
0
votes
1answer
307 views

Why are map tiles being repeated? Using MapServer and Openlayers

Problem I have: map tiles from my layer are being repeated. Shapefile is projection 3059. I have specified 3059 is in the mapfile and also when creating map object. I know OpenLayers.Layer.WMS is ...
0
votes
2answers
148 views

OpenLayers and Mapserver-WMS-Layer disappear if the map is draged

I have a client for the WMS-Services of my mapserver. The client program is written in javascript and it uses Openlayers (v. 2.12). The map has as a base layer "Google satellite"-Layer and the ...
0
votes
1answer
146 views

No building and Point of interest available while setting up “Rendering Osm Data Ubuntu using MAPSERVER”

I have followed RenderingOsmDataUbuntu 10.10 and set up Google styled web map using mapserver. The osm-google.map seems to be not using table osm_new_buildings. Also no POI (Point of interest) data is ...
0
votes
1answer
76 views

How to display map in MapServer?

I haven't found any good explanation yet about how to display a map in Mapserver (localhost). I have msw4 with p.mapper in my pc. I have created a base .map file, shape files and html file. Please ...
0
votes
1answer
109 views

problem display tile when config tilecache for WMS

i have a problem with config tilecache for WMS when i have shown it. but there are proplem when display tiles. any idea? this is my config for tilecache.cfg [world] ...
0
votes
2answers
220 views

MapServer and OpenLayers: Properly using MAXSCALEDENOM in mapfile (google baselayer)

My base layer: google map My points on the map: from an airports.db file, set up as a WFS layer in the OpenLayers code. As of now: map loads, points in the correct places on the map. My goal: ...
0
votes
2answers
174 views

MS4W (MapServer 4 Windows) - version 3.0.3 Crashes JVM and Tomcat frequently. How to fix this?

I am using MS4W (MapServer 4 Windows with Java Mapscript) - v 3.0.3 for a GIS web application hosted over Tomcat 6.0.33 with Java jdk1.6.0_13 and PostgreSQL 9.1 with PostGIS 1.5.2 @ the database end. ...
0
votes
1answer
109 views

Difficulty with using truetype font symbols in Mapserver

I am basically following this workflow and having no luck. I have add a truetype font file to my fonts.list (under the alias 'ddv') however, I cannot get the fonts to render in the service. Any ideas, ...
0
votes
2answers
409 views

UMN MapServer alternatives [duplicate]

I am new to GIS application world. I would like to ask what are the other alternatives to UMN MapServer in the market preferably open source?
0
votes
1answer
128 views

WMS GetCapabilities and variable substitution with MapServer

I have created a layer with a variable substitution to request wether or not a bird species has been observed in a town. It works ok. But if I make a WMS GetCapabilities I only see one layer as ...
0
votes
1answer
249 views

How to set DATA string on LayerObj in MapFile by Using Mapserver's PHP Mapscript?

I'm manipulating mapfiles through mapscript. Setting layer attribute values like the opacity works like this: $layer = $map->getLayer('layername'); //set an attribute value ...
0
votes
1answer
266 views

mapserver layer classes display order

My layer Point (OGR geojson) has several classes: CLASS NAME "Station1" EXPRESSION ([extrude]=0) STYLE COLOR 0 0 250 OUTLINECOLOR 255 255 255 SYMBOL ...
0
votes
1answer
301 views

MapServer Mapfile and OpenLayers: using SIZEUNITS. Labels shrinking on 1x zoom and points disappearing upon zooming in

I am trying to set the symbol radius to 100 miles. This seems ok (note, not including the whole mapfile, just what's at hand here): LAYER NAME POIs TOLERANCE 50 TOLERANCEUNITS miles ...
0
votes
1answer
1k views

How to add Mapserver layer to Leaflet?

I have a layer in PostGIS in epsg:4326. Put in in MapServer: MAP IMAGETYPE PNG EXTENT 60.0 56.0 61.2 57.4701 SIZE 800 600 OUTPUTFORMAT NAME "png" DRIVER GD/PNG IMAGEMODE PC256 ...
0
votes
1answer
83 views

Mapserver 6.2 concatenate attributes in FILTER

Back in version 5.0 I had: FILTER ("<tcode:expression/>" eq '[STATE][COUNTY]') final version = FILTER ("11000" eq '[STATE][COUNTY]') so I would filter out the features with state = 11 and ...
0
votes
2answers
632 views

Problem with extent of mapserver wms/layer

I use mapserver with MS SERVER 2008. The problem with the correctly computing layer extend of Map server. If map file like this MAP NAME "test map" IMAGETYPE GIF EXTENT ...
0
votes
1answer
274 views

Mapfile + OpenLayers: accessing the database by column names (hover, onclick functionality) without using MapServer templates?

What I'm trying to accomplish: take the functionality below (see picture) and do the same without using a MapServer template (if this is even possible). I currently have a mapfile, and an openlayers ...
0
votes
1answer
104 views

Intersects Filter on WFS 1.0.0

I use WFS=1.0.0 on the Mapserver v5.6.6 and v6.0.1 with MS4W package. I want to get the Intersects of Spatial Operator. When I make getcapabilities request I see just "Intersect" like: ...
0
votes
2answers
109 views

MapServer: Symbol color is set in mapfile. Is there a way to change it using javascript (ie not in mapfile)?

I have a mapfile where the symbol color is set to blue. In my html I have a hover event that brings a popup when the user puts their cursor over the symbol. Working as intended. Now on that same ...
0
votes
1answer
125 views

Is there a way to control label density in mapserver?

I'm reading a US County Tiger Shapefile and everything is plotting correctly, but I want to slim down the number of labels shown at scales larger than the state level because it begins to overwhelm ...
0
votes
1answer
95 views

Unsupported WFS request in MapServer at Insert and Update

I'm created a WFS with MapServer (ms4w) and SQL Server DB. The wfs:GetFeature works fine. But I cann't get the wfs:insert/wfs:update to work, they return: <?xml version="1.0" ...
0
votes
1answer
122 views

How to use bbox in long/lat with google/bing/etc… using mapserver‏

The bbox of OpenLayers.Control.GetFeature works in utm when the baselayer is 900913 ie. google/bing/etc) and in long/lat when the baselayer is 4326 (ie. my postgis layers served by mapserver), no ...
0
votes
1answer
375 views

Error running mapserver export in quantum gis

I have a project in Quantum GIS that I need to export to a .map file using de plugin mapserver export. I fill all the forms but I get this error when running the app. Any ideas of what is ...
0
votes
1answer
3k views

Query Feature using OpenLayers + MapServer

I'm trying to query a feature in OpenLayers, but it's returning just an image highlighted that is not possible to make zoom, pan and drag. My intention is to query a feature on the map like street ...
0
votes
1answer
11 views

How to set a label's buffer color in a mapfile?

I would like to set a white buffer around labels in a mapfile (Mapserver version 6.2.1). In the official documentation, I can't find a specific parameter for this... I have tried the SHADOWCOLOR and ...
0
votes
0answers
7 views

Use MapCache to forward an existing WMTS?

Is it possible to use MapCache to forward an existing WMTS? I see no source type "wmts". Could that cause any problems?
0
votes
1answer
25 views

Can't zoom to see the whole map in OL3

I have a special map. Its rather a schema not a common world map. Not very high but it is very long. Now when I display the map, I see a part of the schema at zoom level 0 (I additionally set it ...
0
votes
0answers
18 views

raster image display

iam trying to display raster image using mapserver but it is not displaying anything, page is blank my mapfile code is MAP ########### NAME "ny_pop" SHAPEPATH ...
0
votes
0answers
23 views

Live Updating Map With Large Dataset

I need to be able to display a map on a webpage with multiple layers of squares and points, possibly up to 10,000 objects per layer. There could be up to maybe 20 layers, but having move than a ...
0
votes
0answers
12 views

geoext legendpanel not displaying symbols

I am using geoext 1.1 with openlayers 2.11. I have a few point layers (WFS) with associated styles where I pass an image adress to 'externalGraphic' parameter like this ...
0
votes
1answer
16 views

Coordinates of Polygon layer

i am using Mapserver map file and Openlayers to display a polygon layer on the Google map. layer is displaying but that layer is not on the center. i have used map.setcenter, but i do not know the ...
0
votes
0answers
23 views

Mapserver Python Mapscript - Is There An Equivalent to Mapnik's Python Plugin?

I have been developing a sophisticated web mapping app using MapServer in conjunction with the Python MapScript bindings - and it has been working great. However, I am thinking a custom data provider ...
0
votes
0answers
32 views

Learning MapServer Tutorial for C# mapscript (ASP.NET)?

I am learning the MapServer Tutorial for C# mapscript (ASP.NET). Could you tell me how to let the map show on the webpage? I mean how to trough transforming the value between the mapstream.aspx to ...
0
votes
0answers
11 views

Modifications to use multiple mapbooks in Geomoose

Currently i'm working on two projects and i want to use two mapbooks.I want to load two mapbooks at the same time without changing the whole geomoose2 folder.I've done the steps shown in ...
0
votes
0answers
17 views

Problem setting up mapcache.xml

I'm having a problem getting started with mapcache. I'm fairly new at this, but I have mapserver running: the following query works as expected and shows the appropriate tiles: ...
0
votes
0answers
38 views

Any recomendations for a GIS web app?

I'm new at this world of geographic systems. I'm at Ubuntu 14.04 and I'm using Django (v1.6) to create an app that is both a CMS and a GIS. I already finished the CMS so now I'm trying to get started ...