An application of ArcGIS for Desktop that is used to create, edit and manage models within its Geoprocessing Framework

learn more… | top users | synonyms (1)

1
vote
0answers
10 views

Enable/Disable Parameters based on Boolean

I'm working in model builder and I have a boolean parameter that determines which of two processes run. Right now, all of the parameters for both processes show up when I run the model. Is there a ...
2
votes
0answers
18 views

Problems with the Iterate Feature Selection tool

I´ll try to work with the "Iterate feature selection" tool, but it seems like it doesn't work the way I want it to. I read all the help information about this tool, but maybe I understood something ...
0
votes
0answers
6 views

How to export (only) final iteration from modelbuilder?

I'm using an iterator in Model Builder (1) to merge files, using a feedback loop (2). The output file is named "Output_%n%.txt", (3), so each file is unique. Now, I'm merging a fair number of files, ...
1
vote
1answer
16 views

Using global parameters in nested models of ModelBuilder?

I have a model that consists of two nested models and various parameters. There are two parameters that are common to all of the models (including the overall “grand” model). The common parameters are ...
2
votes
2answers
46 views

Using Feature Class name to populate new field

I am trying to get the Feature Class name (from Iterate Feature Classes) into a new field. I have been following the models described in the following two threads. Using Value from Iterate Feature ...
0
votes
2answers
43 views

How to extract portion of a string for a field value

This is simple but driving me mad. I am using Modelbuilder to iterate through a folder of feature classes, and need to add a field that extracts a portion of the filename. Example: CF0140r01.shp I ...
1
vote
1answer
22 views

Error with z values in ArcGIS ModelBuilder

Although the input data has z values the tool "Adjust 3D z values" in ModelBuilder gives ERROR 000245: The input feature class must have z values A multipoint feature gets intersected with a ...
2
votes
0answers
47 views

Correcting addresses with Python or Model Builder

I am trying to make a script in Python (or Model Builder in ArcGIS) for correcting addresses. I have a point shapefile with the addresses (it has X and Y, and fields for "number", "street name", and ...
2
votes
0answers
36 views

SQL Query does not work in ModelBuilder (but works elsewhere)

I am having issues getting a simple SQL query to work in model builder. It works fine when I use it with the standard "Select features by attributes tool", but ModelBuilder doesn't find the required ...
0
votes
0answers
26 views

How can include a 3D Analyst tool into a custom model builder tool?

I trying to include the ¨Profile Graph tool¨ contained into 3D Analyst toolbar, into a custom model toolbox. Thank you
2
votes
1answer
39 views

Limitations of iterate row selection in ArcGIS ModelBuilder?

inb4 using real script ;), I'm looking for some advice on arc's model builder. The iterate row selection in Arc's model builder allows you to make multiple table views based on field groupings of a ...
1
vote
1answer
52 views

Running ArcGIS model at specified time or with delay?

I am looking to start running an ArcGIS model built in ModelBuilder in the future. Start at a specific time. or Start in x hours. or something similar. When I leave the office I may have data ...
1
vote
0answers
24 views

ModelBuilder, Iterate by Field and Viewshed

I want to compute the independent Viewshed for 360 different points. If I run these all together, I have one viewshed output which shows how many times any given cell is visible, but this does not ...
1
vote
1answer
26 views

Run model from python .. module object not callable

Having issues to run a model from python, below the actual code , always return module object not callable. ArcMap 10.1 using arcPy esri python 64 bits Any ideas why ? Thanks import arcpy ...
1
vote
2answers
22 views

Output not feeding next step of ModelBuilder?

I have numerous input .txt files that I need to feed into an Arc tool (Samples>DataManagement>Features>CreateFeaturesFromTextFile) that creates Features from text files (the text file contains UTM ...
4
votes
0answers
66 views

ArcGIS model builder - make query layer with query parameters from generated values

What I want to do: I want to join a realationship table (same database, not in sde) to a sde feature class to distplay only needed features. This has to be done multiple times according to every row ...
3
votes
1answer
42 views

Iterate calculate field in multiple tables in ModelBuilder

I would like to iterate calculate field in multiple tables using ArcGIS Model Builder. The figure below explains details of the calculations. My existing model calculates value only for the first ...
2
votes
1answer
29 views

Land Use layer by combining, removing attributes and assigning new attributes

I'm working in Model Builder and I have limited (let's face it, no) Python knowledge, so I'd like to stay here if possible! I have numerous shapefiles that I want to combine into a single land use ...
4
votes
0answers
28 views

Modelbuilder Workspaces: Defaults to a folder, would like it to be a geodatabase

I'm having an issue with modelbuilder workspaces. I have created a simple model to clip a raster, run focal statistics on it, and create contours. I have a workspace variable as an input. If I run the ...
2
votes
1answer
24 views

Setting creation of feature dataset as precondition to iterative process using ArcGIS ModelBuilder?

When using ArcGIS ModelBuilder, how do you set the creation of a feature dataset as a precondition to an iterative process, and not have it re-create the feature dataset each time through? This is ...
2
votes
1answer
34 views

ArcGIS 10.1+: Allow a model tool to run on any computer

I've created a tool that runs from a model built in ModelBuilder in ArcGIS 10.1. Right now, I can run the tool with no problem from my computer, but no one else can run it successfully. I've changed ...
3
votes
1answer
47 views

Check for feature existence before extract by attribute Arc GIS Model Builder

I have a model that runs through a series of Rasters in a folder and extracts individual crops as layers cyclically. The problem is that if the crop is not grown in a particular state, the model ...
1
vote
1answer
30 views

How to calculate a new field to represent the sum of the values in an existing field in Arcmap

I need a way of calculating the total sum of the values in an existing field and displaying this value in the corresponding cells of another field. In other words, I want this second field to display ...
0
votes
0answers
29 views

Problem with Raster Calculator in Model Builder

I have created a model which repeatedly uses the raster calculator. My problem is that unlike that of the other tools, the output name of the raster calculator does not change. This means that I can ...
1
vote
1answer
16 views

Options for publishing model with custom script containing call to .exe on GP server

So I have a ModelBuilder model that uses a custom python script, and within the script there is a call to a command line interface (CLI) executable. The model runs fine on my local desktop, but when I ...
3
votes
1answer
70 views

How do I iterate a model over multiple fields using ModelBuilder?

I have built a model to interpolate air pollution from 40 recording stations using IDW. The results are then exported to an average for census divisions. I need to repeat this process hundreds of ...
3
votes
3answers
100 views

Iterating feature class output file names using ModelBuilder?

I am trying to iterate a series of feature classes (polygons) in model builder to convert a series of polygons to rasters, however, I am having an issue with the output file names. After inserting ...
0
votes
1answer
46 views

Using Spatial join tool returning “Count” values in Model Builder in ArcGIS10

I want to replicate the manual Spatial join (R-click Join) using 'count' in Model Builder. I have 2 datasets: Historic Road Traffic Collisions (RTC) locations - Point feature (gdb) - 3,398 rows ...
1
vote
0answers
34 views

User input and passing variables with ModelBuilder

I have created three modelbuilder tools that must be run in sequence. After running each tool, the user must examine several shapefiles and potentially change the input parameters of the next tool. ...
1
vote
1answer
57 views

Using ModelBuilder to Iterate, Join & Export Feature Classes?

I am trying to make what I thought was a very simple batch processing tool, but I can't get the output to work properly. I would like the model to iterate through a geodatabase, join each feature ...
2
votes
4answers
104 views

Field Calculator Python Expression Issues

I'm pretty new to Python and this is my first post on this forum so I could use some help. I am currently attempting to run some code in the Field Calculator in a model in order to replace string ...
4
votes
2answers
37 views

Repeating steps based on different field using ModelBuilder?

I have built a model to interpolate air pollution from 40 recording stations using IDW. The results are then exported to an average for census divisions. I need to repeat this process hundreds ...
2
votes
0answers
36 views

Way to extract a specific feature class from a dataset in model builder?

I would like to be able to run a model that iterates through datasets and at one point extracts just a single point feature from within the dataset and save it in a different geodatabase. The problem ...
0
votes
1answer
37 views

Trying to use the “Iterate Datasets” tool with .dwg files

I'm trying to expand on a model created by a co-worker that uses the Point and Polyline CAD feature classes within a .dwg to perform a number of geoprocessing tasks. My goal is to be able to have the ...
1
vote
1answer
38 views

how to create a multipoint geometry in arcgis using python and arcPy library

I have specific points and I need to create multipoint geometries, in a model-builder python script, following an equation that provides me the new (x,y) points around my initial point. Is there any ...
2
votes
0answers
17 views

1-2 Pixel Gaps in NDVI raster function aligning with Mosaic Dataset footprint?

I am curious if anybody has seen a situation like this? Using Model Builder in ArcGIS 10.2.2, I: Create a FGDB > Create Mosaic Dataset > Add Rasters to Mosaic Dataset (800+ tiffs) > Edit Raster ...
2
votes
1answer
56 views

Model Builder Query by date

I've created a model that does several spatial joins based off of a lat/long in a table. In the table, I have a "Modified_date" which gives year, month, date, time. This model is set to run ...
1
vote
1answer
31 views

How to map a filename into fields of a geodatabase

I'm using ModelBuilder to append a number of shapefiles to a single geodatabase. The shape files are located in a folder SHP and the model is designed to iterate through SHP, appending each .shp to ...
1
vote
0answers
19 views

How do I truncate a fieldname in model builder using field iterator [closed]

I have about 9,000 tables with rather long fieldnames, I need to chop off part of the fieldname, so for instance I want to change 'GP_CodeA82010' to 'A82010'. I am doing this using field iterator ...
0
votes
1answer
26 views

Is there a method to determine the sources that are used in a model in ArcGIS?

I have a model that I have had to go through to model parameters in order to create a geoprocessing service. Is there a way to check all sources that are being used in the model via python? I am ...
1
vote
2answers
42 views

Calculating Bearing/Direction via Spatial Join?

I was just wondering if it was possible to calculate a bearing field via a spatial join? Basically I have needed in the past to calculate distances from one singular point (e.g a well) to a number of ...
1
vote
0answers
17 views

Python Script calling custom model failing during model execution

I have a python script that calls a model I built in model builder. If I run the model by itself it runs perfectly. If I call the model in the python script, the model errors in various locations. ...
1
vote
3answers
70 views

If/then Field Calculator

I have two fields in my model, the first is a spatial join return for the township, the second is a spatical join to a city. If there is not city, then the field is left blank. The column that has ...
2
votes
0answers
23 views

ArcGIS Model Builder - Loading Tab Reader Parameter

In our office, we got a large set of MapInfo TAB files, and are planning to migrate those data to ArcGIS GDB with the same symbology available in the TAB file. On a individual TAB file to GDB, we can ...
2
votes
0answers
50 views

Run a large model by calling it in a python script?

I've created a rather large model containing a sub-model that calculates the volume of water basins(playas) in a relatively flat area of Texas. The volume is taken from one foot slices of each each ...
1
vote
1answer
50 views

ERROR 000728: Field Code does not exist in ModelBulider using iteration

The first join in the model is working, but after this the names of the fields are changing in the name of the Shape and a number . Therefore get the ERROR 000728. So I like to ask you if there is ...
2
votes
1answer
50 views

ArcGIS Model Builder perform split operation on each selected feature and delete identical on collection

I have created a model to select parcels and create segments for each parcel. If two parcels are sharing the same segment, delete duplicate. My model is attached. My question is: Before appending or ...
2
votes
1answer
53 views

Why were Series variables of ModelBuilder removed at ArcGIS 10.0?

I've read a number of posts regarding the sequential batch processing of a model in ArcGIS. In particular this one, because I'm having the exact same issue. Recently, I found an old 9.3 help page ...
0
votes
1answer
63 views

Summarizing at Modelbuilder

I like to summarize of the ID-Field with the ModelBulider because in the end I have to build a tool. The problem I have is that the field “GRIDCODE” should get in the new table comma separate. So that ...
5
votes
0answers
86 views

Why does a z factor of 1 get turned into 0.999998 in my output

Just built a model that uses 3D Analyst - Surface Volume. I am trying to use a z factor of 1. Whenever I run the model my output table shows that a Z factor of 0.999998 was used instead of 1. I ...