A proprietary Unix-based operating system created by Apple Inc.

learn more… | top users | synonyms

2
votes
2answers
56 views

Install GDAL frameworks and QGIS — redundant?

Just wondering if GDAL tools are actually already within QGIS -- was it redundant for me to install them on my OS X Yosemite independently? Recently I used GDAL tools to explode .kml data for use ...
1
vote
0answers
28 views

python-mapscript on OSX Yosemite

I am keen to try out the mapserver export plugin from QGIS 2.6 This needs python-mapscript which comes from the mapserver package. This can be downloaded from ...
1
vote
1answer
302 views

Syncing Google Earth My Places data in OS X

Since Google hasn't implemented a sync service for Google Earth's My Places data, I'm trying to make this work manually between my home and work computers, one OS X the other Windows. Windows side ...
2
votes
2answers
699 views

Geoserver startup page

I have been looking for this for a while and can't find the answer: when you startup geoserver a webpage is opened at localhost:8080/geoserver/web but if you have changed your port config in jetty.xml ...
1
vote
1answer
49 views

setting SAGA folder for QGIS with OS X macports install

I am trying to get the toolbox to work in QGIS 2.6, but I keep getting an error message that SAGA is not properly configured. After much digging, I finally found I can set the SAGA folder in ...
2
votes
2answers
147 views

GDAL in C++: Reading a ShapeFile

I am trying to use the GDAL Lib to read a ShapeFile (.shp). I followed the instructions of http://www.gdal.org/ogr_apitut.html - But it doesn't work! #include <gdal_priv.h> #include ...
1
vote
1answer
358 views

QGIS loads PostGIS layers but DBManager can't connect

DB Manager can't connect to PostgreSQL, but "Add PostGIS Layer" can. My eventual goal is to save created layers to PostGIS. I assume I can do this using the DBManager Tool. I can alternatively use ...
1
vote
1answer
58 views

QGIS Semi-automatic classification plugin install error on OS X 10.10: matplotlib.backends.backend_qt4agg

I have tried repeatedly to install the QGIS Semi-automatic classification plugin via both (1) Plugins > Install & Manage Plugins and (2) manually based on other comments I found here, but I ...
0
votes
0answers
92 views

qgis python error mac yosemite

This problem started when I installed GRASS. I changed one environment variable and then I tried fixing, then I uninstalled egis, grass gdal, then I upgraded to Yosemite, and I still have the ...
0
votes
0answers
43 views

QGIS 2.6: Globo & Qgis2threejs on Mac OSX Yosemite

I use QGIS 2.6 on my Mac with OsX Yosemite, but plugins globo and qgis2threejs don't run. Can someone help me?
2
votes
1answer
356 views

pyQgis in stand alone script, vector loading error

I am trying to use the Qgis functions in a stand alone Python script. I m running Mountain Lion OS, 2.7 Python & the Qgis 2.0.1 Dufour. My main problem is that I cannot get started - I cannot ...
1
vote
0answers
61 views

QGIS Mac OSX version cannot batch write output files after rasterization

Happy new year everyone, I have been trying to batch rasterize a series of .shp files using QGIS for Mac OS X, and keep coming up against a strange problem. I am using the QGIS 2.6.1 user interface, ...
0
votes
3answers
490 views

Unable to connect to PostGIS databases after Mac OS X Yosemite upgrade

I upgraded to Mac OS 10.10 Yosemite and am unable to connect to PostGIS databases (PostgreSQL version 9.3 and PostGIS installed from KyngChaos). Typing psql my_database returns this message: psql: ...
3
votes
1answer
1k views

GDAL ECW Support on OSX

I have a large number of ECW format raster images and would like to use with GDAL (and ultimately in QGIS) on Mac OSX. Having seen that there is no official ESRI support for the ECW library on any ...
2
votes
1answer
63 views

How to convert a RGB tiff into pseudocolor with GDAL etc?

In QGIS I have made a singleband pseudocolor image out of one of the bands from a RGB GeoTiff. I choose one band and then make a linear color interpolation (see attached image). I now want to do ...
2
votes
2answers
119 views

Calling QGIS from MacOS python

I would like to import qgis.core and utils from my own copy of python. I do have PYQT4 installed there. I'd be happy to add to my PYTHONPATH or sys.path.append in my code, where do the qgis modules ...
0
votes
0answers
36 views

QGIS 2.6 graphical modeller error Mac Osx

After I installed Qgis 2.6 the processing graphical modeler seems not to work correctly. From the toolbox the built in algorythms work correctly, but from the graphical modeler not. From the toolbox ...
14
votes
5answers
4k views

Using ArcGIS 10 on a virtual machine with OSX

I'm currently using ArcGIS 10 on a Windows 7 64 bit Macbook Pro (2.53 Ghz and 8GB of RAM) using VMWare. However, when I am using ArcGIS I find it quite slow even with Windows 7 (64-bit) optimized for ...
1
vote
0answers
32 views

Mobile Safari and ArcGIS JavaScript API Errors

So in creating an application that uses the LaywerSwipe widget the application displays fine on iOS but I am unable to move the scope or slider. I get the following errors from init.js : It keeps ...
0
votes
1answer
45 views

Exception error when enabling workspace specific services in Geoserver 2.5 OpenGeo suite

When I try and enable a workspace specific WMS in the bundled GeoServer app form boundless I get the following error. java.lang.reflect.InvocationTargetException This is running on OSX 10.9.5 with ...
2
votes
0answers
122 views

Unable to add shapefiles via drag and drop - QGIS 2.4 OSx

I have a clean install of OSx Yosemite Beta 5, with homebrew install of QGIS 2.4 and all its basic dependencies. -QGIS version 2.4.0-Chugiak -QGIS code revision exported -Compiled against ...
1
vote
1answer
465 views

Setting up PostGIS: Postgres can't see the PostGIS extensions?

I've just installed Postgres 9.3.4 and PostGIS 2.1 on OSX Mavericks using the very latest versions of the KyngChaos libraries. This is a new machine, and I deliberately haven't installed Postgres ...
1
vote
0answers
137 views

Virtual machine or bootcamp for ArcGIS

I want to use ArcGIS for viewshed analysis on a Mac. Would virtual machine software such as Parallels or VMware Fusion be powerful enough for viewshed analysis compared with bootcamp?
1
vote
1answer
164 views

How to install postgis extension using an existent version on postgresql on OSX 10.9.4

I'm trying to install postgis using my existent version of postgresql. I tried doing: brew install postgis. But I'm getting the following error trying run create extension postgis; query ...
0
votes
1answer
290 views

OpenLayers does not appear in the QGIS plugin menu [duplicate]

I have installed the OpenLayers QGIS plugin, which features external map layers in QGIS. Quoting the official page: OpenStreetMap, Google Maps, Bing Maps layers and more In QGIS, it seems that ...
2
votes
1answer
116 views

OS X Preview unable to open GeoTiff due to error 259?

I'm currently working on a GeoTiff writer which writes GeoTiffs to the file system. I can write the GeoTiff, dump it with tiffdump, listgeo and gdalinfo and my own GeoTiff reader can read it with no ...
10
votes
5answers
4k views

installing GEOS, PROJ, GDAL/OGR into a python virtualenv on Mac OS X

I am trying to setup an isolated python virtualenv to work on GIS projects on my Mac OS X. Sounds like I will need to install the GEOS, PROJ, GDAL/OGR from the kyngchaos site here ...
1
vote
0answers
26 views

Problem Loading Plug-Ins in QGIS 2.2 on Mac

I'm trying to load the 'processing' module in QGIS (2.2.0-Valmiera on Mac OSX 10.8). However, this module and others (e.g. GarminaCustomMap) re failing to load with a message: ImportError: No ...
1
vote
1answer
66 views

How can I fix a broken gdal-tools plugin in QGIS?

I have QGIS installed on my 2011 macbook pro and I recently upgraded my OS to 10.9. After the upgrade, I noticed that QGIS gives me this error (see attachment 1) saying that the plugin is not ...
3
votes
1answer
697 views

Trying to install QGIS - missing 1.11 GDAL

I just spent the last n hours working on this, and still haven't gotten anywhere, so I'll throw it to the group. I see that other people have asked about this here and here, and I'd be happy to take ...
1
vote
2answers
589 views

OSX 10.9 + QGIS 2.0.1 - Missing osgeo module

Running the following: QGIS 2.0.1 (via Kyngchaos) OSX 10.9 GDAL/OGR 1.10.1 (via Homebrew). Recently, I've become unable to use the OpenLayers plugin, which is complaining that I'm missing the ...
1
vote
1answer
60 views

Mac os x 10.9.4 run geoserver binary in background

I have had problems running Geoserver 2.5.2 as a WAR package in Tomcat 7 on OS X 10.9. Tomcat runs but when I add Geoserver, Tomcat crashes. This happened after the OS X 10.9.4 update. Well, I didn't ...
1
vote
1answer
146 views

mmqgis plugin not showing up in plugin dropdown menu

I have installed the plugin from the plugin dialog box, but I am unable to figure out exactly how to run the plugin.
1
vote
1answer
50 views

What causes this error when loading plugin

After installing pyspatialite on my Mac two plugins fail to load with this error:: This plugin is broken invalid literal for int() with base 10: '2-spatialite' I am fairly sure that the offending ...
3
votes
3answers
2k views

QGIS 2 Python error on Mac OSX

Have just installed newly released QGIS 2.0. I installed the gdal package available at the official kyngchaos site. It seems to run ok, but when the program loads up I get a lengthy error message ...
1
vote
1answer
137 views

Can not install geoserver 2.5.1 on Mac OSX 10.9.3

I am trying to install geoserver 2.5.1 on my Mac (OSX 10.9.3) but i am getting the error “GeoServer.app” is damaged and can’t be opened. You should move it to the Trash. Can you pls help?
0
votes
1answer
781 views

Missing QGIS raster menu tools - '“osgeo [python-gdal]” module is missing'

I recently had to reinstall QGIS (version 2.2.0-9) and the raster menu is missing its tools. I understand that the GdalTools plugin must be installed and enabled. I have already installed the GDal ...
0
votes
0answers
66 views

Installing PostGis / GeoServer in Mac OSX

On a Mac Server I am working to setup the ports. My understanding is that there is a system instance of PostgreSQL running and then a geoserver instance. Version is 10.7.5. I need help approaching ...
1
vote
1answer
200 views

Unexpected output when using gdal_rasterize

Ok, I used the following code for converting my layer into raster format but I get a tif file that is completely black or white... from osgeo import gdal, ogr # Define pixel_size and NoData value ...
0
votes
0answers
78 views

geoserver installation instructions for osx

I recently setup Geoserver on my MacBook (OS X Mavericks) in anticipation of loading it onto an eventual OS X Mavericks Server machine. While installing on my macbook I found a nice blog with step by ...
0
votes
1answer
148 views

Threejs “Failed to generate a dem file using gdalwarp. gdalwarp is not installed.”

I am trying to test out the new threejs plugin for QGis and have come across this error. Failed to generate a dem file using gdalwarp. gdalwarp is not installed. I have installed the latest ...
0
votes
2answers
596 views

How to uninstall and re-install a stable version?

I just posted about a DEM problem after installing the latest nightly build...now I am completely screwed. I uninstalled the latest nightly build and associated files, hoping to resort back to the ...
0
votes
1answer
222 views

Error in QGIS 2.2 Raster Merge Tool in OS X

I'm having this strange error in QGIS 2.2 for OS X while trying to run the raster merge tool (in the Raster - Miscellaneous - Merge). This happens just by clicking on the "Select" button to choose the ...
1
vote
1answer
135 views

Is it possible to run qgis through python?

I need to build an app to analyze some raster layers in qgis. I thought it was possible to just write code in python (2.7.6) (IDLE) and let it automatically open QGIS, load some layers, do a distance ...
0
votes
1answer
154 views

How to create graduated Pie Charts from CSV in QGIS 2.0.1 Defour?

I am trying to make a map in QGIS 2.0.1 ( running on my Mac OS X Maveriks) with the proportionally sized (graduated) pie-charts. I have started with the csv conversion to kml just to place my sample ...
1
vote
1answer
392 views

Is it necessary/advisable to uninstall QGIS 1.8 first before installing 2.0?

Who has installed QGIS 2.0 on Mac OSX 10.6.8 (Snow Leopard)? Is it necessary/advisable to uninstall QGIS 1.8 first? Have you seen any problems importing QGIS 1.8 projects to 2.0?
0
votes
1answer
147 views

QGIS toolbox not functional on OSX

Has anybody had any luck getting the tools in the QGIS2 Toolbox to run? So far I have tried SAGA and TauDEM but both throw up errors. I eventually got TauDEM to produce something from the D8 tool by ...
0
votes
1answer
400 views

Need help installing QGIS 2.0 Need GDAL then SQLite3 3.7.16

OSX 10.7.5 I need help installing QGIS 2.0 It says I then need GDAL. When I try to install GDAL it says SQLite3 3.7.16 or newer framework is required. I can't find SQLite3 3.7.16.
0
votes
1answer
127 views

OS X Python vs QGIS Python

I'm wondering why after I updated to Python 2.7.6 on my OS X 10.9 Mac, QGIS Python console says that it is still running the old 2.7.5 version. This is not affecting my work but I'm curious about why ...
0
votes
2answers
519 views

QGIS 2.0 won't open on OSX Mavericks [duplicate]

I successfully installed QGIS 2.0 on my macbook running OSX Mavericks, but when I attempt to open the program, I get the following message: "QGIS cannot be opened because of a problem. Check with the ...