A small software application that extends the functionality of a Web browser.

learn more… | top users | synonyms

2
votes
2answers
455 views

QGIS 1.7.3 and pyqt4 version mismatch

I installed QGIS 1.7.3 using OSGeo4W installer.I have python 2.7 and pyqt4-py2.7 installed on my system.My system paths are: ...
5
votes
3answers
1k views

Add 3rd party repositories button not in version 1.8.0 Lisboa

The available manuals and other help sources all refer to the 'Add 3rd Party Repositories button' in Plugins>Fetch Python Plugins and then the Repositories Tab. My problem is that the installation of ...
2
votes
1answer
161 views

QGis - Plugin libraries

I need to develop a couple of qgis-plugins. I made some promising first steps and completed a few easy plugins. Now its time to move to more complex plugins which need to import several tool-classes I ...
2
votes
1answer
210 views

How can i include program form (created in Designer ) to my QGIS plugin?

How can I include a form created in Designer in my QGIS plugin? And how to get controls values (textbox,label,etc)?
2
votes
1answer
1k views

How can I add button to the QGIS toolbox or create my own toolbox?

I want to create a button and add it to the QGIS toolbox or alternatively create my own toolbox and add the button here. A plugin should be started when the user clicks the button.
7
votes
4answers
2k views

How to close watermarks window in QGIS Openlayers plugin?

I'm using Quantum GIS Ver. 1.7.4. I have upgraded openlayers plugin 0.7 to 0.9. However when I open google satellite, a watermarks/copyright dialog box "Data Peta@2012 ..." appear in the middle of the ...
7
votes
2answers
2k views

Cannot add plugins to QGIS on Ubuntu 11.10 Oneric

I have installed Qgis on ubuntu. it works fine but I am not getting option to add new plugins only option to manage plugins is available. Please help
2
votes
1answer
777 views

How to use SQLite db with QGIS plugin?

Hi I would like to use SQLite for storing some information in my plugin for QGIS. I have a problem: if I put the db let say test.db among the resources as file, after compilied the resorce.qrc file, ...
2
votes
2answers
539 views

How to set up a plugin repository for QGIS?

I am working with python plugins for QGIS.I developed my plugin and created .zip file including my .ui,.py and resources files.In order to incooperate this plugin into QGIS i created .xml file ...
1
vote
0answers
78 views

Is there a plugin that collects and allows you to just “turn on” open layers?

I'm thinking on a similar approach as gapminder.org, only that this plugin would contain GIS-data, not only statistics. I'm specifically interested in if there is a plugin like this for QGIS. If ...
3
votes
1answer
170 views

Why is the plugin list so short?

i have installed QGIS with GRASS and QDAL complete... I followed the instructions for additional QDAL configuration (adding usr/bin to the QDAL path). When i try to "fetch plugins" my list is short ...
1
vote
2answers
527 views

How to install Sourcepole zonal statistics

I am trying to install the zonal statistics tool created/supplied by sourcepole from http://www.sourcepole.com/2010/12/16/zonal-statistics-plugin-for-qgis. The instructions area as follows: **To ...
0
votes
0answers
250 views

Missing QGIS python plugin database connectors

I am working with python plugins for QGIS.I developed my plugin and inorder to incooperate the same into QGIS i copied the folder in C:\Documents and Settings\comp90\.qgis\python\plugins I opened ...
2
votes
0answers
135 views

How to change the QGIS help dialog?

I am working with python plugins for QGIS. I am done with my one of my .py file using python 2.5 and pyqt4. It is just help file for QGIS, which i changed. I wanted to incorporate the same in QGIS. I ...
1
vote
1answer
6k views

Python :ImportError: DLL load failed: The specified module could not be found

I am working on Python plugins for QGIS. I set my variables as PATH :=C:\OSGeo4W\apps\qgis;%PATH% PYTHONPATH:=C:\OSGeo4W\apps\qgis\python But when I try to run my .py file in IDLE I get an error ...
2
votes
1answer
612 views

QGIS 1.7.1 and PyQT4 conflict: what am I doing wrong?

I've just started playing with QGIS with a view to eventually developing a few simple plugins in Python. I downloaded QGIS 1.7.1 for Windows and started working through these workshop notes. If I've ...