A small software application that extends the functionality of a Web browser.

learn more… | top users | synonyms

0
votes
2answers
110 views

cadtool and spline plugins not working

Am trying to edit a line shapefile using a spline tool in QGIS 2.4.0 .Its drawing but the ok button is inactive. what could be the problem? Generally am trying to create a curved line.
1
vote
1answer
73 views

gHydraulic plugin for QGIS 2.8 make EPANET Model Type Error

I've set up my water network layers to create an EPANET model using the gHydraulics plugin for QGIS 2.8: pipes, junctions, and a reservoir. The pipes have unique IDs, with their corresponding ...
6
votes
1answer
2k views

How can I add button to the QGIS toolbar or create my own toolbar?

I want to create a button and add it to the QGIS toolbar or alternatively create my own toolbar and add the button here. A plugin should be started when the user clicks the button.
1
vote
0answers
24 views

How to create displacement vectors in QGIS using GPS points with different dates?

Is there a way to calculate and visualize displacement vectors in QGIS ? I have DGPS points taken at the same place (ground control points), but their position moved over time as they are located on a ...
5
votes
1answer
210 views

How to create a python plugin in QGIS 2.4.0?

While I am learning to create a python plugin in QGIS 2.4.0, I have followed the proceedure expalined in ...
1
vote
1answer
98 views

How to fix the broken MGRS Tools plugin?

Here the case: i have a plugin installed in .qgis2/python/plugins that remains broken and i cant make it work. I've found it here https://github.com/volaya/mgrs-tools. If any of you know the way to ...
1
vote
1answer
307 views

How can I get the plugin manager “get more” icon?

I am fairly new to QGIS and i was looking to add more plugins to the core provided in version 2.0 I read the user manual provided by QGIS and found out that there should be an icon "get more" ...
4
votes
1answer
521 views

GIS applications and noSQL solutions

I'm a bit lost about NoSQL and applications using GIS. My aim, to sum it up quickly, is to store geospatial object into a MongoDB database and display them into a map via OpenLayers. Is it possible ...
1
vote
1answer
27 views

How can a QGIS user plugin reflect the events of UI?

I am developing a plugin for QGIS 2.8 which uses the data of the active layer. It has a dockable window. When the user changes the active layer, the contents of the plugin window's widgets must ...
1
vote
0answers
90 views

Installing PostGIS Layer Viewer for pgAdmin III

I have difficulties installing pgAdmin's plugin PostGIS Layer Viewer. The official repository on GitHub gives this Web site for install procedure, then the former site gives this Web site for ...
0
votes
0answers
53 views

QGIS expression: select from <layer> possible?

I have a project file with many nested layers and would like to query certain layers without having to click on them first. The expression tool however requires me to select the layer I want to query. ...
1
vote
0answers
16 views

Is it possible to enter start/stop points non-interactively in Road Graph plugin?

I need to find the shortest paths in a network of roads for many pairs of start/stop points. The Road Graph plugin in qgis allows me to interactively select a starting and ending point on a map, but ...
1
vote
1answer
75 views

QGIS/OpenLayers - How to add a “labels-only” reference layer (basemap focused on labels)?

In ArcGIS you can add a "reference basemap" which features labels for key locations as in: http://www.arcgis.com/home/item.html?id=8b3d38c0819547faa83f7b7aca80bd76 however, in QGIS, I cant figure ...
2
votes
2answers
77 views

Is it possible to set up a local QGIS Plugin repository?

I've developed a couple of custom QGIS Plugins for use by our office. I can't post them to the official QGIS Plugins repository as they reference/utilize sensitive data on our own servers. For ...
0
votes
0answers
31 views

qgis action html

I'm a newbie in QGIS and python. I made a QGIS Action with parameters [% attributename %] that works fine. import urllib2 req = ...
0
votes
0answers
80 views

Updating attribute data of a layer in MapWindow GIS plugin using C#

I'm creating a plugin to MapWindow GIS (using C#) with a map and a database. I had success in getting information from the map and showing it. But I couldn't update new data using a form coded with ...
1
vote
2answers
136 views

Flowmapper plugin will not load on QGIS Brighton

Iyi gunler Cem Bey, I have just installed QGIS 2.6 (Brighton) on my PC (Bootcamp) running Windows 7 and would like to try out FlowMapper. However after I have loaded it I received the following error: ...
0
votes
1answer
136 views

QT GUI make for QGIS plugin

I was used to develop qgis2leaf on a Ubuntu machine and after each change on the PyQT dialog I've used "make" in the terminal to "compile" the GUI. How does this work on a Windows machine?
3
votes
0answers
334 views

Connect to QGIS 2.6 Python Plugin function via button on custom feature form

I am trying to connect to a QGIS 2.6 Python plugin function via a custom feature form button. On my feature form, I'm attempting to do a few things : enable the updateButton only if the ...
3
votes
2answers
60 views

Send signal when attributes modified - QGIS 2.6

For a QGIS 2.6 python plugin, I am trying to send a signal when an attribute value is changed (values for an existing feature are updated or added and the attribute form dialog is accepted). This ...
1
vote
0answers
156 views

Custom QGIS 2.6 map tool - mouse click and release issue

I have create a custom map tool for QGIS 2.6, implementing a canvasReleaseEvent and canvasPressEvent. I can't though get the signals to work on one single mouseclick (I have to click twice). My map ...
1
vote
1answer
61 views

QGIS 2.6 : Programmatically setting key value pairs for ValueMap widget

Using QGIS 2.6 and Python 2.7 on Windows 7, I am trying to programmatically insert key value pairs into a ValueMap widget via a csv file. Issue is that some of the values are properly inserted and ...
2
votes
1answer
166 views

GRASS plugin absent from QGIS 2.6 OSGeo4W install

I've just installed QGIS 2.6 Brighton using the OSGeo4W installation. The GRASS toolbox plugin has not, however installed as it had been with previous versions. Before, I was able to access the GRASS ...
2
votes
0answers
32 views

What should i do if the Repository tab “Status” was indicating “unavailable”.? (using proxy server)

In the plug in Repository tab. The "Status" was indicating "unavailable". I tried "hawkens" suggestion about the HTTPproxy thing but it didn't work (the network that I am using is a proxy server). ...
0
votes
0answers
16 views

Ushahidi WMS plugin legend

Does anyone know how to include legend in WMS plugin of Ushahidi?
1
vote
1answer
44 views

Route and distance measuring

I'm looking for a plugin that can make a route from given GPS points and then calculate the distance of this route. I'm going to create GPS points and import it to Qgis as a GPX file. I know I can ...
0
votes
1answer
57 views

JOSM plugin not working

I have been trying to use a PicLayer plugin in the JOSM editor, however after installing the plugin it would never appear in the top menu next to Windows, Audio, Help dropdowns (at least that's where ...
2
votes
1answer
107 views

Listing installed QGIS plugins via PyQGIS

Can you please tell me how I can programmatically (or from the console) access the loaded plugin list? I tried: QgsProviderRegistry.pluginList() but got: TypeError: ...
1
vote
0answers
190 views

Trying to use OS Translator plugin and cant find ogr2ogr.exe

I have installed the OS Translator plugin from the Faunalia Repository but when I try to use the plugin I get a "Can't find ogr2ogr[.exe], can't continue" error message. I have tried reinstalling the ...
8
votes
4answers
2k views

Cannot add plugins to QGIS on Ubuntu 11.10 Oneric

I have installed Qgis on ubuntu. it works fine but I am not getting option to add new plugins only option to manage plugins is available. Please help
0
votes
1answer
110 views

Missing Plugins in QGIS 2.6

Do I need to re-install plugins after upgrading to 2.6? Not all the plugins I had on QGIS 2.4 appear on 2.6.
0
votes
1answer
61 views

Is there a QGIS plugin that can transform tabular data to graph?

I have a CSV file with water level measurments in a well, taken once a year for 40 years. Is there a way to show this data as a graph (x axis being the date and y axis the water level) in QGIS?
0
votes
0answers
278 views

Missing QGIS python plugin database connectors

I am working with python plugins for QGIS.I developed my plugin and inorder to incooperate the same into QGIS i copied the folder in C:\Documents and Settings\comp90\.qgis\python\plugins I opened ...
2
votes
0answers
269 views

Matplotlib error when installing Molusce or lifemapper in QGIS Brighton

I am installing plugins via the QGIS desktop internal interface, and have had twice now messages associated with matplotlib. The first error was for something called lifemapper and now for MOLUSCE. ...
2
votes
2answers
959 views

QGIS crashes when using dxf to shp converter

this is my first question on Stackexchange. I use a GPS to capture data in .dxf, manipulate it in a CAD program that I know how to use, then the dxf2shp converter (I think Python is mentioned) to let ...
2
votes
1answer
802 views

GeoJSON, circlemarkers using the Leaflet OverlappingMarkerSpiderfier plugin

I am wondering if I can use the Leaflet OverlappingMarkerSpiderfier plugin with my circlemarkers. I've loaded a GeoJSON file and added circlemarkers using; var gj = L.geoJson(route, { ...
1
vote
1answer
328 views

how to create a map with oneway flows using FlowMapper for QGIS

my plan is to create a map that shows the top 50 (by amount of passengers) international flights departing the United States (e.g. New York -> London, Honolulu -> Tokyo...). I want to use the plugin ...
0
votes
1answer
253 views

Flow mapper plugin failed

I want to create a desire line with the Flow Mapper plugin using QGIS version 2.1. After I did, it has failed. The data that I used is pictured below. There may be an error procedure I have used. Can ...
1
vote
1answer
95 views

Implementing python code in Whitebox spatial analysis tool

1.I want to implement this python code wd = pluginHost.getWorkingDirectory(C:\xampp\htdocs\learn\doit) flowPointer = wd + "d8flowpointer.dep" outputFile = wd + "manjflowaccscript.dep" outputType ...
1
vote
2answers
71 views

Creating a plugin tutorial

I am looking for a tutorial of how to create a plugin for QGIS. I want a tutorial that: Explains about the latest version of QGIS Working in windows environment. adequate for absolute beginners and ...
0
votes
0answers
26 views

Is there a Leaflet plugin to manually correct geocoded locations?

When geo coding an address, I get the coordinates on the map. However, sometimes the user wants to correct the location if it's inexact or wrong. Is there a Leaflet plugin that provides this ...
2
votes
1answer
108 views

QGIS Plugin development version compatibility

At this time latest QGIS version is 2.4 , QT Version is 5.3.1 and PyQT5.Are these version compatible with each other ? Once QGIS 2.4 is installed , how does one know which version of QT and PyQT(and ...
1
vote
1answer
164 views

using DotSpatial plugins in my app

I am new with dotspatial and I want to enable and use plugins on my own. I have a custom button that I want to add, it's a click handle measure function and shows the results in a text label. Is ...
0
votes
1answer
57 views

Trouble installing PostGIS PlugIn for OpenJump

I’m trying to install PostGISPlugin version 1.52 in OpenJUMP 1.7.1 release 4004. I moved the JAR file into my installation’s lib/ext directory, but I’m not sure how to access the plugin-specific UI ...
2
votes
2answers
2k views

Is it possible to use WMTS in QGIS?

Is it possible to use WMTS e.g. by http://data.wien.gv.at in QGIS? ich möchte gerne daten der stadt wien als WMTS-Layer in qgis hinzuladen. ist das überhaupt möglich? ich bin kein profi und bitte ...
3
votes
1answer
71 views

Adding a new Tool (Plugin) to Whitebox GAT - anyone else have trouble?

I am in the midst of adding a new tool to Whitebox GAT, which is merely copy of a current tool with some minor modifications to suppress messages output by the tool upon completion. This tool's ...
21
votes
3answers
4k views

What do I need to know, to develop a plugin for QGIS?

I wish to develop a simple plugin for QGIS, which will open some data, and some specific processing. I have quite a it of development experience with ESRI's Arcojects, but haven't developed with QGIS ...
1
vote
1answer
260 views

Problem with CadTools plugin in QGIS 2.2

I've just downloaded the CadTools plugin from QGIS Plugins page (can't do this through QGIS itself as I'm behind a proxy) and after installation I keep getting an error saying that it "Couldn't load ...
3
votes
1answer
105 views

Referencing Qt UIs external to plugin with python

I'm developing a plugin that sets up a working environment for a user: loading layers (from db), applying styles and several custom designed (Qt) UI files etc. Primary user interaction is in the ...
4
votes
1answer
213 views

Installing ArcSDE engine plugin for Eclipse?

I'm looking for the following jars for the ArcSDE API: jsde_sdk.jar jpe_sdk.jar concurrent.jar icu4_3_2.jar thanks to this answer I've found that they can be gotten installing the ArcSDE engine ...